[Usaco2015 Feb]Censoring

A. Censoring

题目描述

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).
FJ has taken all of the text from the magazine to create the string S of length at most 10510^510?5?? characters. He has a list of censored words t1t_1t?1?? ... tNt_Nt?N??
that he wishes to delete from S. To do so Farmer John finds the
earliest occurrence of a censored word in S (having the earliest start
index) and removes that instance of the word from S. He then repeats the
process again, deleting the earliest occurrence of a censored word from
S, repeating until there are no more occurrences of censored words in
S. Note that the deletion of one censored word might create a new
occurrence of a censored word that didn‘t exist before.
Farmer John
notes that the censored words have the property that no censored word
appears as a substring of another censored word. In particular this
means the censored word with earliest index in S is uniquely
defined.Please help FJ determine the final contents of S after censoring
is complete.
FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10510^510?5??的字符串S。他有一个包含n个单词的列表,列表里的n个单词记为t1t_1t?1??...tNt_Nt?N??。他希望从S中删除这些单词。
FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词
FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的
请帮助FJ完成这些操作并输出最后的S

输入格式

The first line will contain S.
The second line will contain N, the number of censored words.
The next N lines contain the strings t1t_1t?1?? ... tNt_Nt?N??.
Each string will contain lower-case alphabet characters (in the range
a..z), and the combined lengths of all these strings will be at most 10510^510?5??.
第一行包含一个字符串S
第二行包含一个整数N N<2000
接下来的N行,每行包含一个字符串,第i行的字符串是tit_it?i??

输出格式

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
一行,输出操作后的S

样例

样例输入

begintheescapexecutionatthebreakofdawn
2
escape
execution

样例输出

beginthatthebreakofdawn

AC自动机+栈,和之前kmp一样,不过这个是多模式串用到AC自动机。然而标准的AC自动机会TLE,所以我又写了一个trie图。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<time.h>
using namespace std;
struct trie
{
    int count;
    trie *nxt[26],*fail;
    trie()
    {
        count=0;
        fail=NULL;
        for(int i=0;i<26;i++)nxt[i]=NULL;
    }
}*q[2000000],*root=new trie();
int head,tail;

char str[100010];
char key[100010];
int n;
char stack[100010];
trie *ff[100010];
int top;

void insert(char s[],trie *root)
{
    int len=strlen(s);
    trie *p=root;
    int i=0,index;
    while(s[i])
    {
        index=s[i]-‘a‘;
        if(p->nxt[index]==NULL)p->nxt[index]=new trie();
        p=p->nxt[index];
        i++;
    }
    p->count=len;
}
void build_ac(trie *root)
{
    q[++tail]=root;
    while(head!=tail)
    {
        trie *now=q[++head];
        for(int i=0;i<26;++i)
        {
            if(now->nxt[i])
            {
                if(now==root) now->nxt[i]->fail=now;
                else now->nxt[i]->fail=now->fail->nxt[i];
                q[++tail]=now->nxt[i];
            }
            else
            {
                if(now==root) now->nxt[i]=now;
                else now->nxt[i]=now->fail->nxt[i];
            }
        }
    }
}
inline int read()
{
    int s=0;char a=getchar();
    while(a<‘0‘||a>‘9‘)a=getchar();
    while(a>=‘0‘&&a<=‘9‘){s=s*10+a-‘0‘;a=getchar();}
    return s;
}
int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("data14.in","r",stdin);
//    freopen("cen.out","w",stdout);

    scanf("%s",str);
    int len=strlen(str);
    n=read();
    for(int i=1;i<=n;i++)
    {
        scanf("%s",key);
        insert(key,root);
    }
    build_ac(root);

    int index;
    trie *p=root;
    trie *temp=NULL;
    for(int i=0;i<len;i++)
    {
        stack[++top]=str[i];
        index=str[i]-‘a‘;
        ff[top]=p;
        p=p->nxt[index];
        if(p==NULL)p=root;
        if(p->count)
        {
            top-=p->count;
            p=ff[top+1];
        }

    }
    for(int i=1;i<=top;i++)
        putchar(stack[i]);
    return 0;
}

原文地址:https://www.cnblogs.com/Al-Ca/p/11025322.html

时间: 2024-10-09 05:44:29

[Usaco2015 Feb]Censoring的相关文章

bzoj3942: [Usaco2015 Feb]Censoring

AC自动机.嗯bzoj3940弱化版.水过去了(跑的慢啊QAQ.想了想可以用hash写.挖坑 #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #include<queue> using namespace std; #define rep(i,s,t) for(int i=s;i<=t;i++) #define clr(x,c) memset

BZOJ 3942: [Usaco2015 Feb]Censoring

3942: [Usaco2015 Feb]Censoring Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 404  Solved: 221[Submit][Status][Discuss] Description Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material

bzoj 3940: [Usaco2015 Feb]Censoring -- AC自动机

3940: [Usaco2015 Feb]Censoring Time Limit: 10 Sec  Memory Limit: 128 MB Description Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during

Bzoj3940 [Usaco2015 Feb]Censoring

Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 391  Solved: 183 Description Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking

【bzoj3940】[Usaco2015 Feb]Censoring

[题目描述] FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S.他有一个包含n个单词的列表,列表里的n个单词 记为t_1...t_N.他希望从S中删除这些单词. FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词.他重复这个操作直到S中 没有列表里的单词为止.注意删除一个单词后可能会导致S中出现另一个列表中的单词 FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是

BZOJ 3942 Usaco2015 Feb Censoring KMP算法

题目大意:给定两个串A和B,要求将A中删掉所有的B后输出 为何BC群刚有人问完我这题的[C++语法基础题]版之后就出了个KMP版的= = 维护一个栈,将A中的字符依次加进去,一旦A的栈顶出现了B就弹栈 用KMP算法来加速这个过程即可 #include <cstdio> #include <cstring> #include <iostream> #include <algorithm> #define M 1001001 using namespace st

bzoj3943[Usaco2015 Feb]SuperBull*

bzoj3943[Usaco2015 Feb]SuperBull 题意: n头牛进行锦标赛,每场比赛的好看程度是两头牛的编号异或和,并总有一方被淘汰.求安排比赛(可以决定比赛胜负)可以得到的最大总好看程度是多少.n≤2000 题解: 先求出牛两两之间的异或和,然后发现可以把比赛看做连边,且共有n-1场比赛,所以求最大生成树就行了.神犇们用的都是Prim,蒟蒻不会,用Kruscal结果时间排倒数. 代码: 1 #include <cstdio> 2 #include <cstring>

[bzoj3943][Usaco2015 Feb]SuperBull_Kruskal

SuperBull bzoj-3943 Usaco-2015 Feb 题目大意:贝西和她的朋友们在参加一年一度的“犇”(足)球锦标赛.FJ的任务是让这场锦标赛尽可能地好看.一共有N支球队参加这场比赛,每支球队都有一个特有的取值在1-230-1之间的整数编号(即:所有球队编号各不相同).“犇”锦标赛是一个淘汰赛制的比赛——每场比赛过后,FJ选择一支球队淘汰,淘汰了的球队将不能再参加比赛.锦标赛在只有一支球队留下的时候就结束了.FJ发现了一个神奇的规律:在任意一场比赛中,这场比赛的得分是参加比赛两队

【BZOJ3940】【Usaco2015 Feb】Censoring AC自动机

链接: #include <stdio.h> int main() { puts("转载请注明出处[vmurder]谢谢"); puts("网址:blog.csdn.net/vmurder/article/details/44960463"); } 题意: 题意同BZOJ3942,不过要删除的串是多串 http://blog.csdn.net/vmurder/article/details/44959895 题解: --思路一模一样,除了不用kmp用AC