poj1860——Currency Exchange(Eellman-Ford+权值为正的环路)

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0

1 2 1.00 1.00 1.00 1.00

2 3 1.10 1.00 1.10 1.00

Sample Output

YES

一些价值为s的货币经过一系列的交换,是否能增加价值。抽象出来就是一种货币代表一个节点,节点之间的权值就是交换规则后的价值,因为最后是求最初的货币,因此是一个回路,货币经过这个回路就回升值,说明这个回路是正值的。

运用bellman-ford算法,原始的是判断是否存在负值的环路并求出最短路,这里只要稍微改下松弛操作就可以判断是否存在正值的环路

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 105
#define mod 1000000007
using namespace std;
int n,m,s,e;
double v,dis[MAXN];
struct Node
{
    int beg,end;
    double r,c;
};
Node edge[MAXN<<1];
void add(int b,int en,double r,double c)
{
    edge[e].beg=b;
    edge[e].end=en;
    edge[e].r=r;
    edge[e].c=c;
    e++;
}
bool relax(int p)
{
    double t=(dis[edge[p].beg]-edge[p].c)*edge[p].r;
    if(dis[edge[p].end]<t)
    {
        dis[edge[p].end]=t;
        return true;
    }
    return false;
}
bool bellman()
{
    memset(dis,0,sizeof(dis));
    dis[s]=v;
    for(int i=1; i<n; ++i)
    {
        bool flag=false;
        for(int j=0; j<e; ++j)
        {
            if(relax(j))
                flag=true;
        }
        if(dis[s]>v)
            return true;
        if(!flag)
            return false;
    }
    for(int j=0; j<e; ++j)
        if(relax(j))
            return true;
    return false;
}
int main()
{
    e=0;
    int a,b;
    double rab,cab,rba,cba;
    scanf("%d%d%d%lf",&n,&m,&s,&v);
    for(int i=0; i<m; ++i)
    {
        scanf("%d%d%lf%lf%lf%lf",&a,&b,&rab,&cab,&rba,&cba);
        add(a,b,rab,cab);
        add(b,a,rba,cba);
    }
    if(bellman())
        printf("YES\n");
    else
        printf("NO\n");
    return 0;
}
时间: 2024-11-08 07:39:15

poj1860——Currency Exchange(Eellman-Ford+权值为正的环路)的相关文章

POJ 1860【求解是否存在权值为正的环 屌丝做的第一道权值需要计算的题 想喊一声SPFA万岁】

题意: 有n种钱币,m个钱币兑换点,小明一开始有第n种钱币数量为w. 每个兑换点可以将两种不同的钱币相互兑换,但是兑换前要先收取一定的费用,然后按照比例兑换. 问小明是否可以经过一系列的兑换之后能够将持有的第n种钱的数量增加. 这题大概就是看是否存在权值为正的环.如果存在这样的环,那么可以一直循环,然后在适当的时候兑换成第n种钱币. 这种算法一定要看好兑换率的范围!~ 思路: 利用SPFA算法,当一个点松弛次数超过N次的时候我们认为存在一个正环. #include<stdio.h> #incl

POJ1860 Currency Exchange【BellmanFord算法】【求正权回路】

Currency Exchange Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 20994 Accepted: 7522 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and perfor

POJ 1860 Currency Exchange (Bellman ford)

Currency Exchange Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 22405   Accepted: 8095 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and pe

POJ1860:Currency Exchange(BF)

http://poj.org/problem?id=1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be sev

POJ1860——Currency Exchange(BellmanFord算法求最短路)

Currency Exchange DescriptionSeveral currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points sp

POJ-1860 Currency Exchange( Bellman_Ford, 正环 )

题目链接:http://poj.org/problem?id=1860 Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can b

POJ-1860 Currency Exchange 【spfa判负环】

Description Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the

POJ 1860 Currency Exchange(如何Bellman-Ford算法判断正环)

题目链接: https://cn.vjudge.net/problem/POJ-1860 Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be s

[poj1860] Currency Exchange (bellman-ford算法)

题目链接:http://poj.org/problem?id=1860 题目大意:给你一些兑换方式,问你能否通过换钱来赚钱? 使用ford算法,当出现赚钱的时候就返回YES,如果不能赚钱,则返回NO 应该是可以停下来的,但是我不会分析复杂度,谁来教教我? 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 #include <vector> 5 #include <map&