poj1611——The Suspects(并查集)

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

给出一些团体里的人物编号,0号代表受感染的人,圈子里的人能够互相感染,问最终感染了多少人。

并查集类似一种树形结构吧,同一个团体里的人在一棵树上,所有人都用最初加入这个树的人编号表示。树的合并,也就是并查集的合并,找到各自所在的树的编号,再判断编号的等级,这里默认把一个团体的人合并到第一个人所造的树上,如果第一个人的编号等级比后面的人大,那就加入作为子树。

如果等级小,说明后面的人加入了一个更大的树,那么就要把第一个人所在的树加入后面的树。

如果等级相同,合并后把其中一个树的等级提高就行。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 200010
#define Mod 10001
using namespace std;
int f[MAXN],rank[MAXN];
int find(int x)
{
    if(x!=f[x])
    {
        f[x]=find(f[x]);
    }
    return f[x];
}
void join(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a==b)
        return;
    if(rank[a]<rank[b])
        f[a]=b;
    else
    {
        f[b]=a;
        if(rank[a]==rank[b])
            rank[a]++;
    }
}
int main()
{
    int n,m,k,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<=n;++i)
        {
            f[i]=i;
            rank[i]=0;
        }
        while(m--)
        {
            scanf("%d",&k);
            scanf("%d",&a);
            for(int i=1;i<k;++i)
            {
                scanf("%d",&b);
                join(a,b);
            }
        }
        int ans=1;
        for(int i=1;i<=n;++i)
        {
            if(find(i)==find(0))
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
时间: 2024-11-08 03:33:43

poj1611——The Suspects(并查集)的相关文章

POJ1611 The Suspects: 并查集入门

#include<iostream> using namespace std; #define Size 30000 int Pre[Size+1], Sum[Size+1];// Sum[i] 表示 第i组 的人数 int Get_Pre( int a ) { if( Pre[a]!=a ) a = Get_Pre( Pre[a] );// 路径压缩 return a; } void Union( int a, int b ) { int P1 = Get_Pre(a); int P2 =

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21586   Accepted: 10456 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects (并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Sprea

POJ 1611 The Suspects (并查集+数组记录子孙个数 )

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 24134   Accepted: 11787 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects(并查集维护根节点信息)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 37090   Accepted: 17980 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 1611 The Suspects (并查集求数量)

Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In t

POJ 1611 The Suspects 并查集 Union Find

本题也是个标准的并查集题解. 操作完并查集之后,就是要找和0节点在同一个集合的元素有多少. 注意这个操作,须要先找到0的父母节点.然后查找有多少个节点的额父母节点和0的父母节点同样. 这个时候须要对每一个节点使用find parent操作.由于最后状态的时候,节点的parent不一定是本集合的根节点. #include <stdio.h> const int MAX_N = 30001; struct SubSet { int p, rank; }sub[MAX_N]; int N, M; v

The Suspects——并查集求联通块数量的模板题

题目链接 题意: n个学生分属m个团体,一个学生可以属于多个团体.一个学生疑似患病,则他所属的整个团体都疑似患病.已知0号疑似患病,以及每个团体都有哪些学生构成,求一共有多少个学生疑似患病 题解: 很经典的并查集的题目,找一个num[]数组记录每一个以当前下标为根节点的集合的个体数目,最后输出0号的根节点对应的num值,就是0号学生所在团体的人数. 代码: #include<iostream> #include<stdio.h> #include<math.h> usi

POJ 1611 The Suspects (并查集)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 25130   Accepted: 12313 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects(并查集求节点数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 28164   Accepted: 13718 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T