Seeding--zoj2100

Seeding


Time Limit: 2 Seconds      Memory Limit: 65536 KB


It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S‘ is a square with stones, and ‘.‘ is a square without stones.

Input is terminated with two 0‘s. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

主要就是深搜!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,ds;
char map[8][8];
int move[4][2]={0,1,0,-1,1,0,-1,0};
int visit[8][8],cot,flag;
void dfs(int x,int y)
{
        int next_x,next_y,i;
        if(cot==ds)//如果已经找完了所有的点就跳出
        {
            flag=1;//设置一个开关
            return;
        }
        for(i=0;i<4;i++)
        {
            next_x=x+move[i][0];
            next_y=y+move[i][1];//往四个方向移动
            if(next_x>=0&&next_x<n&&next_y>=0&&next_y<m)//在图的范围内
            {
                if(!visit[next_x][next_y]&&map[next_x][next_y]!=‘S‘) //没被访问过,这个点还不能是S
                {
                    cot++;//访问一次就加一次
                    visit[next_x][next_y]=1;//标记为走过
                    dfs(next_x,next_y);//进入下一层
                    visit[next_x][next_y]=0;//取消标记
                    cot--;//跳出一次就减一次
                }
            }
        }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n||m)
    {
        getchar();
        cot=0;
        ds=0;
        flag=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                visit[i][j]=0;
                scanf("%c",&map[i][j]);
                if(map[i][j]==‘.‘)
                ds++;//记录点的个数
            }
            getchar();
        }
        visit[0][0]=1;//访问过就标记为1
        cot++;//先加一次
        dfs(0,0);//从0,0点开始访问
        //printf("%d\n",ds);
        if(flag)
        printf("YES\n");
        else
        printf("NO\n");
    }
return 0;
}
时间: 2024-08-05 03:08:51

Seeding--zoj2100的相关文章

Seeding zoj2100 【DFS】

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-machine. At the beginning, the machine lies in the top left

Oracle Warehouse Builder(OWB) 安装报seeding owbsys错误的解决

今天在RHEL6.4上安装Oracle Warehouse Builder 11.2时在最后一步报错,打开日志查看有如下信息: main.TaskScheduler timer[5][email protected]:27:55.055: 00> oracle.wh.ui.install.assistant.wizards.AssistantWizardDefinition.display(AssistantWizardDefinition.java:1476): [executeOwbRepo

ZOJ Seeding 2100【简单深搜】

Seeding Time Limit: 2 Seconds      Memory Limit: 65536 KB It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-ma

ZOJ 题目2100 Seeding(DFS)

Seeding Time Limit: 2 Seconds      Memory Limit: 65536 KB It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-ma

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-machine. A

Zoj 2100 Seeding

  <pre class="html" name="code">#include<stdio.h> char map[8][8]; int visited,flag; int n,i,j,m; void dfs(int x,int y) { if( x<0 || y<0 || x>=n || y>=m) return; if(map[x][y]!='.') return; if(flag) return; map[x]

laravel seeding

提前配置测试数据 php artisan make:seeder UserTableSeeder write random data <?php use Illuminate\Database\Seeder; use Illuminate\Support\Facades\DB; class UserTableSeeder extends Seeder { /** * Run the database seeds. * * @return void */ public function run()

ASP.NET MVC5(二):控制器、视图与模型

前言 本篇博文主要介绍ASP.NET MVC中的三个核心元素:控制器.视图与模型,以下思维导图描述了本文的主要内容. 控制器 控制器简介 在介绍控制器之前,简单的介绍一下MVC工作原理:URL告知路由机制该使用哪个控制器(Controller),调用该控制器中的哪个方法(Action),并为该方法提供需要的参数.控制器响应用户的输入,在响应时修改模型(Model),并决定使用哪个视图(View),并对该视图进行渲染.注意:MVC模式提供的是方法调用结果,而不是动态生成的页面. 以上内容对于初学者

使用wget命令时发生错误

用的是centos6.5, 当我使用命今 sudo wget https://cmake.org/files/v3.6/cmake-3.6.1.tar.gz 下载个cmake的包时, 发生了这样的错误 --2016-09-01 06:53:39-- https://cmake.org/files/v3.6/cmake-3.6.1.tar.gz Resolving cmake.org... 66.194.253.19 Connecting to cmake.org|66.194.253.19|:4

《机器学习》周志华 习题答案9.4

原题采用Kmeans方法对西瓜数据集进行聚类.我花了一些时间居然没找到西瓜数据集4.0在哪里,于是直接采用sklearn给的例子来分析一遍,更能说明Kmeans的效果. #!/usr/bin/python # -*- coding:utf-8 -*- import numpy as np import matplotlib.pyplot as plt from sklearn.ensemble import BaggingClassifier from sklearn.tree import D