poj-1146 ID codes

Description

It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people‘s movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a‘, 2 of `b‘ and 1 of `c‘, then three of the allowable 60 codes under these conditions are:

      abaabc
      abaacb
      ababac

These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor‘ if the given code is the last in the sequence for that set of characters.

Input

Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output

Output will consist of one line for each code read containing the successor code or the words ‘No Successor‘.

Sample Input

abaacb
cbbaa
#

Sample Output

ababac
No Successor题目大意:一组字符全排列,如果有下一个全排列则则输出 若无,则输出NO;注意:在STL中有个next_permutation(const *str,int length);函数。若有下一个全排列则返回true并生成下一个全排列,反之返回false;<a href="www.baidu.com">这儿</a>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int  permutation(char str[],int length)
{   int j=0;
  //  sort(str,str+length);

        while(next_permutation(str,str+length))
            {
        for(int i=0;i<length;i++)
        cout<<str[i];

        cout<<endl;
        j++;
        break;

        }
        return j;
}
int main ()
{
while(1)
{

char str[100];
cin>>str;
if(str[0]==‘#‘)break;
int len=strlen(str);
int q=permutation(str,len);
if(!q)cout<<"No Successor"<<endl;
}

return 0;
}

  

时间: 2024-10-13 08:02:51

poj-1146 ID codes的相关文章

ACM POJ 1146 ID Codes

题目大意:输入一个字符串,输出它的下一个字典序排列. 字典序算法思想: 1.从右向左寻找字符串找出第一个a[i]<a[i+1]的位置i; 2.从右向左找出第一个大于a[j]的元素a[i]; 3.swap(a[i],a[j]) 4.将a[i]......到a[stelen(a)]倒序 5.输出a 代码如下: #include<iostream> #include<cstdio> #include <cstring> #include<algorithm>

POJ 1146 ID Codes(枚举排序)

[题意简述]:求下一个排列 [分析]:同1833一样,如果用STL 一下就解决了,最好自己写函数. // 192K 0Ms #include<iostream> #include<cstring> #include<algorithm> using namespace std; char alphabit[51]; int main() { int i,j,len; while(1) { cin>>alphabit; if(alphabit[0] == '#

1146 ID Codes

题目链接: http://poj.org/problem?id=1146 题意: 给定一个字符串(长度不超过50), 求这个字符串的下一个字典序的字符串, 如果已经是最大字典序, 那么输出 "No successor". 分析: <algorithm>中有一个现成的next_permutation(begin, end), 对输入的字符串进行排列. 原型如下: 1 template<class BidirectionalIterator> 2 bool next

POJ 1146:ID Codes

ID Codes Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 6281 Accepted: 3769 Description It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby

UVA - 146 - ID Codes (枚举排列)

UVA - 146 ID Codes Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its ci

UVA 146 ID Codes(下一个排列)

C - ID Codes Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Appoint description:  System Crawler  (2014-05-12) Description  ID Codes  It is 2084 and the year of Big Brother has finally arrived, albeit a century l

Brute Force &amp; STL --- UVA 146 ID Codes

 ID Codes  Problem's Link:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=3&problem=82&mosmsg=Submission+received+with+ID+14418598 Mean: 求出可重排列的下一个排列. analyse: 直接用STL来实现就可.自己手动写了一个,并不复杂.

寒假集训.ID Codes

ID Codes Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Description  ID Codes  It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citi

poj 1147 Binary codes

Binary codes Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5647   Accepted: 2201 Description Consider a binary string (b1-bN) with N binary digits. Given such a string, the matrix of Figure 1 is formed from the rotated versions of the