poj 3250 Bad Hair Day(栈的运用)

http://poj.org/problem?id=3250

Bad Hair Day

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15985   Accepted: 5404

Description

Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        ==       ==   -   =         Cows facing right -->=   =   == - = = == = = = = =1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow‘s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow‘s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题目大意:

n个数,从左到右排成一排,问每个数的右边比他小的数有几个,然后求和

可以反过来想,看每个数他的左边有多少个数比他大的有几个,然后再加起来

用栈来模拟,先将第一个数压入栈:

如果栈首元素S.top() > a[i],

则栈里面的元素都比a[i]大,那么比a[i]大的数的个数就是栈里面的元素个数S.size();

否则栈首元素S.top() <= a[i],说明S.top()不符合条件(不大于a[i])

则让栈首元素出栈,继续比较栈内元素如果不大于a[i],就让他出栈

也就是说栈内的元素都是比a[i]大的数
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<stack>
#include<algorithm>

using namespace std;
const int N = 80010;
typedef __int64 ll;

int a[N];

int main()
{
    stack<int>S;
    int n;
    while(~scanf("%d", &n))
    {
        ll sum = 0;
        for(int i = 0 ; i < n ; i++)
            scanf("%d", &a[i]);
        S.push(a[0]);//第一个数进栈
        for(int i = 1 ; i < n ; i++)//遍历
        {
            while(!S.empty() && S.top() <= a[i])
                S.pop();//出栈
            sum += S.size();
            S.push(a[i]);//入栈
        }
        printf("%I64d\n", sum);
    }
    return 0;
}


时间: 2024-10-13 22:03:11

poj 3250 Bad Hair Day(栈的运用)的相关文章

POJ 3250 Bad Hair Day(单调栈)

题目地址:POJ 3250 初学单调栈.多校和网络赛已经碰到两次了. 单调栈的原理简单的不能再简单了..就是让栈里的元素从栈顶到栈底呈单调性. 比如说递增单调栈. 每次放进一个数的时候,如果栈顶的数小于要放的数,就把栈顶的数pop出来使得栈里保持单调性. 对于这道题来说,就从右往左开始遍历,建一个递增单调栈.那么每次pop出来的就是当前的牛可以看到的牛数.然后累加即可. 代码如下: #include <iostream> #include <cstdio> #include <

poj 2082 Terrible Sets (数据结构 ——栈 STL)

 Terrible Sets Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 2999   Accepted: 1549 Description Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elem

POJ 3250:字母重排

AC CODE: import java.util.Scanner; public class Main { private static char[] ASCII = { 'a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z' }; private static String getString() { Scanner input = new

poj 3250 Bad Hair Day (单调栈)

Bad Hair Day Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14883   Accepted: 4940 Description Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants

poj 3250 Bad Hair Day 单调栈入门

Bad Hair Day 题意:给n(n <= 800,000)头牛,每头牛都有一个高度h,每头牛都只能看到右边比它矮的牛的头发,将每头牛看到的牛的头发加起来为多少? 思路:每头要进栈的牛,将栈顶比其矮的牛出栈,因为这些牛都没有机会看到更后面的牛了,所以出栈;这时加上栈中的元素个数即可: #include<iostream> #include<cstdio> #include<cstring> #include<string.h> #include&l

poj 3250 Bad Hair Day【栈】

Bad Hair Day Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 15922   Accepted: 5374 Description Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants

[单调栈] poj 3250 Bad Hair Day

题意: 一排母牛站成一排,给出牛的身高,每只牛都只能往右看,对于每只母牛有一个c[i] c[i]代表i能看见多少只牛,矮的牛看不见高的牛,问所有c[i]的和是多少. 思路: 我们转换一下,其实就是求对于每只母牛能被看见多少次,显然是对于它往左单调递增的牛都能看见它 那么我们维护一个这样的单调栈,每次都将小于等于它的出栈,那么栈中的元素的个数就是能看见它的个数 这样再把该元素插入栈就好了. 代码: #include"cstdlib" #include"cstring"

POJ 3250 Bad Hair Day 模拟单调栈

Bad Hair Day Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14989   Accepted: 4977 Description Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants

poj 3250 Bad Hair Day

题目链接:http://poj.org/problem?id=3250 思路分析: 题目要求求每头牛看见的牛的数量之和,即求每头牛被看见的次数和:  现在要求如何求出每头牛被看见的次数?  考虑到对于某头特定的牛来说,看见它的牛一定在它的左边,另外其高度应该大于该牛的高度,所以只需要计算在其左边并高度大于它的牛的数目即可:  考虑构建一个栈,在某头牛入栈时,弹出栈中高度小于它的牛,剩下的牛高度大于它,此时计算栈的长度就可以得到该牛被看见的次数. 代码如下: #include<iostream>