Alisha's Party

Alisha’s Party

Time Limit: 1 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5437

Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n?th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i?th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i?th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t?th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1?th,...,nq?th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1

5 2 3

Sorey 3

Rose 3

Maltran 3

Lailah 5

Mikleo 6

1 1

4 2

1 2 3

Sample Output

Sorey Lailah Rose

好题,直接用结构体来写的话会时间超限,不断的用sort排序,但用优先队列的话,每次只往里面添加有限的个数只需遍历一遍。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int k,m,p,pos[150007],x;
struct Come
{
    int vis;
    int num;
}come[150007];
bool cmp(Come a,Come b)
{
    return a.vis<b.vis;
}
struct Node
{
    int idx;
    int v;
    char name[210];
    friend bool operator<(Node x,Node y)
    {
        if(x.v==y.v) return x.idx>y.idx;
        return x.v<y.v;
    }
}node[150007];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        priority_queue<Node>q;
        scanf("%d%d%d",&k,&m,&p);
        for(int i=1;i<=k;i++)
        {
            scanf("%s%d",&node[i].name,&node[i].v);
            node[i].idx=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&come[i].vis,&come[i].num);
        }
        sort(come,come+m,cmp);
        int ans=1;
        int inf=1;
        for(int i=0;i<m;i++)
        {
            while(inf<=come[i].vis)//放入有限个数
            {
                q.push(node[inf]);
                inf++;
            }
            while(come[i].num && !q.empty())
            {
                pos[ans++]=q.top().idx;
                q.pop();
                come[i].num--;
            }
        }
        while(inf<=k)
        {
            q.push(node[inf]);
            inf++;
        }
        while(!q.empty())
        {
            pos[ans++]=q.top().idx;
            q.pop();
        }
        for(int i=0;i<p;i++)
        {
            scanf("%d",&x);
            if(i) printf(" ");
            printf("%s",node[pos[x]].name);
        }
        printf("\n");
    }
    return 0;
}

Alisha's Party

时间: 2024-08-01 01:27:38

Alisha's Party的相关文章

HDU5437 Alisha’s Party(优先队列+模拟)

Alisha's Party Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 4075    Accepted Submission(s): 1052 Problem Description Princess Alisha invites her friends to come to her birthday party. Each

Alisha’s Party(队列)

Alisha’s Party Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 2518    Accepted Submission(s): 681 Problem Description Princess Alisha invites her friends to come to her birthday party. Each o

hdu 5437 Alisha’s Party 模拟 优先队列

Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a

hdu 5437 Alisha’s Party (线段树)

Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a

HDU 5437 Alisha’s Party

题目链接: http://acm.split.hdu.edu.cn/showproblem.php?pid=5437 Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Be

HDU5437 Alisha’s Party (优先队列 + 模拟)

Alisha’s Party Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 2650    Accepted Submission(s): 722 Problem Description Princess Alisha invites her friends to come to her birthday party. Each o

HDU 5437 &amp; ICPC 2015 Changchun Alisha&#39;s Party(优先队列)

Alisha’s Party Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 7971    Accepted Submission(s): 1833 Description Princess Alisha invites her friends to come to her birthday party. Each of her f

Alisha’s Party---hdu5437(模拟+优先队列)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5437 题意:公主有k个朋友来参加她的生日party,每个人都会带价值为v[i]的礼物过来,在所有人到齐之前公主会打开大门m次,每次开门就是在第t个人到来之后,然后让p个人进入大厅,如果当前人数不足p人,则让所有人都进去,最后在所有人都来到门口时,再次打开门,让剩下所有的人都进入大厅:当然选择礼物价值大的先进入,如果两个人的礼物价值相等,则先来的先进,现在有q个问题,问第ni个进入大厅的人是谁: 我们

hdu 5437 Alisha’s Party (优先队列)

http://acm.hdu.edu.cn/showproblem.php?pid=5437 题目意思比较好理解,如果暴力的话或超时,可以考虑到用优先队列就可以很简单的解决问题 1 #include<queue> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 using namespace std; 6 struct point { 7 int x,id; 8 char na[2