hdoj 1162 Eddy's picture【最小生成树】

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8117    Accepted Submission(s): 4114

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

 

 

代码:

 

Kruskal算法:

 
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int n;
double x[110],y[110];
int per[110];
struct record
{
	int s,e;
	double w;
}num[10000];
bool cmp(record a,record b)
{
	return a.w<b.w;
}
int init()
{
	for(int i=1;i<=n;i++)
	{
		per[i]=i;
	}
}
int find(int x)
{
	int r;
	r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	per[x]=r;
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
		return true;
	}
	return false;
}
int main()
{
	int i,j,k;
	double d,sum;
	while(scanf("%d",&n)!=EOF)
	{
		k=0;sum=0;
		init();
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&x[i],&y[i]);
		}
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				d=sqrt((x[j]-x[i])*(x[j]-x[i])+(y[j]-y[i])*(y[j]-y[i]));
			    num[k].s=i;
			    num[k].e=j;
			    num[k].w=d;
			    k++;
			}
		}
		sort(num,num+k,cmp);
		for(i=0;i<k;i++)
		{
			if(join(num[i].s,num[i].e))
			{
				sum+=num[i].w;
			}
		}
		printf("%.2lf\n",sum);
	}
	return 0;
}

Prim算法:

#include<stdio.h>
#include<string.h>
#include<math.h>
#define INF 0x3f3f3f
int vis[110];
double x[110],y[110],low[110],map[110][110];
int n;
int prim()
{
	int i,j,next;
	double min,sum=0;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
	{
		low[i]=map[1][i];
	}
	vis[1]=1;
	for(i=2;i<=n;i++)
	{
		min=INF;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&min>low[j])
			{
				min=low[j];
				next=j;
			}
		}
		sum+=min;
		vis[next]=1;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&low[j]>map[next][j])
			{
				low[j]=map[next][j];
			}
		}
	}
	printf("%.2lf\n",sum);
}
int main()
{
	int i,j;
	double d;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(i==j)
				map[i][j]=map[j][i]=0;
				else
				map[i][j]=map[j][i]=INF;
			}
		}
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&x[i],&y[i]);
		}
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				d=sqrt((x[j]-x[i])*(x[j]-x[i])+(y[j]-y[i])*(y[j]-y[i]));
				map[i][j]=map[j][i]=d;
			}
		}
		prim();
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 1162 Eddy's picture【最小生成树】

时间: 2024-07-29 09:21:19

hdoj 1162 Eddy's picture【最小生成树】的相关文章

hdoj 1162 Eddy&#39;s picture(最小生成树)

Eddy's picture http://acm.hdu.edu.cn/showproblem.php?pid=1162 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7521    Accepted Submission(s): 3821 Problem Description Eddy begins to like painti

hdoj 1162 Eddy&#39;s picture

并查集+最小生成树 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7669    Accepted Submission(s): 3882 Problem Description Eddy begins to like painting pictures recently ,he is sure of hi

hdu 1162 Eddy&#39;s picture 最小生成树入门题 Prim+Kruskal两种算法AC

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7428    Accepted Submission(s): 3770 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdu 1162 Eddy&#39;s picture(最小生成树算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6866    Accepted Submission(s): 3469 Problem Description Eddy begins to like p

HDU 1162 Eddy&#39;s picture (最小生成树)(java版)

Eddy's picture 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 --每天在线,欢迎留言谈论. 题目大意: 给你N个点,求把这N个点连在一起的最短总距离. 思路: 假设每两两点之间都有路径,求最小生成树. AC代码:(Java) 1 import java.util.Scanner; 2 import java.math.*; 3 public class Main { 4 public static final int MAX

HDU 1162 Eddy&#39;s picture【最小生成树,Prime算法+Kruskal算法】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 4711 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

HDU 1162 Eddy&#39;s picture(图论-最小生成树)

题目如下: Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7267    Accepted Submission(s): 3676 Problem Description Eddy begins to like painting pictures recently ,he is sure of himse

hdu 1162 Eddy&#39;s picture(最小生成树)

Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result i

hdu 1162 Eddy&#39;s picture (Kruskal算法,prim算法,最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 [题目大意] 给你n个点的坐标,让你找到联通n个点的一种方法,保证联通的线路最短,典型的最小生成树问题. 方法一 , 通过不断找到最小的边来找到最终结果. Kruskal 算法 #include <iostream> #include <algorithm> #include <cstdio> #include <cmath> using namespac