POJ 1797 Heavy Transportation 【最大生成树,Prime】

Heavy Transportation

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 29765   Accepted: 7944

Description

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo‘s place) to crossing n (the customer‘s
place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

原题链接:http://poj.org/problem?id=1797

此题原来已用Dijkstra算法解决了,链接在此:http://blog.csdn.net/hurmishine/article/details/52151573

后来又看到网上说可以用最大生成树来做,http://blog.csdn.net/blue_skyrim/article/details/52165237

今天就来试一下。

AC代码:

#include <iostream>
#include <cstdio>

using namespace std;
int n,m;
const int maxn=1005;
const int INF=0x3f3f3f3f;
int a[maxn][maxn];
bool vis[maxn];
int dis[maxn];
void Prime()
{
    for(int i=1; i<=n; i++)
    {
        vis[i]=false;
        dis[i]=a[1][i];
    }
    vis[1]=true;
    dis[1]=0;
    int ans=INF;
    for(int i=2; i<=n; i++)
    {
        int maxx=-INF;
        int p=-1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>maxx)
                maxx=dis[p=j];
        }
        if(maxx<ans)
            ans=maxx;
        vis[p]=true;
        if(p==n)
            break;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<a[p][j])
                dis[j]=a[p][j];
        }
    }
    cout<<ans<<endl<<endl;;
}
int main()
{
    int T,kase=0;
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int x,y,z;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
                if(i==j) a[i][j]=0;
                else a[i][j]=-INF;
        }
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z>a[x][y])
                a[x][y]=a[y][x]=z;
        }
        cout<<"Scenario #"<<++kase<<":"<<endl;
        Prime();
    }
    return 0;
}
时间: 2024-08-10 12:51:21

POJ 1797 Heavy Transportation 【最大生成树,Prime】的相关文章

poj 1797 Heavy Transportation(最大生成树)

poj 1797 Heavy Transportation Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has

POJ 1797 Heavy Transportation (最短路变形)

Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 20364   Accepted: 5401 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man

POJ 1797 Heavy Transportation SPFA变形

原题链接:http://poj.org/problem?id=1797 Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 24576   Accepted: 6510 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand

POJ 1797 Heavy Transportation(最大生成树/最短路变形)

传送门 Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 31882   Accepted: 8445 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever

POJ 1797 Heavy Transportation (Dijkstra变形)

F - Heavy Transportation Time Limit:3000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1797 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand busines

POJ 1797 Heavy Transportation【Dijkstra最短路变形】

Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 29682   Accepted: 7919 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man

POJ 1797 Heavy Transportation (Dijkstra)

题目链接:POJ 1797 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant

poj 1797 Heavy Transportation 【最短路Dijkstra 变式】

Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 23914   Accepted: 6355 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man

POJ 1797 Heavy Transportation(二分+并查集/kruskal)

Heavy Transportation Time Limit: 3000MS   Memory Limit: 30000K Total Submissions: 24398   Accepted: 6472 Description Background Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man