bc #43(hdu 5265) pog loves szh II

pog loves szh II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2115    Accepted Submission(s): 609

Problem Description

Pog and Szh are playing games.There is a sequence with n numbers, Pog will choose a number A from the sequence. Szh will choose an another number named B from the rest in the sequence. Then the score will be (A+B) mod p.They hope to get the largest score.And what is the largest score?

Input

Several groups of data (no more than 5 groups,n≥1000).

For each case:

The following line contains two integers,n(2≤n≤100000),p(1≤p≤231−1)。

The following line contains n integers ai(0≤ai≤231−1)。

Output

For each case,output an integer means the largest score.

Sample Input

4 4
1 2 3 0
4 4
0 0 2 2

Sample Output

3
2

Source

BestCoder Round #43

Recommend

hujie   |   We have carefully selected several similar problems for you:  5338 5337 5336 5335 5334

对于读入的a[i] mod p后

对于任意 0=<i,j<=n-1  a[i]+a[j] 大于等于0小于等于2p-2

所以a[i]+a[j]的结果只有两种情况,一种是 <p,直接就是答案,另一种是 >=p  <=2p-2   a[i]+a[j]-p 是答案

把a[i]升序排列,如果存在a[i]+a[j]>=p ,那么最大的一定是a[n-1]+a[n-2]

对于a[i]+a[j]小于p的,我们枚举i,找到最大的j,使得a[i]+a[j]<p,这是对于i最大的答案。

如果直接枚举O(N2)会超时

由于a[i]数组已经是有序的了

我们可以利用a[i]的单调性,从两边往中间找。

这样复杂度就是O(N)了

这个优化前几天刚遇到过。。。。

/*************************************************************************
    > File Name: code/bc/#43/B.cpp
    > Author: 111qqz
    > Email: [email protected]
    > Created Time: 2015年07月31日 星期五 16时38分13秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x7fffffff;
const int N=1E5+7;
LL a[N];
int n,p;

int main()
{
    while (scanf("%d %d",&n,&p)!=EOF)
    {
    LL ans = -1;
    for ( int i = 0 ; i < n;  i++ )
    {
        scanf("%lld",&a[i]);
        a[i]=a[i]%p;
    }
    sort(a,a+n);
    ans = (a[n-1]+a[n-2])%p;
    int j = n-1;
    for ( int i = 0 ; i  < n-2 ; i++ )
    {
        while (i<j&&a[i]+a[j]>=p) j--;
        ans = max(ans,(a[i]+a[j])%p);
    }
    cout<<ans<<endl;

    }

    return 0;
}
时间: 2024-12-22 09:45:16

bc #43(hdu 5265) pog loves szh II的相关文章

HDU 5265 pog loves szh II (二分查找)

[题目链接]click here~~ [题目大意]在给定 的数组里选两个数取模p的情况下和最大 [解题思路]: 思路见官方题解吧~~ 弱弱献上代码: Problem : 5265 ( pog loves szh II ) Judge Status : Accepted RunId : 13961817 Language : G++ Author : javaherongwei Code Render Status : Rendered By HDOJ G++ Code Render Versio

hdu 5265 pog loves szh II STL

pog loves szh II Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5265 Description pog在与szh玩游戏,首先pog找到了一个包含n个数的序列,然后他在这n个数中挑出了一个数A,szh出于对pog的爱,在余下的n−1个数中也挑了一个数B,那么szh与pog的恩爱值为(A+B)对p取模后的余数,pog与szh当然想让恩爱值越高越好,并且他们

hdu 5265 pog loves szh II

函数lower_bound()在first和last中的前闭后开区间进行二分查找,返回大于或等于val的第一个元素位置.如果所有元素都小于val,则返回last的位置 #include<stdio.h> #include<iostream> #include<algorithm> using namespace std; typedef unsigned long long ull; int main() { __int64 n,p,a[100000+5],ans; _

HDU 5265 pog loves szh II (找两数之和)

题意:给一个数字序列,要求再其中找到两个数,其和再模p的结果是最大的,求此和. 思路:先将输入的元素模p,排序.结果可能有两种情况: (1)a+b大于p:肯定由两个最大的数之和来产生. (2)a+b小于p:设b为最大且a+b小于p,那么结果在这两个数的位置之间产生.用两个指针找出来,再与(1)中的ans比较,谁大就取谁. 若有a+b=p-1肯定是答案. 1 #include <bits/stdc++.h> 2 #define LL long long 3 using namespace std

HDU ACM 5265 pog loves szh II

题意:求数组中两个不同元素使得两元素和%p最大. 分析: 1.序列中的数可能超过P,将所有数读入后进行模P操作. 2.将取模后的所有数从小到大排序,现在所有数都是小于P且排好序的. 3.假设任意选了两个数X和Y,则0≤X+Y≤2P-2.若X+Y<P,则答案就是X+Y,若X+Y≥P,答案是X+Y-P. 从小到大枚举第一个数,另一个匹配的数显然是从大到小的,可以用POS记录当前另一个匹配的数的位置,每次枚举时POS递减至符合条件.可以做到O(n)的时间复杂度.这题还可以使用二分等方法. #inclu

贪心/二分查找 BestCoder Round #43 1002 pog loves szh II

题目传送门 1 /* 2 贪心/二分查找:首先对ai%=p,然后sort,这样的话就有序能使用二分查找.贪心的思想是每次找到一个aj使得和为p-1(如果有的话) 3 当然有可能两个数和超过p,那么an的值最优,每次还要和an比较 4 注意:不能选取两个相同的数 5 反思:比赛时想到了%p和sort,lower_bound,但是还是没有想到这个贪心方法保证得出最大值,还是题目做的少啊:( 6 */ 7 #include <cstdio> 8 #include <algorithm>

hdu 5266 pog loves szh III 在线lca+线段树区间优化

题目链接:hdu 5266 pog loves szh III 思路:因为它查询的是区间上的lca,所以我们需要用在线lca来处理,达到单点查询的复杂度为O(1),所以我们在建立线段树区间查询的时候可以达到O(1*nlgn)的时间复杂度 ps:因为栈很容易爆,所以.....你懂的 -->#pragma comment(linker, "/STACK:1024000000,1024000000") /*****************************************

hdu 5264 pog loves szh I 水题

pog loves szh I Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5264 Description pog拥有很多字符串,它喜欢将两个长度相等字符串交错拼在一起,如abcd与efgh,那么交错拼在一起就成了aebfcgdh啦!szh觉得这并不好玩,因此它将第二个字符串翻转了一遍,如efgh变成了hgfe,然后再将这两个字符串交错拼在一起,因此abcd与efg

hdu 5264 pog loves szh I

题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5264 pog loves szh I Description Pog has lots of strings. And he always mixes two equal-length strings. For example, there are two strings: "abcd" and "efgh". After mixing, a new string &q