1032 Parliament

描述
愚人土地议会的新集会由N名代表组成。 根据现行规定,代表们应分为不同规模的不相交群体,每天每个小组必须派一名代表参加和解委员会。 和解委员会的组成应该每天都不同。 议会只有在完成这项工作的情况下才能运作。
您将编写一个程序,确定每个组应包含多少代表,以便议会尽可能长时间地工作。
输入
输入文件包含单个整数N(5 <= N <= 1000)。
输出
将输出文件写入允许议会在最长可能时间内工作的组的大小。 这些尺寸应按升序打印在一行上,并应以空格分隔。
样例输入
7
样例输出
3 4

//////////////////////////////////////////////////////////////////////////
//        POJ1032 Parliament
//        Memory: 280K        Time: 0MS
//        Language: C++        Result: Accepted
//////////////////////////////////////////////////////////////////////////

#include <iostream>

using namespace std;

int main() {
    int N;
    cin >> N;
    int cnt;
    int sum = 0;
    for (cnt = 0; sum + 2 + cnt<= N; ++cnt) {
        sum += (2 + cnt);
    }
    int left = N - sum;
    int p = 1 + cnt;
    while (left > 0) {
        --p;
        --left;
    }
    if (p == 0) {
        for (int i =3; i < 2 + cnt; ++i) {
            cout << i << " ";
        }
        cout << 3 + cnt << endl;
    } else if (p == 1) {
        for (int i =3; i < 2 + cnt; ++i) {
            cout << i << " ";
        }
        cout << 2 + cnt << endl;
    } else if (p == cnt + 1) {
        for (int i =2; i < 1 + cnt; ++i) {
            cout << i << " ";
        }
        cout << 1 + cnt << endl;
    } else {
        for (int i =2; i <= p; ++i) {
            cout << i << " ";
        }
        for (int i = p + 2; i < cnt + 2; ++i) {
            cout << i << " ";
        }
        cout << 2 + cnt << endl;
    }
    system("pause");
    return 0;
}

来源:https://www.cnblogs.com/dengeven/p/3229143.html

原文地址:https://www.cnblogs.com/sweet-ginger-candy/p/11518216.html

时间: 2024-11-05 02:05:25

1032 Parliament的相关文章

poj 1032 Parliament 【思维题】

题目地址:http://poj.org/problem?id=1032 Parliament Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17473   Accepted: 7371 Description New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation

Poj 1032 Parliament

Parliament Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19103   Accepted: 8101 Description New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into dis

POJ百道水题列表

以下是poj百道水题,新手可以考虑从这里刷起 搜索1002 Fire Net1004 Anagrams by Stack1005 Jugs1008 Gnome Tetravex1091 Knight Moves1101 Gamblers1204 Additive equations 1221 Risk1230 Legendary Pokemon1249 Pushing Boxes 1364 Machine Schedule1368 BOAT1406 Jungle Roads1411 Annive

如何快速解决MySQL 1032 主从错误

3分钟解决MySQL 1032主从错误 Part1:写在最前1032错误----现在生产库中好多数据,在从库误删了,生产库更新后找不到了,现在主从不同步了,再跳过错误也没用,因为没这条,再更新还会报错 解决方案 Part1:临时方案 mysql> stop slave;Query OK, 0 rowsaffected (0.00 sec) mysql> set global sql_slave_skip_counter=1;Query OK, 0 rowsaffected (0.00 sec)

复制中常见1062和1032错误处理方法

复制中错误处理 传统复制错误跳过: stop slave sql_thread ; set global slq_slave_skip_counter=1; start slave sql_thread ; GTID复制错误跳过: stop slave sql_thread ; set gtid_next='uuid:N'; begin;commit; set gtid_next='automatic'; start slave sql_thread ; 注意: 若是binlog+pos复制,使

mysql5.6 传统复制模式下1032和1062故障处理

一.环境 master     172.16.1.61      3307 slave      172.16.1.62      3307 二.检查环境 在master上检查 ([email protected]) [(none)]>show processlist\G *************************** 1. row ***************************      Id: 2    User: root    Host: localhost:42483

Last_IO_Errno: 1032

(一):更新找不到记录 1032 Last_SQL_Errno: 1032 Last_SQL_Error: Could not execute Update_rows event on table lgj3306.t01; Can't find record in 't01', Error_code: 1032; handler error HA_ERR_END_OF_FILE; the event's master log mysql-bin.000001, end_log_pos1940 如

修复mysql slave复制1032错误

一台从库出现1032错误,那1032是什么错误,我们看一下 [[email protected] ~]# perror 1032 MySQL error code 1032 (ER_KEY_NOT_FOUND): Can't find record in '%-.192s' 简单说,就是在从库上找不到相应的记录,同时在show slave status\G;中有相关输出,我们看一下: Last_Errno: 1032 Last_Error: Could not execute Update_ro

问题 1032: C语言程序设计教程(第三版)课后习题8.6

/******************************************************************** @file Main.cpp @date 2017-5-26 09:45:32 @author Zoro_Tiger @brief 问题 1032: C语言程序设计教程(第三版)课后习题8.6 http://www.dotcpp.com/oj/problem1032.html *****************************************