POJ 1979 Red and Black (DFS)

Red and Black

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23904   Accepted: 12927

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile

‘#‘ - a red tile

‘@‘ - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
[email protected]
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domestic

题意:给一个图,‘@‘是起点,‘.‘可以通过,‘#‘不可以通过。问从起点出发最多可以到达图中的多少个点。

解析:从起点深搜即可,每次dfs的时候,都把当前的起点改为’@‘,每次向四个方向搜索的时候,只有不出边界且当前点为’.‘的时候才继续深搜。只需要记录多少次dfs即为答案。

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b)  a+(b-a)/2
const int maxn = 1000 + 10;
int d[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
int m, n, ans;
char s[22][22];

void dfs(int x, int y){
    s[x][y] = '@';
    ans ++;
    for(int i=0; i<4; i++){
        int dx = x + d[i][0], dy = y + d[i][1];
        if(dx < n && dx >=0 && dy < m && dy >=0 && s[dx][dy] == '.')              //开始用的条件是s[dx][dy] != '#',程序老是死掉!!!
            dfs(dx, dy);
    }
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int sx = 0, sy = 0;
    while(scanf("%d%d", &m, &n)!=EOF  && !(!n && !m)){
        ans = 0;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++){
                cin >> s[i][j];
                if(s[i][j] == '@'){                 //记录起点坐标
                    sx = i;
                    sy = j;
                }
            }
        dfs(sx, sy);
        printf("%d\n", ans);
    }
    return 0;
}
时间: 2024-08-13 06:23:06

POJ 1979 Red and Black (DFS)的相关文章

poj 1979 Red and Black(dfs)

简单深搜 1 #include <cstdio> 2 int dir[4][2] = {{0,1},{1,0},{0,-1},{-1,0}}; 3 char map[21][21]; 4 int n,m; 5 int result; 6 7 void DFS(int sx, int sy) 8 { 9 int tx,ty; 10 for(int k = 0; k < 4; ++k) 11 { 12 tx = sx + dir[k][0]; 13 ty = sy + dir[k][1];

POJ 1979 Red and Black (红与黑)

POJ 1979 Red and Black (红与黑) Time Limit: 1000MS    Memory Limit: 30000K Description 题目描述 There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to

poj 1979 Red and Black(dfs水题)

Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only

POJ 3087 Shuffle&#39;m Up (DFS)

题目链接:Shuffle'm Up 题意:有a和b两个长度为n的字符序列,现定义操作: 将a.b的字符交叉合并到一个序列c,再将c最上面的n个归为a,最下面n个归为b 给出a,b和目标序列c,问最少多少次操作a.b转化为c 解析:将a.b放入哈希表,然后模拟操作过程直接dfs即可. AC代码: #include <cstdio> #include <iostream> #include <cstring> #include <map> using names

poj A Knight&#39;s Journey(DFS)

题目链接:http://acm.hrbust.edu.cn/vj/index.php?c=problem-problem&id=190592 题意:给出p*q的棋盘,从(A,1)开始,走“日”字,问能否走完棋盘上所有的点,如果能,按字典序输出路径: 思路:DFS,并保存路径即可,注意处理走的方向顺序int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}}; #include <stdio.h> #in

POJ 2488-A Knight&#39;s Journey(DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31702   Accepted: 10813 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 1979 Red and Black(简单DFS)

Red and Black Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he

《挑战》2.1 POJ POJ 1979 Red and Black (简单的DFS)

B - Red and Black Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1979 Description There is a rectangular room, covered with square tiles. Each tile is col

POJ 1979 Red and Black (深搜)

Red and Black Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 23095   Accepted: 12467 Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a