HDOJ 1015 Safecracker

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15066    Accepted Submission(s): 7946

Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===
"The
item is locked in a Klein safe behind a painting in the second-floor
library. Klein safes are extremely rare; most of them, along with Klein
and his factory, were destroyed in World War II. Fortunately old
Brumbaugh from research knew Klein‘s secrets and wrote them down before
he died. A Klein safe has two distinguishing features: a combination
lock that uses letters instead of numbers, and an engraved quotation on
the door. A Klein quotation always contains between five and twelve
distinct uppercase letters, usually at the beginning of sentences, and
mentions one or more numbers. Five of the uppercase letters form the
combination that opens the safe. By combining the digits from all the
numbers in the appropriate way you get a numeric target. (The details of
constructing the target number are classified.) To find the combination
you must select five letters v, w, x, y, and z that satisfy the
following equation, where each letter is replaced by its ordinal
position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the
one that is lexicographically greatest, i.e., the one that would appear
last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For
example, given target 1 and letter set ABCDEFGHIJKL, one possible
solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are
actually several solutions in this case, and the combination turns out
to be LKEBA. Klein thought it was safe to encode the combination within
the engraving, because it could take months of effort to try all the
possibilities even if you knew the secret. But of course computers
didn‘t exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop
a program to find Klein combinations in preparation for field
deployment. Use standard test methodology as per departmental
regulations. Input consists of one or more lines containing a positive
integer target less than twelve million, a space, then at least five and
at most twelve distinct uppercase letters. The last line will contain a
target of zero and the letters END; this signals the end of the input.
For each line output the Klein combination, break ties with
lexicographic order, or ‘no solution‘ if there is no correct
combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL

11700519 ZAYEXIWOVU

3072997 SOUGHT

1234567 THEQUICKFROG

0 END

Sample Output

LKEBA

YOXUZ

GHOST

no solution

题意描述:
给出一个目标值和一串仅包含大写字母的长度在5~12的字符串,
字符串中A的值为1,B的值为2,,,Z为26,
要求在这个字符串中找出5个不同的字符满足v-w*w+x*x*x-y*y*y*y+z*z*z*z*z
等于目标值的同时,求出字典序最大的这样5个字符组成的字符串。

Your idea:
1.一开始你竟然会想到用5-12选5得组合算法,
老铁,时间不够就算了,这里还要字典序输出 ,就算你先排序,但是还有重复的怎么办?
2. 暴力枚举,不用在给定的字符串中找,直接从A-Z(不过要根据给定的字符串标记能用的),
而且最先找到的就是最大字典序的,也不要用排序。
3. 字符到数字,其实不用真的把字符转换成数字,直接从1-26枚举,最后在输出时转换成字符就行了。
4.补充:int (‘ascii‘) ==ascii,也就是说char(7)并不是对应‘7‘;

//COPY

#include<cstdio>
#include<cstring>
int f[30],target;
int main(){
    char s[30];
    while(scanf("%d%s",&target,s)!=EOF&&target){
        memset(f,0,sizeof(f));
        if(strlen(s)<5){
            printf("no solution");
            break;
        }
        bool key=false;
        for(int i=0;i<strlen(s);i++)
            f[s[i]-‘@‘]=1;
        for(int a=26;a>0&&!key;a--)
        for(int b=26;b>0&&!key;b--){
            if(b!=a)
            for(int c=26;c>0&&!key;c--){
                if(c!=b&&c!=a)
                for(int d=26;d>0&&!key;d--){
                    if(d!=c&&d!=b&&d!=a)
                    for(int e=26;e>0&&!key;e--){
                        if(e!=d&&e!=c&&e!=b&&e!=a)
                        if(f[a]&&f[b]&&f[c]&&f[d]&&f[e])
                        if(a-b*b+c*c*c-d*d*d*d+e*e*e*e*e==target){
                            key=true;
                            printf("%c%c%c%c%c\n",(char)a+64,(char)b+64,(char)c+64,(char)d+64,(char)e+64);
                        }
                    }
                }
            }
        }
        if(!key) printf("no solution\n");
    }
    return 0;
}
时间: 2024-11-05 11:36:17

HDOJ 1015 Safecracker的相关文章

hdoj 1015 Safecracker【DFS】

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10612    Accepted Submission(s): 5429 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Kle

HDU 1015 Safecracker 题解

Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in Wo

hdu 1015 Safecracker (纯暴力)

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8183    Accepted Submission(s): 4143 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein

hdu 1015 Safecracker 水题一枚

题目链接:HDU - 1015 === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World

HDOJ 1015 Safecracker-DFS

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9548    Accepted Submission(s): 4860 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klei

HDU 1015 Safecracker【数值型DFS】

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3966    Accepted Submission(s): 2028 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein

HDU 1015 Safecracker(第一次用了搜索去遍历超时,第二次用for循环能够了,思路一样的)

Safecracker Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 3   Accepted Submission(s) : 1 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe b

hdu 1015 Safecracker DFS解法 ,简单明了

Safecracker Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9327    Accepted Submission(s): 4721 Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klei

HDU 1015 Safecracker(DFS)

Safecracker Problem Description === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were des