hdu4322 最大费用最大流

http://acm.hdu.edu.cn/showproblem.php?pid=4322

Problem Description

There are N candies and M kids, the teacher will give this N candies to the M kids. The i-th kids for the j-th candy has a preference for like[i][j], if he like the sugar, like[i][j] = 1, otherwise like[i][j] = 0. If the i-th kids get the candy which he like
he will get K glad value. If he or she do not like it. He will get only one glad value. We know that the i-th kids will feel happy if he the sum of glad values is equal or greater than B[i]. Can you tell me whether reasonable allocate this N candies, make
every kid feel happy.

Input

The Input consists of several cases .The first line contains a single integer t .the number of test cases.

For each case starts with a line containing three integers N, M, K (1<=N<=13, 1<=M<=13, 2<=K<=10)

The next line contains M numbers which is B[i](0<=B[i]<=1000). Separated by a single space.

Then there are M*N like[i][j] , if the i-th kids like the j-th sugar like[i][j]=1 ,or like[i][j]=0.

Output

If there have a reasonable allocate make every kid feel happy, output "YES", or "NO".

Sample Input

2
3 2 2
2 2
0 0 0
0 0 1

3 2 2
2 2
0 0 0
0 0 0

Sample Output

Case #1: YES
Case #2: NO

Hint

Give the first and second candy to the first kid.
Give the third candy to the second kid.
This allocate make all kids happy.
/**
hdu 4322  最大费用最大流

题目大意:(题解转)
        like[i][j]表示第i个孩子喜欢第j个糖果(总共m个孩子,n个糖)。 如果孩子拿到他喜欢的糖果,那么他将会增加k个欢乐值;
        拿到不喜欢的,增加1。 如果孩子i的欢乐值大于B[i],那么他才是开心的。能否有一种分配方案,让所有孩子都开心。
解题思路:
          首先声明,由于被小孩子不喜欢的糖果的对小孩产生的效力是一样的,所以我们在网络流的时候先不考虑。
          1 - 源点0到1~N个糖果,容量为1,费用为0
          2 - 根据like数组,like[i][j] == 1时在糖果j和人N+i之间建立有一条边,容量为1,费用为0
          3*- 根据b[i]和K的值建立小孩和汇点之间的边:
          如果b[i] 是 K 的倍数, 说明花费b[i] / K个喜欢的糖果可以达到b[i],建立一条边,费用为K,容量为b[i] / K;
          否则,将这条边拆为两部分,第一部分是b[i] / K的部分,第二部分根据b[i] % K的部分。(如果b[i] % k == 0,说明b[i]是k的倍数;
          若b[i] % k == 1, 特殊糖果和一般糖果价值一样,没必要当做特殊糖果处理)
          建好图后,求最大费用最大流(只需将费用改为负的,然后套最小费用最大流即可).。
          得出特殊糖果匹配b[i]的最大值。看剩余的普通糖果是否满足缺少的b[i]。
*/
#include <iostream>
#include <string.h>
#include <algorithm>
#include <cstdio>

using namespace std;

const int oo=1e9;//无穷大
const int maxm=1111;//边的最大数量,为原图的两倍
const int maxn=42;//点的最大数量

int node,src,dest,edge;//node节点数,src源点,dest汇点,edge边数
int head[maxn],p[maxn],dis[maxn],q[maxn],vis[maxn];//head链表头,p记录可行流上节点对应的反向边,dis计算距离
int n,m,k,dist[maxn],lik[maxn][maxn],Flow;

struct edgenode
{
    int to;//边的指向
    int flow;//边的容量
    int cost;//边的费用
    int next;//链表的下一条边
} edges[maxm];

void prepare(int _node,int _src,int _dest);
void addedge(int u,int v,int f,int c);
bool spfa();

inline int min(int a,int b)
{
    return a<b?a:b;
}

inline void prepare(int _node,int _src,int _dest)
{
    node=_node;
    src=_src;
    dest=_dest;
    for (int i=0; i<node; i++)
    {
        head[i]=-1;
        vis[i]=false;
    }
    edge=0;
}

void addedge(int u,int v,int f,int c)
{
    edges[edge].flow=f;
    edges[edge].cost=c;
    edges[edge].to=v;
    edges[edge].next=head[u];
    head[u]=edge++;
    edges[edge].flow=0;
    edges[edge].cost=-c;
    edges[edge].to=u;
    edges[edge].next=head[v];
    head[v]=edge++;
}

bool spfa()
{
    int i,u,v,l,r=0,tmp;
    for (i=0; i<node; i++) dis[i]=oo;
    dis[q[r++]=src]=0;
    p[src]=p[dest]=-1;
    for (l=0; l!=r; ((++l>=maxn)?l=0:1))
    {
        for (i=head[u=q[l]],vis[u]=false; i!=-1; i=edges[i].next)
        {
            if (edges[i].flow&&dis[v=edges[i].to]>(tmp=dis[u]+edges[i].cost))
            {
                dis[v]=tmp;
                p[v]=i^1;
                if (vis[v]) continue;
                vis[q[r++]=v]=true;
                if (r>=maxn) r=0;
            }
        }
    }
    return p[dest]>=0;
}

int spfaflow()
{
    int i,ret=0,delta;
    while (spfa())
    {
        //按记录原路返回求流量

        for (i=p[dest],delta=oo; i>=0; i=p[edges[i].to])
        {
            delta=min(delta,edges[i^1].flow);
        }
        for (int i=p[dest]; i>=0; i=p[edges[i].to])
        {
            edges[i].flow+=delta;
            edges[i^1].flow-=delta;
        }
        ret+=delta*dis[dest];
        Flow+=delta;
    }
    return ret;
}

int main()
{
    int T,tt=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        int sum=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d",&dist[i]);
            sum+=dist[i];
        }
        prepare(n+m+2,0,n+m+1);
        for(int i=1; i<=n; i++)
        {
            addedge(src,i,1,0);
        }
        for(int i=1; i<=m; i++)
        {
            for(int j=1; j<=n; j++)
            {
                int u;
                scanf("%d",&u);
                if(u==1)
                {
                    addedge(j,i+n,1,0);
                }
            }
        }
        for(int i=1;i<=m;i++)
        {
            addedge(i+n,dest,dist[i]/k,-k);
            if(dist[i]%k>1)
            {
                addedge(i+n,dest,1,-dist[i]%k);
            }
        }
        printf("Case #%d: ",++tt);
        Flow=0;
        int cost=spfaflow();
        if(sum+cost<=n-Flow)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
时间: 2024-11-03 11:10:23

hdu4322 最大费用最大流的相关文章

hdu4322 candy 费用流

题意: n个糖果,m个孩子,给一个矩阵like[i][j]表示第i个孩子喜欢第j个糖果. 如果孩子拿到他喜欢的糖果,那么他将会增加k个快乐度,拿到不喜欢的,增加1. 如果孩子i的欢乐值大于B[i],那么他就是开心的. 问,能否有一种分配方案,让所有孩子都开心,有输出yes,没有no. 思路:(讲的不好请见谅,大牛勿喷) 起初是看了一个大牛的一篇关于网络流建模的总结,里面有个跟这个题同名的题,只是它里面k是固定的就是2.里面的做法是用单纯的最大流做的,没有考虑到费用.建图是这样的,每颗糖作为一个点

【BZOJ3876】【Ahoi2014】支线剧情 有下界的最小费用最大流

#include <stdio.h> int main() { puts("转载请注明出处谢谢"); puts("http://blog.csdn.net/vmurder/article/details/43025375"); } [BZOJ2324]营救皮卡丘 这道题也是一道有下界的最小费用最大流. 我的题解地址:http://blog.csdn.net/vmurder/article/details/41378979 这道题其实就是模板题. 我的处理

POJ 3686.The Windy&#39;s 最小费用最大流

The Windy's Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 5477   Accepted: 2285 Description The Windy's is a world famous toy factory that owns M top-class workshop to make toys. This year the manager receives N orders for toys. The ma

P3381 【模板】最小费用最大流

P3381 [模板]最小费用最大流 题目描述 如题,给出一个网络图,以及其源点和汇点,每条边已知其最大流量和单位流量费用,求出其网络最大流和在最大流情况下的最小费用. 输入输出格式 输入格式: 第一行包含四个正整数N.M.S.T,分别表示点的个数.有向边的个数.源点序号.汇点序号. 接下来M行每行包含四个正整数ui.vi.wi.fi,表示第i条有向边从ui出发,到达vi,边权为wi(即该边最大流量为wi),单位流量的费用为fi. 输出格式: 一行,包含两个整数,依次为最大流量和在最大流量情况下的

C++之路进阶——最小费用最大流(支线剧情)

F.A.Qs Home Discuss ProblemSet Status Ranklist Contest ModifyUser  hyxzc Logout 捐赠本站 Notice:由于本OJ建立在Linux平台下,而许多题的数据在Windows下制作,请注意输入.输出语句及数据类型及范围,避免无谓的RE出现. 3876: [Ahoi2014]支线剧情 Time Limit: 10 Sec  Memory Limit: 256 MBSubmit: 542  Solved: 332[Submit

hdu 4494 Teamwork 最小费用最大流

Teamwork Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=4494 Description Some locations in city A has been destroyed in the fierce battle. So the government decides to send some workers to repair these location

POJ - 2195 Going Home(最小费用最大流)

1.N*M的矩阵中,有k个人和k个房子,每个人分别进入一个房子中,求所有人移动的最小距离. 2.人看成源点,房子看成汇点,求最小费用最大流. 建图-- 人指向房子,容量为1,费用为人到房子的曼哈顿距离. 建立超级源点和超级汇点:超级源点指向人,容量为1,费用为0:超级汇点指向房子,容量为1,费用为0. 求超级源点到超级汇点的最小费用最大流即可. ps:容量为什么都设为1?---有待研究.. 3. 1.Bellman-Ford: #include<iostream> #include<st

hdu 1853 Cyclic Tour 最小费用最大流

题意:一个有向图,现在问将图中的每一个点都划分到一个环中的最少代价(边权和). 思路:拆点,建二分图,跑最小费用最大流即可.若最大流为n,则说明是最大匹配为n,所有点都参与,每个点的入度和出度又是1,所以就是环. /********************************************************* file name: hdu1853.cpp author : kereo create time: 2015年02月16日 星期一 17时38分51秒 *******

最小费用最大流

Farm Tour http://poj.org/problem?id=2135 建图再说吧 1 #include<cstdio> 2 #include<cstring> 3 #include<cstdlib> 4 #include<cmath> 5 #include<map> 6 #include<stack> 7 #include<queue> 8 #include<vector> 9 #include&l