HDU 4800 Josephina and RPG(动态规划)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4800

题面:

Josephina and RPG

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1077    Accepted Submission(s): 320

Special Judge

Problem Description

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal
acting or through a process of structured decision-making or character development.

Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.

The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination
as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the
challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.

Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning
rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers
which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

Sample Input

4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2

Sample Output

0.378000

Source

2013 Asia Changsha Regional Contest

解题:

每三个人组成一只队伍,所以R的大小为C(3,n)。给出的数组是某种组合对应某种组合的获胜几率。开始可以任选一种组合。dp[i][j]代表的是,i这个位置当前选用了j这个组合的成功率。由常规的i-1推到i似乎很难推,因为并不知道之前使用的是什么或者说之前是否进行了替换。此时就要进行转换,由i推到i+1。

dp[i+1][j]=max(dp[i+1][j],dp[i][j]*rate[j][rival[i+1]]);
dp[i+1][rival[i]]=max(dp[i+1][rival[i]],dp[i][j]*rate[rival[i]][rival[i+1]]);

下一位置的dp[i+1][j]的值为其原先值,和在i+1位置保持用j的成功率的最大值。

下一位置的dp[i+1][rival[i]]的值为其原先值,和在i+1位置用上一轮打败的对手的成功率的最大值。

答案即为遍历最后一个位置取所有组合中最大的一个。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;
double rate[260][260],dp[10010][260],ans;
int rival[10010];
double max(double a,double b)
{
	return a>b?a:b;
}
int C(int a,int b)
{
	int res=1;
	for(int i=1;i<=a;i++)
		res=res*(b-i+1)/i;
	return res;
}
int main()
{
    int n,t;
	while(scanf("%d",&n)!=EOF)
	{
	  n=C(3,n);
	  ans=0.0;
      for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
			scanf("%lf",&rate[i][j]);
      scanf("%d",&t);
	  for(int i=0;i<t;i++)
		  scanf("%d",&rival[i]);
	  for(int i=0;i<t;i++)
		  for(int j=0;j<n;j++)
			  dp[i][j]=0.0;
      for(int i=0;i<n;i++)
		  dp[0][i]=rate[i][rival[0]];
	  for(int i=0;i<t-1;i++)
	  {
		  for(int j=0;j<n;j++)
		  {
			  dp[i+1][j]=max(dp[i+1][j],dp[i][j]*rate[j][rival[i+1]]);
			  dp[i+1][rival[i]]=max(dp[i+1][rival[i]],dp[i][j]*rate[rival[i]][rival[i+1]]);
		  }
	  }
	  for(int i=0;i<n;i++)
		  ans=max(ans,dp[t-1][i]);
	  printf("%.6lf\n",ans);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-21 09:58:30

HDU 4800 Josephina and RPG(动态规划)的相关文章

hdu 4800 Josephina and RPG (动态规划)

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 923    Accepted Submission(s): 261 Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) i

HDU 4800 Josephina and RPG

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 605    Accepted Submission(s): 165Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) is

2013长沙赛区现场赛 J - Josephina and RPG

J - Josephina and RPG Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 4800 Description A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of cha

Josephina and RPG 简单概率DP

Josephina and RPG 题目抽象:给出R=C(m,3)个队伍之间的胜率.给出需要挑战的n个队伍(按顺序).玩家最开始从R个队伍中任选一支队伍去挑战,当挑战某队伍成功时,可以将当前的队伍与挑战成功的队伍交换,也可以继续选择该队伍.  求最大的胜率. 思路:物理递推法. /*                    dp[i+1][j]            dp[i][j]=                    dp[i+1][num[i]]*/ 1 #include <iostrea

HDU 1160 FatMouse&#39;s Speed 动态规划 记录路径的最长上升子序列变形

题目大意:输入数据直到文件结束,每行两个数据 体重M 和 速度V,将其排列得到一个序列,要求为:体重越大 速度越低(相等则不符合条件).求这种序列最长的长度,并输出路径.答案不唯一,输出任意一种就好了. 题目思路:这是个最长上升子序列的问题,我们按W的升序进行排序,若W相等则按V的降序排序.用Pre[]记录当前点的前驱节点,Last记录序列最后一个点,maxn记录最长长度,完成动规后可根据Last和Pre[]输出路径. #include<cstdio> #include<stdio.h&

HDU 1505 Largest Rectangle in a Histogram &amp;&amp; HDU 1506 City Game(动态规划)

1506题意:给你连续的直方图(底边边长为1),求连续的矩阵面积. 对每个直方图,分别向左向右进行扩展. #include<cstdio> #include<stdlib.h> #include<string.h> #include<string> #include<map> #include<cmath> #include<iostream> #include <queue> #include <sta

hdu4800 Josephina and RPG

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 511    Accepted Submission(s): 139Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) is

Josephina and RPG

Josephina and RPG Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 929    Accepted Submission(s): 265Special Judge Problem Description A role-playing game (RPG and sometimes roleplaying game) is

HDU 4336 Card Collector(动态规划-概率DP)

Card Collector Problem Description In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. As a