hdu4268 Alice and Bob,multiset

Alice and Bob

Problem Description

Alice and Bob‘s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob‘s. The card A can cover the card B if the height of A is not smaller than
B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob‘s cards that Alice can cover.

Please pay attention that each card can be used only once and the cards cannot be rotated.

Input

The first line of the input is a number T (T <= 40) which means the number of test cases.

For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and
width of Alice‘s card, then the following N lines means that of Bob‘s.

Output

For each test case, output an answer using one line which contains just one number.

Sample Input

2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4 

Sample Output

1
2

题意:

有童鞋A 和 童鞋B

A想用手里的牌尽量多地覆盖掉B手中的牌..

给出了T表示有T组样例..

每组样例给出一个n 表示A和B手中都有n张牌

接下来2*n行 有h w 分别代表A手中n张牌的高和宽 以及 B手中n张牌的高和宽

问A手中的牌最多能覆盖B多少张牌

Sort、 Multiset

#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100000 + 10;
struct Node {
    int w, h;
    bool operator < (const Node& rhs) const
    {
        return w < rhs.w;
    }
};

Node A[maxn], B[maxn];

multiset<int> ms;
multiset<int>::iterator it;
int n;

int main()
{
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        for(int i=0; i<n; ++i) {
            scanf("%d%d", &A[i].w, &A[i].h);
        }
        for(int i=0; i<n; ++i) {
            scanf("%d%d", &B[i].w, &B[i].h);
        }

        sort(A, A+n);
        sort(B, B+n);
        int ans = 0;
        ms.clear();

        for(int i=0, j=0; i<n; ++i) {
            while(j<n&&A[i].w>=B[j].w) {
                ms.insert(B[j++].h);
            }
            if(ms.empty()) continue;
            it = ms.upper_bound(A[i].h);
            if(it != ms.begin()) {
                ms.erase(--it);
                ans++;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
时间: 2024-10-31 11:58:52

hdu4268 Alice and Bob,multiset的相关文章

HDU4268 Alice and Bob 【贪心】

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2869    Accepted Submission(s): 926 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

HDU 4268 Alice and Bob(贪心+multiset)

HDU 4268 题意:Alice与Bob在玩卡片游戏,他们每人有n张卡片,若Alice的一张卡片长与宽都不小于Bob的一张卡片,则Bob的卡片就会被盖住,一张卡片只可以使用一次,且不可旋转求Alice最多可以盖住多少张Bob的卡片. 思路:记录两人卡片情况,并按照长度将两人卡片分别降序排序.遍历两人的卡片,将长度小于Alice的卡片长度的Bob卡片的宽度插入multiset中,在multiset中找到小于等于Alice卡片宽度的第一个数,将这个数给消去且答案+1.//贪心法自行发挥即可. co

hdu 4268 Alice and Bob(贪心+multiset+二分)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3511    Accepted Submission(s): 1129 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In thi

hdu 4268 Alice and Bob(multiset)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4268 题目大意:就是问你Alice的牌能覆盖Bob牌最多数量.牌不能翻转 思路:首先我们不分种类,把牌按高度排序,然后我们在依次判断牌的种类,如果是Bob的牌,我们就他牌的宽度放入multiset中,如果是Alice的牌就在multiset中找到宽度最大的那一张并删掉. #include<cstdio> #include<iostream> #include<cstring>

zoj 3666 Alice and Bob , SG函数

题意: 在一个有向无环图上,有若干玩具,每人每次只能将一个玩具移动一步,玩具被移动到终点n将不能再被移动了,最后不能移动者输. 组合博弈 SG函数应用 #include<vector> #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn = 10000 + 100; int SG[maxn]; vector<int>

ZOJ 3757 Alice and Bob and Cue Sports(模拟)

题目链接 题意 : 玩台球.Alice 和 Bob,一共可以进行m次,Alice 先打.有一个白球和n个标有不同标号的球,称目标球为当前在桌子上的除了白球以外的数值最小的球,默认白球的标号为0.如果白球落入洞中,要把白球拿出来放在桌子上,如果是其他的球就不拿哪怕是犯规打进去的.每打一局(每一局代表每人打一杆)时当发生以下三种行为时算是犯规,会将相应的罚分加给对方,自己不减分. 白球没有打中任何球.将目标球的数值加到对方的分数上. 白球没有入洞且至少打中一个球,一开始没有打中目标球或者一开始同时打

HDU 4268 Alice and Bob(贪心+Multiset的应用)

 题意: Alice和Bob有n个长方形,有长度和宽度,一个矩形可以覆盖另一个矩形的条件的是,本身长度大于等于另一个矩形,且宽度大于等于另一个矩形,矩形不可旋转,问你Alice最多能覆盖Bob的几个矩形? 思路:贪心,先按照h将Alice和Bob的矩形排序,对于Alice的每个矩形,如果Bob的矩形的h小于Alice的h,将Bob的w插入到集合中. 然后,在集合中找到不大于Alice矩形d的最大的Bob的d,那么这样做肯定是最优的. #include<cstdio> #include<

HDU 4268 Alice and Bob(multiset的使用)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3046    Accepted Submission(s): 995 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

hdu 4268 Alice and Bob(multiset|段树)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2901    Accepted Submission(s): 941 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this