hdoj 4841 圆桌问题 【模拟】

圆桌问题

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 299    Accepted Submission(s): 107

Problem Description

圆桌上围坐着2n个人。其中n个人是好人,另外n个人是坏人。如果从第一个人开始数数,数到第m个人,则立即处死该人;然后从被处死的人之后开始数数,再将数到的第m个人处死……依此方法不断处死围坐在圆桌上的人。试问预先应如何安排这些好人与坏人的座位,能使得在处死n个人之后,圆桌上围坐的剩余的n个人全是好人。

Input

多组数据,每组数据输入:好人和坏人的人数n(<=32767)、步长m(<=32767);

Output

对于每一组数据,输出2n个大写字母,‘G’表示好人,‘B’表示坏人,50个字母为一行,不允许出现空白字符。相邻数据间留有一空行。

Sample Input

2 3
2 4

Sample Output

GBBG

BGGB

注意换行。。。

代码:

#include <cstdio>
#include <cstring>
const int M = 33000;

int s[M<<1];

void f(int n, int m){
    int t, i, j;
    j = 0;
    for(i = 0; i < n; i ++){
        int cou = 0;
        while(cou < m){
            if(s[j] == 0) ++cou;
            if(cou >= m) break;
            j ++;
            if(j == 2*n) j = 0;

        }
        s[j] = 1;
    }
}

int main(){
   int n, m;
    while(scanf("%d%d", &n, &m) == 2){
        memset(s, 0, sizeof(s));
        f(n, m);
        int i;
        for(i = 0; i < 2*n; i ++){
            if(i&&i%50 == 0) printf("\n");
            printf("%c", s[i]?'B':'G');
        }
        printf("\n\n");
    }
    return 0;
}
时间: 2024-10-30 14:06:13

hdoj 4841 圆桌问题 【模拟】的相关文章

hdu 4841 圆桌问题(用vector模拟约瑟夫环)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4841 圆桌问题 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 104    Accepted Submission(s): 17 Problem Description 圆桌上围坐着2n个人.其中n个人是好人,另外n个人是坏人.如果从第一

HDOJ 2317. Nasty Hacks 模拟水题

Nasty Hacks Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3049    Accepted Submission(s): 2364 Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of

hdu 4841 圆桌问题

最近写广搜,突发奇想看能不能用队列来模拟约瑟夫问题,然后就a了这道题,用队列居然比链表慢不了多少. #include<iostream> #include<queue> using namespace std; int main() { int n,m; while(cin>>n>>m) { int a[2*n]; queue<int>root; for(int i=0;i<2*n;i++) { a[i]=1; root.push(i);

HDOJ 4699 Editor 栈 模拟

用两个栈模拟: Editor Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1913    Accepted Submission(s): 591 Problem Description Sample Input 8 I 2 I -1 I 1 Q 3 L D R Q 2 Sample Output 2 3 Hint The fol

hdu 4841 圆桌问题 | vector 容器的使用

Problem Description 圆桌上围坐着2n个人.其中n个人是好人,另外n个人是坏人.如果从第一个人开始数数,数到第m个人,则立即处死该人:然后从被处死的人之后开始数数,再将数到的第m个人处死--依此方法不断处死围坐在圆桌上的人.试问预先应如何安排这些好人与坏人的座位,能使得在处死n个人之后,圆桌上围坐的剩余的n个人全是好人. Input 多组数据,每组数据输入:好人和坏人的人数n(<=32767).步长m(<=32767): Output 对于每一组数据,输出2n个大写字母,'G

HDOJ 5387 Clock 水+模拟

Clock Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 316    Accepted Submission(s): 215 Problem Description Give a time.(hh:mm:ss),you should answer the angle between any two of the minute.hou

模拟 HDOJ 4552 Running Rabbits

题目传送门 1 /* 2 模拟:看懂题意,主要是碰壁后的转向,笔误2次 3 */ 4 #include <cstdio> 5 #include <algorithm> 6 #include <cstring> 7 #include <vector> 8 using namespace std; 9 10 const int MAXN = 1e3 + 10; 11 const int INF = 0x3f3f3f3f; 12 struct Rabbit 13

模拟 HDOJ 5387 Clock

题目传送门 1 /* 2 模拟:这题没啥好说的,把指针转成角度处理就行了,有两个注意点:结果化简且在0~180内:小时13点以后和1以后是一样的(24小时) 3 模拟题伤不起!计算公式在代码内(格式:hh/120, mm/120, ss/120) 4 */ 5 /************************************************ 6 * Author :Running_Time 7 * Created Time :2015-8-13 13:04:31 8 * Fil

HDOJ 题目5097 Page Rank(矩阵运算,模拟)

Page Rank Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others) Total Submission(s): 280    Accepted Submission(s): 75 Problem Description Evaluation and rank of web pages is a hot topic for many internet companies and