hdu 5326 Work

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5326

Work

Description

It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.

Input

There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n

Output

For each test case, output the answer as described above.

Sample Input

7 2
1 2
1 3
2 4
2 5
3 6
3 7

Sample Output

2

统计子树大小为k的节点数。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<set>
using std::set;
using std::pair;
using std::swap;
using std::queue;
using std::multiset;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) decltype((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 110;
const int INF = 0x3f3f3f3f;
struct edge { int to, next; }G[N << 1];
bool inq[N];
int tot, size[N], head[N];
void init(int n) {
    tot = 0;
    rep(i, n + 1) {
        head[i] = -1;
        inq[i] = size[i] = false;
    }
}
inline void add_edge(int u, int v) {
    G[tot].to = v, G[tot].next = head[u], head[u] = tot++;
}
void dfs(int u) {
    size[u] = 1;
    for (int i = head[u]; ~i; i = G[i].next) {
        edge &e = G[i];
        dfs(e.to);
        size[u] += size[e.to];
    }
}
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int n, k, u, v;
    while (~scanf("%d %d", &n, &k)) {
        init(n);
        rep(i, n - 1) {
            scanf("%d %d", &u, &v);
            add_edge(u, v);
            inq[v] = true;
        }
        for(int i = 1; i <= n; i++) {
            if (!inq[i]) {
                u = i;
                break;
            }
        }
        int sum = 0;
        dfs(u);
        for (int i = 1; i <= n; i++) {
            if (size[i] == k + 1) sum++;
        }
        printf("%d\n", sum);
    }
    return 0;
}
时间: 2024-10-11 06:37:09

hdu 5326 Work的相关文章

HDU 5326(2015多校3)-Work(dfs)

题目地址:HDU 5326 题意:给一张有向图n个点,n - 1(....输入n-1)条边. A指向B代表A管理B,然后可以间接管理,比如A管理B,B管理C,则A管理C. 现在问管理k个人的人有多少个. #include <stdio.h> #include <math.h> #include <string.h> #include <stdlib.h> #include <iostream> #include <sstream> #

hdu 5326 Work 水题

Work Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 225    Accepted Submission(s): 166 Problem Description It’s an interesting experience to move from ICPC to work, end my college life and star

hdu 5326 Work【并查集】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5326 题意:n个点 ,给你m有向条边,表示起点是终点的父亲.问子孙节点个数是K的节点有几个? 解法:并查集. 代码: #include <stdio.h> #include <ctime> #include <math.h> #include <limits.h> #include <complex> #include <string>

hdu 5326 Work(杭电多校赛第三场)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5326 Work Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 583    Accepted Submission(s): 392 Problem Description It’s an interesting experience to

HDU 5326 Work (基础树形dp)

Work Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 27    Accepted Submission(s): 19 Problem Description It's an interesting experience to move from ICPC to work, end my college life and start

hdu 5326(基础题) work

http://acm.hdu.edu.cn/showproblem.php?pid=5326 一道水题,题目大意是在公司里,给出n个员工和目标人数m,然后下面的n-1行是表示员工a管理b,问在这些员工中有多少管理员工的人数是k 起初想的是并查集,后来发现没那么简单,因为两者之间的关系有方向的,a管理b是单向的从b指到a,所以并查集的一个集合里包含了很多种关系 还需要用一个二维数组表示关系,它是一环扣一环的从a找到b再从b找到c......因为如果b管理c,a又管理b,那么a也管理c code 1

hdu 5326

Work Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 618    Accepted Submission(s): 412 Problem Description It's an interesting experience to move from ICPC to work, end my college life and sta

hdu 5326 dfs

多校签到题,dfs一下就好了. 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 using namespace std; 5 6 const int N = 101; 7 int head[N]; 8 int sum[N]; 9 bool f[N]; 10 int n, k, e; 11 12 struct Edge 13 { 14 int v, next; 15 } edge[N]; 1

HDU 5326 work (回溯,树)

题意:给一棵树,每个结点的子树下的结点都是它的统治对象,问有多少个统治对象数目为k的结点? 思路:每个结点都设一个cnt来记数,只要将每个结点往上回溯,直到树根,经过的每个结点都将计数器加1.最后再扫一遍,将cnt等于k的结点统计一下. #include <bits/stdc++.h> #define LL long long #define pii pair<int,int> #define INF 0x7f7f7f7f using namespace std; const in