HDOJ1198 Farm Irrigation 【并查集】

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5051    Accepted Submission(s): 2167

Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows. Figure 1 Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map ADC FJK IHE then the water pipes are distributed like Figure 2 Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.   Input There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.   Output For each test case, output in one line the least number of wellsprings needed.   Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

思路是开始将喷泉数赋值为土地块数,然后每次判断右边和下边的点是否与该点联通,若联通再判断是否属于同一个集合,若不属于同一个集合则喷泉数减一并合并成同一个集合。感觉这题貌似也可以用深搜~

//并查集
#include <stdio.h>
struct Node{
	bool up, down, left, right;
}node[] =
{1, 0, 1, 0, //A
 1, 0, 0, 1, //B
 0, 1, 1, 0, //C
 0, 1, 0, 1, //D
 1, 1, 0, 0, //E
 0, 0, 1, 1, //F
 1, 0, 1, 1, //G
 1, 1, 1, 0, //H
 0, 1, 1, 1, //I
 1, 1, 0, 1, //J
 1, 1, 1, 1};//K

char a[52][52];

struct NODE{
	int r, c;
}pre[52][52];

NODE find(NODE k){ //查找与压缩
	NODE i = k;
	while(!(i.r == pre[i.r][i.c].r && i.c == pre[i.r][i.c].c))
		i = pre[i.r][i.c];
	NODE j = k, t;
	while(j.r != i.r || j.c != i.c){
		t = pre[j.r][j.c];
		pre[j.r][j.c] = i;
		j = t;
	}
	return i;
}

int main(){
	int m, n, sum;
	NODE x, y, z;
	char ch;
	while(scanf("%d%d", &m, &n)){
		if(m < 0 || n < 0) break;

		sum = n * m;

		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j){
				pre[i][j].r = i;
				pre[i][j].c = j;
			}

		getchar();
		for(int i = 1; i <= m; ++i)
			gets(a[i] + 1);

		for(int i = 1; i <= m; ++i){
			for(int j = 1; j <= n; ++j){
				x = find(pre[i][j]);
				y = find(pre[i][j+1]);
				z = find(pre[i+1][j]);

				if(j < n && node[a[i][j]-‘A‘].right && node[a[i][j+1]-‘A‘].left){
					if(x.r != y.r || x.c != y.c){ //如果两点联通但又不在一个集合
						--sum;
						pre[y.r][y.c] = x; //联通
					}
				}

				if(i < m && node[a[i][j]-‘A‘].down && node[a[i+1][j]-‘A‘].up){
					if(x.r != z.r || x.c != z.c){
						--sum;
						pre[z.r][z.c] = x;
					}
				}
			}
		}

		printf("%d\n", sum);
	}
	return 0;
}
时间: 2024-12-12 15:30:23

HDOJ1198 Farm Irrigation 【并查集】的相关文章

HDU 1198 Farm Irrigation (并查集)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5809    Accepted Submission(s): 2516 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle,

HDU--1198 Farm Irrigation (并查集做法+DFS做法)

Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pi

并查集总结篇

1.模板题poj1611the suspects 每个组内的人,同一个组内都是感染者,问与"0"号人有关的有多少人 #include <iostream> #include<cstdio> using namespace std; const int MAXN = 1000100; struct DS { int f[MAXN]; void init(int n) { for(int i=0;i<n;i++) f[i]=i; } int ff(int x)

【简单并查集】Farm Irrigation

Farm Irrigation Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 6   Accepted Submission(s) : 3 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Benny has a spacious fa

hdu 1198 Farm Irrigation (搜索或并查集)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5818    Accepted Submission(s): 2521 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle

Farm Irrigation HDU - 1198 (并查集)

Farm Irrigation HDU - 1198 题意:给11种管道,问草地最少需要打多少个井才可以全部灌溉. 把每种管道的状态用二进制表示一下,然后对每一块草地,判断能否和上面或者左面的草地的管道连接. 然后并查集搞一下. 1 #include <bits/stdc++.h> 2 using namespace std; 3 const int maxn=55; 4 5 int g[12]={10,9,6,5,12,3,11,14,7,13,15}; 6 int f[maxn*maxn]

HDU1198水管并查集Farm Irrigation

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked

HDU 1198 Farm Irrigation(并查集,自己构造连通条件)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11188    Accepted Submission(s): 4876 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle

hdu 1198 Farm Irrigation(深搜dfs || 并查集)

转载请注明出处:viewmode=contents">http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1198 ----------------------------------------------------------------------------------------------------------------------