PAT 1072. Gas Station (30)

A gas station has to be built at such a location that the minimum distance
between the station and any of the residential housing is as far away as
possible.  However it must guarantee that all the houses are in its service
range.

Now given the map of the city and several candidate locations for the gas
station, you are supposed to give the best recommendation.  If there are
more than one solution, output the one with the smallest average distance to all
the houses.  If such a solution is still not unique, output the one with
the smallest index number.

Input Specification:

Each input file contains one test case.  For each case, the first line
contains 4 positive integers: N (<= 103), the total number of
houses; M (<= 10), the total number of the candidate locations for the gas
stations; K (<= 104), the number of roads connecting the houses
and the gas stations; and DS, the maximum service range of the gas
station.  It is hence assumed that all the houses are numbered from 1 to N,
and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format P1 P2 Dist where P1
and P2 are the two ends of a road which can be either house numbers or gas
station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best
location.  In the next line, print the minimum and the average distances
between the solution and all the houses.  The numbers in a line must be
separated by a space and be accurate up to 1 decimal place.  If the
solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

此题是一个常规题,主要用了dijkstra算法,其他的就是一些细节的处理了:

#include<iostream>
#include <map>
#include <vector>
#include <memory.h>
#include <algorithm>
#include <numeric>
#include <climits>
using namespace std;

const int N=1001;
const int M=11;
bool visited[M+N];
double Distance[M+N][M+N];
double minDis[M+N];

map<int,vector<int> > adjlist;

struct Gas
{
int index;
double minDis;
double averageDis;
bool operator<(const Gas& rhs) const
{
if(minDis!=rhs.minDis)
return minDis>rhs.minDis;
if(averageDis!=rhs.averageDis)
return averageDis<rhs.averageDis;
return index<rhs.index;
}
}GasStations[M];

int str2int(char p[],int n)
{
int indicator=0;
if(p[0]==‘G‘)
indicator=1;
int index=indicator==0?0:n;
index+=atoi(p+indicator);
return index;
};

void reset()
{
memset(visited,false,sizeof(bool)*(N+M));
for(int i=0;i<N+M;++i)
minDis[i]=-1.0;
}

void dijkstra(int source,int n)
{
reset();
visited[source]=true;
minDis[source]=0;
int newP=source;
for(int i=1;i<n;++i)
{
size_t size=adjlist[newP].size();
for(int j=0;j<size;++j)
{
int child=adjlist[newP][j];
if(visited[child])
continue;
if(minDis[child]<0||minDis[child]>minDis[newP]+Distance[newP][child])
minDis[child]=minDis[newP]+Distance[newP][child];
}
int min=INT_MAX;
for(int k=1;k<=n;++k)
{
if(visited[k]||minDis[k]<0)
continue;
if(minDis[k]<min)
{
min=minDis[k];
newP=k;
}
}
visited[newP]=true;
}
}

int main(int argc, char *argv[])
{
int n,m,k,Ds;
scanf("%d %d %d %d",&n,&m,&k,&Ds);
int i=0;
char p1[5],p2[5];
int idx1,idx2;
for(;i<k;++i)
{
scanf("%s %s",p1,p2);
idx1=str2int(p1,n);
idx2=str2int(p2,n);
scanf("%lf",&Distance[idx1][idx2]);
Distance[idx2][idx1]=Distance[idx1][idx2];
adjlist[idx1].push_back(idx2);
adjlist[idx2].push_back(idx1);
}
int candidates=0;
for(i=0;i<m;++i)
{
int source=n+i+1;
dijkstra(source,n+m);
int j=1;
for(;j<=n;++j)
if(minDis[j]>Ds)
break;
if(j==n+1)
{
GasStations[candidates].index=i+1;
GasStations[candidates].minDis=*min_element(minDis+1,minDis+n+1);
GasStations[candidates].averageDis=accumulate(minDis+1,minDis+n+1,0);
++candidates;
}
}
if(0==candidates)
{
printf("No Solution\n");
return 0;
}
sort(GasStations,GasStations+candidates);
printf("G%d\n%.1f %.1f\n",GasStations[0].index,GasStations[0].minDis,GasStations[0].averageDis/n);
return 0;
}


View
Code

PAT 1072. Gas Station (30)

时间: 2024-07-30 10:18:22

PAT 1072. Gas Station (30)的相关文章

PAT 1072 Gas Station[图论][难]

1072 Gas Station (30)(30 分) A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service

1072. Gas Station (30)

先要求出各个加油站 最短的 与任意一房屋之间的 距离D,再在这些加油站中选出最长的D的加油站 ,该加油站 为 最优选项 (坑爹啊!).如果相同D相同 则 选离各个房屋平均距离小的,如果还是 相同,则 选 编号小的. 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A gas station has to be built at such a location that the minimum distance

1072 Gas Station (30)(30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range. Now given the map of

PAT甲题题解-1072. Gas Station (30)-dijkstra最短路

题意:从m个加油站里面选取1个站点,使得其离住宅的最近距离mindis尽可能地远,并且离所有住宅的距离都在服务范围ds之内.如果有很多相同mindis的加油站,输出距所有住宅平均距离最小的那个.如果平均值还是一样,就输出按照顺序排列加油站编号最小的. 分析:加油站之间也是彼此有路连接的,所以最短路径计算的时候也要把加油站算上,是双向边,所以边的数组大小得开两倍.加油站编号记为n+1~n+m,对这些点用dijkstra计算最短路径即可,这里顺便在dijkstra中进行了剪枝处理,不剪枝也没事. #

PAT (Advanced Level) 1072. Gas Station (30)

枚举一下选的位置,每次算一下就可以了. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; const int

pat1072. Gas Station (30)

1072. Gas Station (30) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. H

A1072. Gas Station (30)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range. Now given the map of

PAT Gas Station

Gas Station A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range. Now give

Gas Station

There are N gas stations along a circular route, where the amount of gas at station i is gas[i]. You have a car with an unlimited gas tank and it costs cost[i] of gas to travel from station i to its next station (i+1). You begin the journey with an e