POJ 1287 Networking (最小生成树)

Networking

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Submit Status Practice POJ 1287

Appoint description: 
System Crawler  (2015-06-02)

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

const    int    SIZE = 105;
int    N,M;
int    FATHER[SIZE];
int    MAP[SIZE][SIZE];
struct    Node
{
    int    from,to,cost;
}G[SIZE];

void    ini(void);
int    find_father(int);
void    unite(int,int);
bool    same(int,int);
bool    comp(const Node &,const Node &);
int    kruskal(void);
int    main(void)
{
    int    from,to,cost;

    while(~scanf("%d",&N))
    {
        if(!N)
            break;
        scanf("%d",&M);
        ini();
        for(int i = 0;i < M;i ++)
            scanf("%d%d%d",&G[i].from,&G[i].to,&G[i].cost);
        sort(G,G + M,comp);
        printf("%d\n",kruskal());
    }

    return    0;
}

void    ini(void)
{
    fill(&MAP[0][0],&MAP[SIZE - 1][SIZE - 1],-1);
    for(int i = 1;i <= N;i ++)
        FATHER[i] = i;
}

int    find_father(int n)
{
    if(n == FATHER[n])
        return    n;
    return    FATHER[n] = find_father(FATHER[n]);
}

void    unite(int x,int y)
{
    x = find_father(x);
    y = find_father(y);

    if(x == y)
        return    ;
    FATHER[x] = y;
}

bool    same(int x,int y)
{
    return    find_father(x) == find_father(y);
}

int    kruskal(void)
{
    int    ans = 0,count = 0;

    for(int i = 0;i < M;i ++)
        if(!same(G[i].from,G[i].to))
        {
            unite(G[i].from,G[i].to);
            ans += G[i].cost;
            count ++;

            if(count == N - 1)
                break;
        }
    return    ans;
}

bool    comp(const Node & a,const Node & b)
{
    return    a.cost < b.cost;
}
时间: 2024-10-21 09:39:08

POJ 1287 Networking (最小生成树)的相关文章

POJ 1287 Networking (最小生成树模板题)

Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

题目链接:ZOJ1372 POJ 1287 Networking 网络设计 Networking Time Limit: 2 Seconds      Memory Limit: 65536 KB You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible

[2016-04-14][POJ][1287][Networking]

时间:2016-04-14 14:48:44 星期四 题目编号:[2016-04-14][POJ][1287][Networking] 题目大意:求最小生成树 分析:直接prim算法,更新边的时候,重边取最小值 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn = 50 + 10; const int inf = 0x3f3f3f3f; i

POJ 1287 Networking(最小生成树)

题意  给你n个点 m条边  求最小生成树的权 这是最裸的最小生成树了 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N = 55, M = 3000; int par[N], n, m, ans; struct edge{int u, v, w;} e[M]; bool cmp(edge a, edge b){return a.w < b

POJ - 1287 Networking

题目链接:http://poj.org/problem?id=1287 Sample Input 1 0 2 3 1 2 37 2 1 17 1 2 68 3 7 1 2 19 2 3 11 3 1 7 1 3 5 2 3 89 3 1 91 1 2 32 5 7 1 2 5 2 3 7 2 4 8 4 5 11 3 5 10 1 5 6 4 2 12 0 Sample Output 0 17 16 26 分析:最小生成树纯模板 1 #include <cstdio> 2 #include &

POJ 1287 Networking【MST模板题】

Networking Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 8214 Accepted: 4528 Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possib

poj 1679 判断最小生成树是否唯一

/* 只需判断等效边和必选边的个数和n-1的关系即可 */ #include<stdio.h> #include<stdlib.h> #define N 110 struct node { int u,v,w; }f[N*N*2]; int cmp(const void *a,const void*b) { return (*(struct node *)a).w-(*(struct node *)b).w; } int pre[N]; int find(int x) { if(x

poj 3723 Conscription(最小生成树拓展)

Conscription Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7702   Accepted: 2667 Description Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be

POJ 2485-Highways(最小生成树prim)

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 22433   Accepted: 10341 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl