A Bug's Life - poj2492

Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Background
Professor
Hopper is researching the sexual behavior of a rare species of bugs. He
assumes that they feature two different genders and that they only
interact with bugs of the opposite gender. In his experiment, individual
bugs and their interactions were easy to identify, because numbers were
printed on their backs.

Problem
Given a list of bug interactions,
decide whether the experiment supports his assumption of two genders
with no homosexual bugs or if it contains some bug interactions that
falsify it.

Input

The first line of the input contains the number of scenarios. Each
scenario starts with one line giving the number of bugs (at least one,
and up to 2000) and the number of interactions (up to 1000000) separated
by a single space. In the following lines, each interaction is given in
the form of two distinct bug numbers separated by a single space. Bugs
are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:",
where i is the number of the scenario starting at 1, followed by one
line saying either "No suspicious bugs found!" if the experiment is
consistent with his assumption about the bugs‘ sexual behavior, or
"Suspicious bugs found!" if Professor Hopper‘s assumption is definitely
wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended. 
#include<iostream>
#include<cstdio>

using namespace std;

#define N 2010

int f[N], v[N];   //  v 数组存的是下标与其根结点的性别状态,0代表同性,1代表异性,f存的是下标的根结点

int found(int x)
{
    int k = f[x];

    if(f[x] != x)
    {
        f[x] = found(k);  //  寻找根结点
        v[x] = (v[x]+v[k])%2;  // 根结点在变,v数组其与根结点的状态也要变,如果与其原先
    }
    return f[x];
}
int main()
{
    int t, a, b, n, m;

    cin >> t;

    for(int i = 1; i <= t; i++)
    {
        cin >> n >> m;
        int ok = 0;

        for(int j = 1; j <= n; j++)
            f[j] = j, v[j] = 0;

        while(m--)
        {
            cin >> a >> b;

            if(ok) continue;

            int na = found(a), nb = found(b);

            if(na == nb && (v[a]+1)% 2 != v[b])   //  如果两个数之前已经有了联系,并且联系不是正常的,同性恋(相等代表正常,ok置为1,就有可疑对象发现
                ok = 1;
            if(na != nb)
            {
                f[na] = nb;

                v[na] = (1-v[a]+v[b])%2;   //  如果之前两个没有联系,就把两个数的根结点联系起来(根据已知其与根结点状态~
            }
        }
        if(i != 1)
            printf("\n");
        printf("Scenario #%d:\n", i);
        if(ok)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
    }
    printf("\n");  // 格式控制,虽然我也没看见题上哪句话是这意思
    return 0;
}

之前一直不太懂什么意思,什么算同性恋,是opposite gender?醉了,是与当前已知条件矛盾。一个人和另一个人有关系就在一个树上,有点关系的都在一条树上。一棵树上应该与根结点状态一致,否则就是同性恋,不在一棵树上随便状态。。和食物链是不是一样,但是我根本都没想食物链的事。。

头脑简单四肢发达的生物,想不出来一直想~

A Bug's Life - poj2492

时间: 2024-10-12 19:07:23

A Bug's Life - poj2492的相关文章

POJ2492 A Bug&#39;s Life 【并查集】

A Bug's Life Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 29011   Accepted: 9451 Description Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders

poj2492 A Bug&#39;s Life【带权并查集】

题目链接:http://poj.org/problem?id=2492 题目描述:找基佬游戏(汗-_-b)有个hentai科学家研究虫子种群,不断地给出二元组xy,表示x和y是异性交往,但是可能会出现矛盾(找到基佬),比如1与2是异性恋,2与3是异性恋,却又告诉你1和3是异性恋.问种群中存不存在基佬败类 思路:与poj1182“食物链”几乎一样,还简单一点,毕竟只有两类物品.par[i]表示父节点,d[i]表示偏移量,0为同性,1为异性.不过要注意的一点是所有合并的过程要对二取模,比如x找到根结

poj2492 A Bug&#39;s Life (并查集拓展)

C - A Bug's Life Crawling in process... Crawling failed Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2492 Appoint description: CSUST_11 (2013-04-14) System Crawler (2016-05-13) Description B

POJ2492 A Bug&#39;s Life (easy)

Description BackgroundProfessor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs a

POJ2492 A Bug&#39;s Life (并查集)

本文出自:http://blog.csdn.net/svitter 题意: 给出昆虫编号,看昆虫能否交配,如果出现同性交配或者自我交配的情况,则出现BUG. 输入输出分析: 1.输入输出数据: input: 2 3 3 1 2 2 3 1 3 4 2 1 2 3 4 output: Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found! 第一行给出的是测试数据的个数,随后跟着n, m.n是昆虫个数,m是

18.9.17 poj2492 A Bug&#39;s Life

描述 BackgroundProfessor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their

POJ-2492.A Bug&#39;s Life(带权并查集)

A Bug's Life Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 48043   Accepted: 15483 Description Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different gender

POJ-2492 A Bug&#39;s Life(种类并查集)

http://poj.org/problem?id=2492 题意: 给出一个T代表几组数据,给出一个n一个m,代表人的编号由1~n,m条命令,每条命令由两个数值组成,代表这两个人性别不同,问所有命令是否符合逻辑 两种写法: 第一种:带权并查集 1 #include <stdio.h> 2 #include <string.h> 3 #include <iostream> 4 #include <string> 5 #include <math.h&g

POJ2492---A Bug&#39;s Life

A Bug's Life Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 29209   Accepted: 9528 Description Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders