HDU2717 Catch That Cow 【广搜】

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7147    Accepted Submission(s): 2254

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <stdio.h>
#include <queue>
#include <string.h>
#define maxn 100002
using std::queue;

struct Node{
	int pos, step;
};
bool vis[maxn];

void move(Node& tmp, int i)
{
	if(i == 0) --tmp.pos;
	else if(i == 1) ++tmp.pos;
	else tmp.pos <<= 1;
}

bool check(int pos)
{
	return pos >= 0 && pos < maxn && !vis[pos];
}

int BFS(int n, int m)
{
	if(n == m) return 0;
	memset(vis, 0, sizeof(vis));
	queue<Node> Q;
	Node now, tmp;
	now.pos = n; now.step = 0;
	Q.push(now);
	vis[n] = 1;
	while(!Q.empty()){
		now = Q.front(); Q.pop();
		for(int i = 0; i < 3; ++i){
			tmp = now;
			move(tmp, i);
			if(check(tmp.pos)){
				++tmp.step;
				if(tmp.pos == m) return tmp.step;
				vis[tmp.pos] = 1;
				Q.push(tmp);
			}
		}
	}
}

int main()
{
	int n, m;
	while(scanf("%d%d", &n, &m) == 2){
		printf("%d\n", BFS(n, m));
	}
	return 0;
}
时间: 2024-10-08 08:16:17

HDU2717 Catch That Cow 【广搜】的相关文章

hdu 2717 Catch That Cow(广搜bfs)

题目链接:http://i.cnblogs.com/EditPosts.aspx?opt=1 Catch That Cow Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7909    Accepted Submission(s): 2498 Problem Description Farmer John has been inform

poj 3278 Catch That Cow 广搜

hdu 2717 Catch That Cow,题目链接 Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11466 Accepted Submission(s): 3551 Problem Description Farmer John has been informed of the location of a fugitive cow

POJ3278 HDU2717 Catch That Cow

问题链接:POJ3278 HDU2717 Catch That Cow. 题意简述:一条线上,人的FJ的起点为K位置,牛在N位置(牛不动),输入正整数K和N.若FJ在x位置,FJ有三种走法,分别是走到x-1.x+1或2x位置.求从K走到N的最少步数. 问题分析:典型的BFS问题.在BFS搜索过程中,走过的点就不必再走了,因为这次再走下去不可能比上次的步数少. 程序中,使用了一个队列来存放中间节点. 需要说明的是,除了BFS方法,这个题应该可以用分支限界法来解,需要更高的技巧. AC的C++语言程

HDU2717 Catch That Cow ( BFS )

Catch That Cow Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a

HDU2717 Catch That Cow

题目:HDU2717 题解:居然一遍就过了!!开心!!大致上跟那个跳棋的差不多,这个比那个简单只有一维数组.所以只要把走路的规则改一下就行了 代码: 1 #include<cstdio> 2 #include<queue> 3 #include<cstring> 4 #define maxn 100005 5 using namespace std; 6 7 int n,k,m,mm,dis[maxn]; 8 bool f[maxn]; 9 10 void bfs()

HDU2717:Catch That Cow(BFS 队列)

这是一道用队列实现的BFS基础搜索题,学长给我们加这道题主要是让我们联系数据结构里面的队列,话不多说看代码吧. #include <stdio.h> #include <string.h> #include <math.h> #include <algorithm> #include <queue> #include <stack> #define LL long long #define mem(a) memset(a,0,size

Catch That Cow(广搜)

个人心得:其实有关搜素或者地图啥的都可以用广搜,但要注意标志物不然会变得很复杂,想这题,忘记了标志,结果内存超时: 将每个动作扔入队列,但要注意如何更简便,更节省时间,空间 Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and t

poj 3278 Catch That Cow(广搜)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 45087   Accepted: 14116 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

poj 3278:Catch That Cow(简单一维广搜)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 45648   Accepted: 14310 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00