挑战程序设计竞赛2.3习题:Cheapest Palindrome POJ - 3280

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag‘s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows‘s ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow‘s ID tag and the cost of inserting or deleting each of the alphabet‘s characters, find the minimum cost to change the ID tag so it satisfies FJ‘s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

拿到题目,一脸懵逼,二脸懵逼。这咋dp啊?实际上这道题我们可以从小到大进行动态规划求解,即从字符串中的一个元素开始,到两个。。。具体方法是这样的:

我们假设dp[i][j]为字符串从i到j变为回文最小的成本。

1、我们易得把一个字符串变成回文从一个字符开始,一个字符肯定是回文,两个如果也是那也不需要钱,但是如果不是,就得要么选择对前一个或者后一个字符进行操作,即添加前一个或者后一个字符在另一端或者删除某个字符,都能变成回文,于是我们不如在读入每个字符的成本时就决定好是添加还是删除,即取成本当中的最小存储。

2、当新加字符后,若首字符不等于尾字符,则需要补充新添加字符的回文,具体是添加还是删去是对新字符串第一个进行操作还是最后一个进行操作,都是看哪个便宜,添加或删除因为1中说了效果都一样,所以1的处理很重要。

3、当新加字符后,若首字符等于尾字符,那说明首尾其实可以不用进行操作,相当于从首字符后一个到尾字符前一个的字符串的dp值(因为新字符串首尾字符相同不必操作,如果选取2中的方法则必定多修改了一个字符,多花冤枉钱。

AC代码(借鉴:https://blog.csdn.net/jxust_tj/article/details/47300409 和 https://blog.csdn.net/y990041769/article/details/24259569 ):

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
char a[2005];
int hashs[30];//字符的最小花费进行映射
int dp[2005][2005];//从某一字符到另一字符的组成的子字符串变成回文字符串所需要的花费
int main(void)
{
    int add, del;
    char c;
    int n, m;
    scanf("%d %d", &n, &m);
    scanf("%s", a);
    for(int i = 0; i < n; i++)
    {
        while(scanf("%c", &c) && !(c <= ‘z‘ && c >= ‘a‘))
        {}
        scanf("%d %d", &add, &del);//读入时计算到底是删还是加划算
        hashs[c - ‘a‘] = min(add, del);
    }
    for(int i = 1; i < m; i++)//i意味着起始位置到结束位置的差值
        for(int j = 0; j + i < m; j++) //j意味着字符串的起始位置
        {
            if(a[j] == a[j + i])//说明我们并不需要j + 1~j + i或者是j ~ j + i - 1组成的字符串变成回文所需要的花费,因为这样多算了本来不需要的一个字符的操作
                dp[j][j + i] = dp[j + 1][j + i - 1];//如果i==j或者是i + 1 == j那么j + 1 > j + i - 1那么那个值理论上不该有,但是我们默认初始化为0,所以用上了。
            else
                dp[j][j + i] = min(dp[j + 1][j + i] + hashs[a[j] - ‘a‘], dp[j][j + i - 1] + hashs[a[j + i] - ‘a‘]);//取对新字符串第一个进行操作划算还是对最后一个
        }
    printf("%d\n", dp[0][m - 1]);//从原字符串的第一个开始到最后一个,使得该子串(其实也就是原字符串)变为回文字符串的最小花费
    return 0;
}

原文地址:https://www.cnblogs.com/jacobfun/p/12229149.html

时间: 2024-11-08 15:13:00

挑战程序设计竞赛2.3习题:Cheapest Palindrome POJ - 3280的相关文章

挑战程序设计竞赛2.2习题:Allowance POJ - 3040

Allowance As a reward for record milk production, Farmer John has decided to start paying Bessie the cow a small weekly allowance. FJ has a set of coins in N (1 <= N <= 20) different denominations, where each denomination of coin evenly divides the

挑战程序设计竞赛2.2习题:Stall Reservations POJ - 3190

Stall Reservations Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a

挑战程序设计竞赛2.3习题:Making the Grade POJ - 3666

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like t

挑战程序设计竞赛2.3习题:Cow Exhibition POJ - 2184

"Fat and docile, big and dumb, they look so stupid, they aren't muchfun..."- Cows with Guns by Dana Lyons The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be

挑战程序设计竞赛2.4习题:Moo University - Financial Aid POJ - 2010

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. Not wishing to admit

挑战程序设计竞赛2.6习题:X-factor Chains POJ - 3421

Given a positive integer X, an X-factor chain of length m is a sequence of integers, 1 = X0, X1, X2, …, Xm = X satisfying Xi < Xi+1 and Xi | Xi+1 where a | b means a perfectly divides into b. Now we are interested in the maximum length of X-factor ch

挑战程序设计竞赛3.1习题:Moo University - Financial Aid POJ - 2010

(原题见POJ2010) 这道题我之前采用了优先队列+预处理的方法求解(https://www.cnblogs.com/jacobfun/p/12244509.html),现在用二分的办法进行求解. 一开始我很纳闷,采用二分求解本题,如果二分的mid值不符合条件,按照二分右边界应该为mid - 1(我采用前闭后闭的二分),那么如果mid + xxx(xxx大于0)可以呢?(考虑mid不行是因为左边最小加起来大了,mid ~ mid + xxx中有极小值,使得mid + xxx的左边可以满足,那么

挑战程序设计竞赛3.2习题:Bound Found POJ - 2566

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two

挑战程序设计竞赛2.3:Wooden Sticks POJ - 1065

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing