PTA(Advanced Level)1036.Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student‘s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF?gradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
思路
  • 跟之前的PTA(Basic Level)1028.人口普查仍旧有点像,不过这里要分男女情况来比较。不过比较的内容是分数,和之前相比算简单的了
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
    char name[20];
    char gender;
    char id[20];
    int grade;
}female_high, male_low;

void Init()
{
    female_high.grade = -1;
    male_low.grade = 110;
}

bool higher(student a, student b)
{
    return a.grade > b.grade;
}

int main()
{
    int n;
    Init();
    scanf("%d", &n);
    student tmp;
    while(n--)
    {
        scanf("%s %c %s %d", tmp.name, &tmp.gender, tmp.id, &tmp.grade);
        if(tmp.gender == 'M' && higher(male_low, tmp))
            male_low = tmp;
        if(tmp.gender == 'F' && higher(tmp, female_high))
            female_high = tmp;
    }

    bool absent = false;
    if(female_high.grade == -1)
    {
        printf("Absent\n");
        absent = true;
    }else printf("%s %s\n", female_high.name, female_high.id);
    if(male_low.grade == 110)
    {
        printf("Absent\n");
        absent = true;
    }else printf("%s %s\n", male_low.name, male_low.id);
    if(absent)
        printf("NA");
    else printf("%d", female_high.grade - male_low.grade);
    return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805453203030016

原文地址:https://www.cnblogs.com/MartinLwx/p/11665090.html

时间: 2024-08-30 13:06:12

PTA(Advanced Level)1036.Boys vs Girls的相关文章

PAT (Advanced Level) 1036. Boys vs Girls (25)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<vector> using namespace std; const int maxn=100000; struct X { string nam

1036. Boys vs Girls (25)

1036. Boys vs Girls (25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contain

PAT 1036. Boys vs Girls (25)

1036. Boys vs Girls (25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contain

PAT 1036 Boys vs Girls[简单]

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT 甲级 1036 Boys vs Girls (25 分)(简单题)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT 1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PTA(Advanced Level)1025.PAT Ranking

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by e

PAT 1036 Boys vs Girls

#include <cstdio> #include <iostream> #include <cstdlib> #include <algorithm> using namespace std; class Stu { public: char name[12]; char id[12]; int grade; char gender; }; bool my_cmp(const Stu* a, const Stu* b) { return a->gr