(compareTo) How Many Fibs hdu1316 && ZOJ1962

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7007    Accepted Submission(s): 2761

Problem Description

Recall the definition of the Fibonacci numbers:

f1 := 1

f2 := 2

fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.

Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.

Sample Input

10 100

1234567890 9876543210

0 0

Sample Output

5

4

用Java,然后利用compareTo来判断大小。

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigInteger a,b;
        while(in.hasNextBigInteger()) {
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            if(a.equals(BigInteger.valueOf(0))&&b.equals(BigInteger.valueOf(0)))
                break;                 //也可以用compareTo。
            System.out.println(Fib(a,b));
        }
    }
     public static int Fib(BigInteger a,BigInteger b)
        {
            int sum = 0;
            BigInteger f = new BigInteger("1");
            BigInteger s = new BigInteger("2");
            BigInteger tmp;
            while(true)
            {
                if(f.compareTo(b)>0)
                    break;
                if(f.compareTo(a) >= 0)
                    sum++;
                tmp = f;                      //可以用迭代的方法求斐波那契数列。
                f = s;
                s = s.add(tmp);
            }
            return sum;
        }
}

原文地址:https://www.cnblogs.com/Weixu-Liu/p/9166478.html

时间: 2024-11-13 08:49:50

(compareTo) How Many Fibs hdu1316 && ZOJ1962的相关文章

hdu1316 How Many Fibs?

//思路就是大整数数组保存fib数,然后二分查找 import java.util.*; import java.math.*; import java.io.*; class Main { public static void main(String[] args) { // TODO Auto-generated method stub BigInteger[] f = new BigInteger[500]; f[0]=f[1]=BigInteger.ONE; for(int i=2;i<

UVA10183 - How Many Fibs?(java大数+二分)

UVA10183 - How Many Fibs?(java大数+二分) 题目链接 题目大意:给你a,b,求[a,b]之间有多少个fibs数. 解题思路:虽然a.b很大,但是在10^100内的fibs却不超过500个.这样就可以先把这些fibs保存在数组中,然后每次二分去找a,b的位置,然后就可以得到之间有多少个fibs. 代码: import java.util.*; import java.math.*; import java.io.*; import java.lang.String.*

HDU 1316-How Many Fibs?(大数类)

How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4295    Accepted Submission(s): 1689 Problem Description Recall the definition of the Fibonacci numbers: f1 := 1 f2 := 2 fn := fn-

hdu--1316--How Many Fibs?(java大数)

How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6371    Accepted Submission(s): 2517 Problem Description Recall the definition of the Fibonacci numbers: f1 := 1 f2 := 2 fn := fn-1

HDU 1316 How Many Fibs?(java,简单题,大数)

题目 /** * compareTo:根据该数值是小于.等于.或大于 val 返回 -1.0 或 1: public int compareTo(BigInteger val) 将此 BigInteger 与指定的 BigInteger 进行比较. 对于针对六个布尔比较运算符 (<, ==, >, >=, !=, <=)中的每一个运算符的各个方法,优先提供此方法. 执行这些比较的建议语句是:(x.compareTo(y) <op> 0), 其中 <op> 是

HDOJ 1316 How Many Fibs?

JAVA大数.... How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3906    Accepted Submission(s): 1545 Problem Description Recall the definition of the Fibonacci numbers: f1 := 1 f2 :=

POJ 2413 How many Fibs? (java大数)

How many Fibs? Description Recall the definition of the Fibonacci numbers: f1 := 1 f2 := 2 fn := f n-1 + f n-2 (n>=3) Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a,b]. Input The input contains several test cases.

【HDOJ】1316 How Many Fibs?

Java水了. 1 import java.util.Scanner; 2 import java.math.BigInteger; 3 4 public class Main { 5 public static void main(String[] args) { 6 Scanner cin = new Scanner(System.in); 7 BigInteger[] fibs = new BigInteger[MAXN]; 8 // init the fibs 9 fibs[0] = B

HDUJ 1316 How Many Fibs?

How Many Fibs? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4106    Accepted Submission(s): 1623 Problem Description Recall the definition of the Fibonacci numbers: f1 := 1 f2 := 2 fn := fn-