POJ3461 Oulipo[KMP]【学习笔记】

Oulipo

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36916   Accepted: 14904

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

BAPC 2006 Qualification


KMP裸题 出现几次

关于KMP

字符串从0开始,所以p[i]就是地i+1个字符

f[i]是失配函数,表示已经匹配了i个字符,i+1(就是p[i])失配转移到哪里

令j=f[i],就是说以位置i-1结尾的后缀包括了0...j-1这个前缀,再检查p[j]==s[i](即j+1  i+1)

//
//  main.cpp
//  poj3461
//
//  Created by Candy on 10/19/16.
//  Copyright © 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+5,M=1e4+5;
int T,f[M];// already i(0...i-1),now pos i
char s[N],p[M];
void getFail(){
    size_t m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1;i<m;i++){
        int j=f[i];
        while(j&&p[i]!=p[j]) j=f[j];
        f[i+1]=p[i]==p[j]?j+1:0;
    }
}
int kmp(){
    getFail();
    int cnt=0;
    size_t n=strlen(s),m=strlen(p);
    int j=0;
    for(int i=0;i<n;i++){
        while(j&&s[i]!=p[j]) j=f[j];
        if(s[i]==p[j]) j++;
        if(j==m) cnt++;
    }
    return cnt;
}
int main(int argc, const char * argv[]) {
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",p,s);
        printf("%d\n",kmp());
    }

    return 0;
}

以前愚蠢的从0开始

从0开始太愚蠢了,于是我从1开始重学重写了一遍

1.算法理解(orz 阮一峰):http://www.ruanyifeng.com/blog/2013/05/Knuth%E2%80%93Morris%E2%80%93Pratt_algorithm.html

2.摘抄(修改)课件:

  • 定义f[i]表示A[1,i]的长度为f[i]的后缀等于A[1,f[i]]  也就是说对于这个子串来说f[i]长度的前缀和后缀相等(注意顺序都是从左到右相等),那么j+1位置匹配失败就可以转移到f[j]位置(因为1..f[j]和刚刚成功的后缀是一样的)继续匹配f[j]+1
  • 多个f[i]符合条件时,取最大的。当然,f[i]是要小于i的,否则就没有意义了。
  • 将i从2到n枚举(f[1]=0是不必计算的),依次计算f[i]。
    计算f[i]时,先令j=f[i-1],f[i]最大只会是j+1。只需判断A[i]与A[j+1]是否相等就能判断f[i]是不是j+1。若相等,f[i]=j+1;否则令j=f[j],继续这个过程。
    如果j=0后仍然和j+1不相等,就使f[i]=0
  • 时间复杂度O(n),因为j最多增加减少n次
//
//  main.cpp
//  poj3461
//
//  Created by Candy on 10/19/16.
//  Copyright ? 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+5,M=1e4+5;
int T,f[M],n,m;
char t[N],p[M];
void getFail(){
    f[1]=0;
    for(int i=2;i<=m;i++){
        int j=f[i-1];
        while(j&&p[i]!=p[j+1]) j=f[j];
        f[i]=p[i]==p[j+1]?j+1:0;
    }
}
int kmp(){
    int ans=0;
    getFail();
    int j=0;
    for(int i=1;i<=n;i++){
        while(j&&t[i]!=p[j+1]) j=f[j];
        j+=t[i]==p[j+1];
        if(j==m) ans++;
    }
    return ans;
}
int main(){
//    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",p+1,t+1);
        n=strlen(t+1),m=strlen(p+1);
        printf("%d\n",kmp());
    }

    return 0;
}
时间: 2024-12-25 14:00:28

POJ3461 Oulipo[KMP]【学习笔记】的相关文章

poj3461 Oulipo (kmp)

Oulipo Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 35732   Accepted: 14439 Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quot

poj3461 Oulipo (KMP模板题~) 前面哪些也是模板题 O.O

# include <stdio.h> # include <algorithm> # include <string.h> using namespace std; char a1[1000010],a2[1000010]; int next[1000010]; int len1,len2,cot; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=len1) { if(j==-1||a1[i]==a1[j]

KMP学习笔记

功能 字符串T,长度为n. 模板串P,长度为m.在字符串T中找到匹配点i,使得从i开始T[i]=P[0], T[i+1]=P[1], . . . , T[i+m-1]=P[m-1] KMP算法先用O(m)的复杂度对模板串进行处理,然后O(n)进行匹配.总时间复杂度O(m+n) 注意失配函数f[i]为第i位处不能匹配时应当转向检查第f[i]位是否匹配: 比如模板串: 0 1 2 3 4 5 6 A B B A A B A 得到的失配函数为: 0 1 2 3 4 5 6 7 0 0 0 0 1 1

POJ3461 Oulipo KMP算法应用

题目描述 给定主串和模式串,问模式串在主串中出现的次数 Sample Input 3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN Sample Output 1 3 0 解题思路:KMP算法是找到一个匹配就跳出,这题是要计数,所以我们把KMP算法稍微改一下即可,在找到一个匹配(即j=模式串长度)时计数器++,再从next[j]开始找就好了.详见代码 #include <cstdio> #include <cstring> void Get

[KMP]【学习笔记】

POJ3461 Oulipo KMP裸题 出现几次 关于KMP 字符串从0开始,所以p[i]就是地i+1个字符 f[i]是失配函数,表示已经匹配了i个字符,i+1(就是p[i])失配转移到哪里 令j=f[i],就是说以位置i-1结尾的后缀包括了0...j-1这个前缀,再检查p[j]==s[i](即j+1  i+1) // // main.cpp // poj3461 // // Created by Candy on 10/19/16. // Copyright © 2016 Candy. Al

POJ3461 Oulipo 【KMP】

Oulipo Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 22295   Accepted: 8905 Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote

算法学习笔记 KMP算法之 next 数组详解

最近回顾了下字符串匹配 KMP 算法,相对于朴素匹配算法,KMP算法核心改进就在于:待匹配串指针 i 不发生回溯,模式串指针 j 跳转到 next[j],即变为了 j = next[j]. 由此时间复杂度由朴素匹配的 O(m*n) 降到了 O(m+n), 其中模式串长度 m, 待匹配文本串长 n. 其中,比较难理解的地方就是 next 数组的求法.next 数组的含义:代表当前字符之前的字符串中,有多大长度的相同前缀后缀,也可看作有限状态自动机的状态,而且从自动机的角度反而更容易推导一些. "前

KMP算法 学习笔记

kmp算法在很多人看来是如此的厉害,很早之前就学过了,但是各种看不懂把我拦住了,现在重新拾取,来写一下个人的学习总结. kmp看毛片算法(小甲鱼教的)(在这给小甲鱼做个广告,我个人看来小甲鱼讲的数据结构很好,很有趣.个人创业不容易,希望大家多多支持www.fishc.com小甲鱼,我跟小甲鱼素不相识,只是有用的东西大家分享) 好了言归正传. 如果你之前看过kmp算法没有看懂希望在这不要带着一种恐惧感,如果你没看过那是更好. 网上有很多详细教程,但是大部分都很啰嗦,容易把人看晕. kmp算法没有什

字符串学习笔记

字符串学习笔记 注:本文涉及到的所有变量名均与模板中变量名同步.模板链接 一.Hash 1.双Hash 2.链式Hash 3.树Hash 二.KMP 1.概述 查询字符串 \(t\) 在字符串 \(s\) 中出现过的所有位置.时间复杂度 \(O(len(s)+len(t))\). char *s = "abacaba"; char *t = "aba"; 0 1 2 3 4 5 6 a b a c a b a \(t\) 在 \(s\) 中出现过的位置为0.4. 2