(KMP)Simpsons’ Hidden Talents -- hdu -- 2594

http://acm.hdu.edu.cn/showproblem.php?pid=2594

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4756    Accepted Submission(s): 1732

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton

homer

riemann

marjorie

Sample Output

0

rie 3

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stack>
using namespace std;

#define N 100050

int Next[N];

void FindNext(char S[])
{
    int i=0, j=-1;
    int Slen = strlen(S);

    Next[0] = -1;

    while(i<Slen)
    {
        if(j==-1 || S[i]==S[j])
            Next[++i] = ++j;
        else
            j = Next[j];
    }
}
int main()
{
    char s1[N], s2[N];

    while(scanf("%s%s", s1, s2)!=EOF)
    {
        int len1=strlen(s1), len2=strlen(s2);
        int Min = min(len1, len2);
        char S[N], s[N];

        strcpy(s, s1);
        strcat(s1, s2);

        FindNext(s1);

        int len = strlen(s1);
        if(Next[len]==0 && len>2)
            printf("0\n");
        else if(Next[len]>Min)
        {
            if(len1>len2)
                printf("%s %d\n", s2, len2);
            else
                printf("%s %d\n", s, len1);
        }
        else
        {
            memset(S, 0, sizeof(S));
            strncpy(S, s1, Next[len]);
            printf("%s %d\n", S, Next[len]);
        }

    }
    return 0;
}

时间: 2024-08-10 01:11:00

(KMP)Simpsons’ Hidden Talents -- hdu -- 2594的相关文章

Simpsons’ Hidden Talents HDU - 2594(拓展kmp)

Sample Input clinton homer riemann marjorie Sample Output 0 rie 3 看输出才题意...拓展kmp特征很明显嘛....注意开始就匹配到尾的情况 #include <iostream> #include <cstdio> #include <sstream> #include <cstring> #include <map> #include <set> #include &

Simpsons’ Hidden Talents - HDU 2594(求相同的前缀后缀)

题目大意:给你两个字符串,找出一个最大的子串,这个子串要是前面串的前缀并且是后面串的后缀...........   分析:next的简单运用吧,可以把两个串进行合并,中间加一个不能被匹配的字符,然后求出来next就行了.......确实很水 代码如下: ========================================================================================================= #include<stdio.h>

HDU 2594 Simpsons’ Hidden Talents (字符串-KMP)

Simpsons' Hidden Talents Problem Description Homer: Marge, I just figured out a way to discover some of the talents we weren't aware we had. Marge: Yeah, what is it? Homer: Take me for example. I want to find out if I have a talent in politics, OK? M

HDU 2594 Simpsons’ Hidden Talents (KMP)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2594 这题直接用KMP算法就可以做出来,不过我还尝试了用扩展的kmp,这题用扩展的KMP效率没那么高. KMP算法: #include<stdio.h> #include<iostream> #include<string.h> using namespace std; int next[50001]; char p[50000],s[50000]; void getnex

HDU 2594 Simpsons’ Hidden Talents(辛普森一家的潜在天赋)

HDU 2594 Simpsons’ Hidden Talents(辛普森一家的潜在天赋) Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) [Description] [题目描述] Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. Marge:

HDU 2594 Simpsons’ Hidden Talents KMP题解

KMP的应用.直接使用s1产生next 数组,然后在s2中搜索s1,那么记录最后一个搜索到的数值,就是s1的前缀在s2中的最长后缀了. 本题应该不能直接调用strstr了吧. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <li

HDU 2594 Simpsons’ Hidden Talents (KMP)

#include <stdio.h> #include <string.h> int next[50005]; char str1[50005],str2[50005]; void build_next(int len2) { int i=0,j=-1; next[0] = -1; while (i < len2) { if (j==-1 || str2[i] == str2[j]) { i++; j++; if (str2[i] != str2[j]) { next[i]

hdu 2594 Simpsons’ Hidden Talents(KMP入门)

Simpsons’ Hidden Talents Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4543    Accepted Submission(s): 1648 Problem Description Homer: Marge, I just figured out a way to discover some of the t

hdu 3336 Count the string(KMP)

一道应用kmp算法中next数组的题目 这其中vis[i]从1加到n vis[i]=[next[i]]+1; #include<string.h> #include<stdlib.h> #include<stdio.h> #include<iostream> #include<algorithm> using namespace std; char s[200005]; int b; int next[200005]; int vis[20000