hdu 3047

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1755    Accepted Submission(s): 664

Problem Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input

There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output

For every case: 
Output R, represents the number of incorrect request.

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output

2

Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

是求出节点a到根的距离。第二行代码使用的是数学中向量计算的原理如图

数学问题,看成向量来解决

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define maxn 1000010
int n,m,fa[maxn],dist[maxn],ans;
int find(int x)
{
      if(x==fa[x])
            return fa[x];
      int k=fa[x];
      fa[x]=find(fa[x]);
      dist[x]+=dist[k];
      return fa[x];
}
void Union(int x,int y,int z)
{
      int fx,fy;
      fx=find(x),fy=find(y);
      if(fx!=fy)
      {
            fa[fx]=fy;
            dist[fx]=dist[y]-dist[x]+z;
      }
      else
      {
            if(dist[x]-dist[y]!=z)
                  ans++;
      }
}
int main()
{
      int x,y,z;
      while(scanf("%d%d",&n,&m)!=EOF)
      {
            ans=0;
            for(int i=0;i<=n;i++)
                  fa[i]=i,dist[i]=0;
            for(int i=0;i<m;i++)
            {
                scanf("%d%d%d",&x,&y,&z);
                Union(x,y,z);
            }
            printf("%d\n",ans);
      }
      return 0;
}

  

时间: 2024-10-24 02:07:03

hdu 3047的相关文章

HDU 3047 Zjnu Stadium 带权并查集

题目来源:HDU 3047 Zjnu Stadium 题意:给你一些人 然后每次输入a b c 表示b在距离a的右边c处 求有多少个矛盾的情况 思路:用sum[a] 代表a点距离根的距离 每次合并时如果根一样 判断sum数组是否符合情况 根不一样 合并两棵树 这里就是带权并查集的精髓 sum[y] = sum[a]-sum[b]+x 这里y的没有合并前b的根 #include <cstdio> #include <cstring> using namespace std; cons

hdu 3047 Zjnu Stadium 并查集高级应用

Zjnu Stadium Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1631    Accepted Submission(s): 616 Problem Description In 12th Zhejiang College Students Games 2007, there was a new stadium built

【带权并查集】HDU 3047 Zjnu Stadium

http://acm.hdu.edu.cn/showproblem.php?pid=3047 [题意] http://blog.csdn.net/hj1107402232/article/details/9921311 [Accepted] 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<string> 5 #include<cmath> 6 #incl

hdu 3047 Zjnu Stadium

Zjnu Stadium Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2109    Accepted Submission(s): 808 Problem Description In 12th Zhejiang College Students Games 2007, there was a new stadium built

hdu 3047(扩展并查集)

Zjnu Stadium Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2672    Accepted Submission(s): 1028 Problem Description In 12th Zhejiang College Students Games 2007, there was a new stadium built

hdu 3047 Zjnu Stadium(并查集)

题意: 300个座位构成一个圈. 有N个人要入座. 共有M个说明 :A B X ,代表B坐在A顺时针方向第X个座位上.如果这个说明和之前的起冲突,则它是无效的. 问总共有多少个无效的. 思路: 并查集的询问方式,,,, 直接看代码吧! 代码: int n,m; int fa[50005]; int dis[50005]; int findFa(int x){ if(fa[x]==x) return fa[x]; int t=findFa(fa[x]); dis[x]+=dis[fa[x]]; r

hdu 3047 Zjnu Stadium【带权并查集】

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1

HDU 3047 Zjnu Stadium(带权并查集,难想到)

M - Zjnu Stadium Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium

2014 8.6 第7场个人 排位

这次比赛有显示了自己的不足,之所以是又,是因为基本上每次都暴露了自己很水,囧. 剩下的时间努力刷题,加油 CodeForces 287B Pipeline (二分加贪心) view code#include <iostream> #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> using namespace std; typedef long l