hdoj 2401 Baskets of Gold Coins

Baskets of Gold Coins

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1855    Accepted Submission(s): 1104

Problem Description

You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the scene and takes 1 coin from Basket 1, 2 coins from Basket 2, and so on, up to and including N-1 coins from Basket N-1. He does not take any coins from Basket N. He weighs the selected coins and concludes which of the N baskets contains the lighter coins. Your mission is to emulate the wizard‘s computation.

Input

The input file will consist of one or more lines; each line will contain data for one instance of the problem. More specifically, each line will contain four positive integers, separated by one blank space. The first three integers are, respectively, the numbers N, w, and d, as described above. The fourth integer is the result of weighing the selected coins.

N will be at least 2 and not more than 8000. The value of w will be at most 30. The value of d will be less than w.

Output

For each instance of the problem, your program will produce one line of output, consisting of one positive integer: the number of the basket that contains lighter coins than the other baskets.

Sample Input

10 25 8 1109

10 25 8 1045

8000 30 12 959879400

Sample Output

2

10

50

题意:给四个数 n,w,d,m  代表n个篮子,每个篮子中放很多金币(大于等于n)每个金币的重量都是w但是有一个篮子中的金币重量是w-d,现在从篮子中拿出来金币,从第一个篮子中拿出一个,第二个篮子拿出两个,第n-1个篮子拿出n-1个第n个篮子不拿,现在给你拿出来的所有金币的总重量m问你第几个个篮子中的金币重量是w-d

题解:计算出当所有的金币重量都是w时按照此方法拿出的金币总重量sum减去m,得到ans则可知  x=ans/d;注意当ans==0时证明,第n个篮子中金币重量为w-d

#include<stdio.h>
#include<string.h>
#define LL long long
int main()
{
	int w,d,n;
	int i;
	LL m,sum,ans;
	while(scanf("%d%d%d%lld",&n,&w,&d,&m)!=EOF)
	{
		sum=0;
		for(i=1;i<n;i++)
		    sum+=i*w;
		ans=sum-m;
		if(ans==0)
		printf("%d\n",n);
		else
		printf("%lld\n",ans/d);
	}
	return 0;
}

  

时间: 2024-08-04 11:43:59

hdoj 2401 Baskets of Gold Coins的相关文章

HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)

Problem Description You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the

hust 1170 - Baskets of Gold Coins

题目描述 You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the scene and takes

Baskets of Gold Coins

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1862    Accepted Submission(s): 1108 Problem Description You are given N baskets of gold coins. The baskets are numbered fro

HDU2401 Baskets of Gold Coins【水题】【推理】

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1648    Accepted Submission(s): 966 Problem Description You are given N baskets of gold coins. The baskets are numbered fro

H - Gold Coins(2.4.1)

H - Gold Coins(2.4.1) Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of

codechef - Bytelandian gold coins 题解

In Byteland they have a very strange monetary system. Each Bytelandian gold coin has an integer number written on it. A coin n can be exchanged in a bank into three coins: n/2, n/3 and n/4. But these numbers are all rounded down (the banks have to ma

UVALive3045 POJ2000 ZOJ2345 Gold Coins

Regionals 2004 >> North America - Rocky Mountain 问题链接:UVALive3045 POJ2000 ZOJ2345 Gold Coins.基础练习题,用C语言编写. 题意简述:骑士第1天获得1个金币,之后的2天获得2个金币,之后的3天获得3个金币,......,之后的i天获得i个金币,.......问到第n天总共获得多少个金币. 问题分析:这是一个数列求和问题,用程序解决比用数学解决方便很多. 程序中,用数组ans[]存储金币之和,即ans[i]

[ACM] POJ 2000 Gold Coins

Gold Coins Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 20913   Accepted: 13098 Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days

Gold Coins(闲来无事水一发)

Gold Coins Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 21155 Accepted: 13265 Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (th