POJ 2318 计算几何+二分

TOYS

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 10425 Accepted: 5002

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner
and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that
the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is
random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the
rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0

3 1

4 3

6 8

10 10

15 30

1 5

2 1

2 8

5 5

40 10

7 9

4 10 0 10 100 0

20 20

40 40

60 60

80 80

5 10

15 10

25 10

35 10

45 10

55 10

65 10

75 10

85 10

95 10

0

Sample Output

0: 2

1: 1

2: 1

3: 1

4: 0

5: 1

0: 2

1: 2

2: 2

3: 2

4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source

Rocky Mountain 2003

/***********************************************
     author     : Grant Yuan
     time       : 2014/8/18 17:12
     algorithm  : 计算几何+二分
     source     : POJ 2318
************************************************/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 5007

using namespace std;

int n,m,x1,y1,x2,y2;
int ans[MAX];
int left,right,l,r,mid,res;

struct Point
{
    int x,y;
    Point() {};
    Point(int _x,int _y){x=_x;y=_y;}
    Point operator -(const Point &b)
    {
        return Point(x-b.x,y-b.y);
    }
    int operator *(const Point &b)
    {
        return x*b.x+y*b.y;
    }
    int operator ^(const Point &b)
    {
        return x*b.y-y*b.x;
    }
};

struct Line
{
    Point a,b;
    Line(){};
    Line(Point _a,Point _b){a=_a;b=_b;}
};
Line line[MAX];

int xmult(Point p0,Point p1,Point p2)
{
    return(p1-p0)^(p2-p0);
}

int main()
{
    int x3,y3;
    Point p1,p2,p;Line l1;
    bool first=true;
    while(~scanf("%d",&n)&&n){
        if(!first) printf("\n");
        if(first) first=false;
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        memset(ans,0,sizeof(ans));
        memset(line,0,sizeof(line));
        int Ui,Li;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&Ui,&Li);
            line[i]=Line(Point(Ui,y1),Point(Li,y2));
        }
            line[n]=Line(Point(x2,y1),Point(x2,y2));
        while(m--)
        {
            scanf("%d%d",&x3,&y3);
            p=Point(x3,y3);
            l=0;r=n;
            while(l<=r)
            {
                mid=(l+r)>>1;
                if(xmult(p,line[mid].a,line[mid].b)<0){
                    r=mid-1;
                    res=mid;
                }
                else l=mid+1;
            }
            ans[res]++;
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,ans[i]);
        }

    }
    return 0;
}

POJ 2318 计算几何+二分

时间: 2024-08-04 22:48:04

POJ 2318 计算几何+二分的相关文章

POJ 2398 计算几何+二分+排序

Toy Storage Time Limit: 1000MS  Memory Limit: 65536K Total Submissions: 3953  Accepted: 2334 Description Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box t

【POJ】2318 TOYS ——计算几何+二分

TOYS Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 10281   Accepted: 4924 Description Calculate the number of toys that land in each bin of a partitioned toy box. Mom and dad have a problem - their child John never puts his toys away w

POJ 2318 TOYS(叉积+二分or暴力)

题目链接:POJ 2318 TOYS [写在前面]前几天跟队友分了方向,学渣开始进行计算几何的专题了,真是脑壳有点痛啊.但是我想做多了就没这么坑爹了 [题意]大体意思就是给你一个矩形,有被若干直线分成N个格子,给出M个点的坐标,问你每个点位于哪个格子中. [思路]其实就是点在凸四边形内的判断,然后就可以利用叉积的性质,当然可以用暴力枚举也可以过,但是时间复杂度有点高,最好是用二分求解.(一直觉得二分真是牛逼啊) 下面贴AC代码,用二分219MS就过了: 1 /* 2 ** POJ 2318 TO

POJ 2318

第一道计算几何. 二分一下用叉积来判..看了DIS上说要INT64,就改INT64了... 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 using namespace std; 6 const int Max=5050; 7 8 struct e{ 9 int x1,x2; 10 }edge[Max]; 11 struct c{

POJ 2318/2398 叉积性质

2318 2398 题意:给出n条线将一块区域分成n+1块空间,再给出m个点,询问这些点在哪个空间里. 思路:由于只要求相对位置关系,而对具体位置不关心,那么易使用叉积性质得到相对位置关系(左侧/右侧),再因为是简单几何线段不相较,即有序分布,那么在求在哪个区间时可以先对所有线段根据x坐标排序,使用二分减少复杂度. /** @Date : 2017-07-11 11:05:59 * @FileName: POJ 2318 叉积性质.cpp * @Platform: Windows * @Auth

poj 2318 TOYS &amp; poj 2398 Toy Storage (叉积)

链接:poj 2318 题意:有一个矩形盒子,盒子里有一些木块线段,并且这些线段坐标是按照顺序给出的, 有n条线段,把盒子分层了n+1个区域,然后有m个玩具,这m个玩具的坐标是已知的,问最后每个区域有多少个玩具 分析:从左往右,直到判断玩具是否在线段的逆时针方向为止,这个就需要用到叉积,当然可以用二分查找优化. 叉积:已知向量a(x1,y1),向量b(x2,y2),axb=x1*y2-x2*y1, 若axb>0,a在b的逆时针方向,若axb<0,则a在b的顺时针方向 注:每组数据后要多空一行

POJ 2318 TOYS 叉积的应用

A - TOYS Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2318 Appoint description:  lijunle  (2011-07-18)System Crawler  (2016-05-08) Description Calculate the number of toys that land in each b

POJ 3484 Showstopper 二分

 Showstopper Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1218   Accepted: 356 Description Data-mining huge data sets can be a painful and long lasting process if we are not aware of tiny patterns existing within those data sets. On

poj 1469 COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16877   Accepted: 6627 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss