hdu 5244 inverse (上海大都会赛) (分治算法)

nverse

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 110    Accepted Submission(s): 44

Problem Description

Mike has got a huge array b,
and he is told that the array is encrypted.

The array is encrypted as follows.

Let ai(0≤i<n) be
the i-th
number of this original array.

Let bi(0≤i<n) be
the i-th
number of this encrypted array.

Let n be
a power of 2,
which means n=2k.

The bi is
calculated as following.

bi=∑0≤j<nf((i or j) xor i)aj

f(x) means,
if the number of 1 in
the binary of x is
even, it will return 1,
otherwise 0.

Mike want to inverse the procedure of encryption.

Please help him recover the array a with
the array b.

Input

The first line contains an integer T(T≤5),
denoting the number of the test cases.

For each test case, the first line contains an integer k(0≤k≤20),

The next line contains n=2k integers,
which are bi respectively.

It is guaranteed that, ai is
an integer and 0≤ai≤109.

Output

For each test case, output ‘‘Case #t:‘‘ to represent this is the t-th case. And then output the array a.

Sample Input

2
0
233
2
5 3 4 10

Sample Output

Case #1: 233
Case #2: 1 2 3 4

分治。吧矩阵构造出来们发现有规律 ,然后就可以用分治求解了。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int mmax = (1<<21);
const int inf = 0x3fffffff;
typedef __int64 LL;
LL b[mmax],a[mmax];
void cdq(int l,int r)
{
    if(l==r)
    {
        a[l]=b[l];
        return ;
    }
    int mid=(l+r)>>1;
    for(int i=l;i<=mid;i++)
    {
        LL tmp=b[i]+b[i+(r-l+1)/2];
        b[i]=(tmp-(b[r]-b[mid]))/2;
        b[i+(r-l+1)/2]-=b[i];
    }
    cdq(l,mid);
    cdq(mid+1,r);
}
int get(int x)
{
    int cnt=0;
    while(x)
    {
        if(x&1)
            cnt++;
        x/=2;
    }
    return cnt;
}
int c[mmax];
void test(int k)
{
    for(int i=0;i<(1<<k);i++)
    {
        int sum=0;
        for(int j=0;j<(1<<k);j++)
            if( get((i|j)^i ) %2==0 )
                sum+=a[j+1];
        b[i+1]=sum;
    }
}
int main()
{
    int t,k,ca=0;
    cin>>t;
    while(t--)
    {
        scanf("%d",&k);
        for(int i=1;i<=(1<<k);i++)
            scanf("%I64d",&b[i]);
//        for(int i=1;i<=(1<<k);i++)
//            scanf("%d",&a[i]);
//        test(k);
        cdq(1,(1<<k));
        printf("Case #%d: ",++ca);
        for(int i=1;i<=(1<<k);i++)
            printf("%I64d%c",a[i],i==(1<<k)?'\n':' ');
        //test(k);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-14 08:59:54

hdu 5244 inverse (上海大都会赛) (分治算法)的相关文章

2018 ACM 国际大学生程序设计竞赛上海大都会赛

传送门:2018 ACM 国际大学生程序设计竞赛上海大都会赛 2018 ACM 国际大学生程序设计竞赛上海大都会赛重现赛2018-08-05 12:00:00 至 2018-08-05 17:00:00时长: 5小时 比赛情况 实录 难度差不多介于省赛和区域赛之间吧.开题A是计算几何,有点思路后就先放下去写签到题,B读错题WA一发,K直接套模板,然后就接着看A.之前写过类似题,没注意数据范围就头铁地交了发n3的代码,TE后才发现数据范围是之前那道十多倍,就听学长的先看D.推十分钟公式无果后打算直

hdu 5244 inverse(分治)

inverse Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 193    Accepted Submission(s): 97 Problem Description Mike has got a huge array b, and he is told that the array is encrypted. The array i

hdu 5475(2015上海网赛) An easy problem

题目;http://acm.hdu.edu.cn/showproblem.php?pid=5475 题意就是给X赋初值1,然后给Q个操作,每个操作对应一个整数M:如果操作是1则将X乘以对应的M,如果是2则除以第M次操作对应的M',求最后X的值对给定值取摸的结果, 直接暴力会爆long long,用数组存每一步的话 会超时,所以用线段树优化进行区间更新 1 #include<cstdio> 2 using namespace std; 3 typedef long long ll; 4 stru

2015全国邀请赛--上海大都会赛

第一次参加的正式比赛,61名```是的,60是银,61就是铜了.弱就不能怪服务器,就算手速再快一点罚时挤进银也没用,仍然没有实力拿银. 这场比赛我仍然是从后往前看题,J本来是个水题,但是我不确定就没有细想,这是我们罚时落后的重大原因.然后刻盘说F水,E也有人过了,接着凯神和刻盘讨论之后敲E,我出了几组E的数据之后和刻盘想F,刻盘想出大体思路的时候我还不是很有头绪.凯神A掉E之后说C有印象,然后我看C他开始敲,敲完测了一发数据交了T了.此时刻盘想出F,刻盘敲,凯神准备优化C,我看B.此前大约整整一

2018 ACM 国际大学生程序设计竞赛上海大都会赛重现赛 A Fruit Ninja

传送门 题解:给你一堆点问你能不能找出一条直线,使其穿过的点大于n*x. 题解:想起某道CF题目,给你一堆点问你能不能找出两条直线使其穿过所有的点.当时就是在一定时限内随机找了两个点,再枚举每个点是否满足,如果超过该时限仍然不满足则直接返回no.这题也是一样的做法,直接随机两个点,再枚举过去.因为x为0.1到0.9,所以如果所给数据满足条件,那么它有极大概率能够跑出结果.4发只有一次超时 #include<bits/stdc++.h> //CLOCKS_PER_SEC #define se s

2018 ACM 国际大学生程序设计竞赛上海大都会赛重现赛-K-Matrix Multiplication(矩阵乘法)

题目描述 In mathematics, matrix multiplication or matrix product is a binary operation that produces a matrix from two matrices with entries in a field, or, more generally, in a ring or even a semiring. The matrix product is designed for representing the

2018 ACM 国际大学生程序设计竞赛上海大都会赛重现赛-B-Perfect Numbers(完数)

题目描述 We consider a positive integer perfect, if and only if it is equal to the sum of its positive divisors less than itself. For example, 6 is perfect because 6 = 1 + 2 + 3. Could you write a program to determine if a given number is perfect or not?

分治算法初步

hdu1007 http://acm.hdu.edu.cn/showproblem.php?pid=1007 解题关键:分治算法求解,注意学习分治算法的写法 1 #include<cstdio> 2 #include<cstring> 3 #include<algorithm> 4 #include<cstdlib> 5 #include<cmath> 6 #include<iostream> 7 #define inf 0x3f3f

分治算法(Divide and Conquer)

分治算法 在计算机科学中,分治法是建基于多项分支递归的一种很重要的算法范式.字面上的解释是“分而治之”,就是把一个复杂的问题分成两个或更多的相同或相似的子问题,直到最后子问题可以简单的直接求解,原问题的解即子问题的解的合并. 分治法所能解决的问题一般具有以下几个特征: 问题的规模缩小到一定的程度就可以容易地解决 问题可以分解为若干个规模较小的相同问题,即该问题具有最优子结构性质 利用该问题分解出的子问题的解可以合并为该问题的解 该问题所分解出的各个子问题是相互独立的,即子问题之间不包含公共的子问