Bro Sorting(2014ACM/ICPC亚洲区北京站-K)

Bro Sorting

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0

Problem Description

   Matt’s friend K.Bro is an ACMer.

   Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

   Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

   There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .

Input

   The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

   The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

   The sum of N in all test cases would not exceed 3 × 106.

Output

   For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.

Sample Input

2
5
5 4 3 2 1
5
5 1 2 3 4

Sample Output

Case #1: 4
Case #2: 1

Hint

In the second sample, we choose “5” so that after the ?rst round, sequence becomes “1 2 3 4 5”, and the algorithm completes.

过的稀里糊涂的一道题。看着数据10^6太大,常规方法肯定TLE,然后在想如果是交换的话肯定是后面的数值比前面的数值大,所以就设定第一个为最大的,后面要是出现比他大的就交换,否则的话就就cnt++,然后敲出来第二组数据的结果是4,后来才发现是找到比当前的数大的数就停止。然后就在想倒着来行不行,因为倒着的话没有前面的那个碰到比自己大的数就停止的限制。就令最后的值为最小值,碰到前面比自己大的就cnt++,否则就更新当前最小值。(如果你正着来看的话正好是是处于后面的值比前面的值小,而不是交换)。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[1000010];
int main()
{
    int T,n,i,j;
    int min;
    int cnt;
    scanf("%d",&T);
    for(j=1;j<=T;j++)
    {
        cnt=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        min=a[n-1];
        for(i=n-2;i>=0;i--)
        {
            if(min>a[i])
                min=a[i];
            else
                cnt++;

        }
        printf("Case #%d: %d\n",j,cnt);
    }
    return 0;
}
时间: 2024-10-19 14:16:08

Bro Sorting(2014ACM/ICPC亚洲区北京站-K)的相关文章

K.Bro Sorting(杭电5122)(2014ACM/ICPC亚洲区北京站)

K.Bro Sorting Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 67    Accepted Submission(s): 39 Problem Description Matt's friend K.Bro is an ACMer. Yesterday, K.Bro learnt an algorithm: Bubbl

2014ACM/ICPC亚洲区北京站-重现赛 [B.Black And White] 涂色DFS

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5113 题目大意:在一个N * M的棋盘里涂色,要求i颜色要涂ci次.ci求和为N * M. 关键思想:从第一个点开始着色,一行一行涂,注意一旦找到答案后面就不必搜,当剩下个数为n时若有种颜色>n/2上取整就不必搜了(!). #include <iostream> #include <iomanip> #include <cstdio> #include <cst

2014ACM/ICPC亚洲区北京站-A-(Curious Matt)

A Curious Matt                                   Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wandering on the non-neg

A Curious Matt(2014ACM/ICPC亚洲区北京站)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0    Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wander

A Curious Matt(2014ACM/ICPC亚洲区北京站-A)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0    Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wander

2014ACM/ICPC亚洲区北京站-A Curious Matt

A Curious Matt Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0 Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wandering on

2014ACM/ICPC亚洲区北京站

A http://acm.hdu.edu.cn/showproblem.php?pid=5112 输入n个时刻和位置,问那两个时刻间速度最快. 解法:按照时间排序,然后依次求相邻两个之间的速度,速度=ds/dt 1 #include<cstdio> 2 #include<algorithm> 3 using namespace std; 4 const int M=1e4+10; 5 struct G{ 6 int t,x; 7 friend bool operator <(

HDU 5112 A Curious Matt (2014ACM/ICPC亚洲区北京站-重现赛)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 3058    Accepted Submission(s): 1716 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is w

2014ACM/ICPC亚洲区北京站题解

本题解不包括个人觉得太水的题(J题本人偷懒没做). 个人觉得这场其实HDU-5116要比HDU-5118难,不过赛场情况似乎不是这样.怀疑是因为老司机带错了路. 这套题,个人感觉动态规划和数论是两个主要的考点. HDU 5113 Black And White HDU 5114 Collision HDU 5116 Everlasting L HDU 5117 Fluorescent HDU 5118 GRE Words Once More!