poj 1007 Quoit Design(分治)

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29694    Accepted Submission(s): 7788

Problem Description

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.

In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a
configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered
to be 0.

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated
by N = 0.

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output

0.71
0.00
0.75
#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
#include <cstring>
using namespace std;

const double eps = 1e-7;
const double INF = 100000000000;
struct point{
    double x , y;
    point(double a = 0 , double b = 0){
        x = a , y = b;
    }
};
vector<point> P;
int N;

bool cmp(point p1 , point p2){
    if(p1.x == p2.x) return p1.y<p2.y;
    return p1.x<p2.x;
}

bool cmpy(point p1 , point p2){
    return p1.y<p2.y;
}

void initial(){
    P.clear();
}

void readcase(){
    double x , y;
    for(int i = 0; i < N; i++){
        scanf("%lf%lf" , &x , &y);
        P.push_back(point(x , y));
    }
}

double dis(point p1 , point p2){
    return sqrt((p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
}

double fenzhi(int l , int r){
    if(l == r) return INF;
    if(r-l==1) return dis(P[l] , P[r]);
    int mid = (l+r)/2;
    double d = min(fenzhi(l,mid) , fenzhi(mid+1 , r));
    int index = mid;
    vector<point> tP;
    for(int i = mid+1; i <= r; i++){
        if(d-(P[i].x-P[mid].x) >= eps) tP.push_back(P[i]);
    }
    sort(tP.begin() , tP.end() , cmpy);
    while(d-(P[mid].x-P[index].x) >= eps && index >= l){
        for(int i = 0; i < tP.size(); i++){
            if(tP[i].y-P[index].y-d>=eps) break;
            d = min(d , dis(tP[i] , P[index]));
        }
        index--;
    }
    return d;
}

void computing(){
    sort(P.begin() , P.end() , cmp);
    printf("%.2lf\n" , fenzhi(0 , N-1)/2);
}

int main(){
    while(scanf("%d" , &N) && N){
        initial();
        readcase();
        computing();
    }
    return 0;
}
时间: 2024-10-30 19:43:31

poj 1007 Quoit Design(分治)的相关文章

hdu 1007 Quoit Design 分治求最近点对

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29344    Accepted Submission(s): 7688 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 [Quoit Design] 分治

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1007 题目大意:N个点,求最近一对点的距离的一半. 关键思想:最傻瓜式的枚举所有点对的距离找最短 O(n^2),会TLE. 分治可以优化成O(nlogn).二分区间,考虑三种情形:点对的两点都在左区间.两点都在右区间.两点一左一右 前两种情况,可以递归地解出来,分别为d1,d2.第三种,可以依据min(d1,d2)收缩成一条带状区域(勾股定理显然). 然后对带中所有点进行处理,此时又可依据min(d

HDU 1007 Quoit Design (分治)

Quoit Design Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. In the field of Cyberground, the position of each toy is fixed, and the ri

HDU 1007 Quoit Design【计算几何/分治/最近点对】

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 58566    Accepted Submission(s): 15511 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

分治 [HDU 1007] Quoit Design

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33577    Accepted Submission(s): 8800 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 Quoit Design

Quoit Design Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 130 Accepted Submission(s): 72   Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings a

ZOJ - 2107 Quoit Design [分治]

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=17751 题目描述:求最近点对 题目分析:分治,(nlogn): 为什么,第二轮按排序:http://noalgo.info/793.html 代码: //problem: zoj 2107 Quoit Design //author: ACsorry //result: Yes #include<iostream> #include<cstdio>

HDU 1007 Quoit Design(二分+浮点数精度控制)

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 47104    Accepted Submission(s): 12318 Problem Description Have you ever played quoit in a playground? Quoit is a game in which fla

HDOJ 1007 Quoit Design 最近点对

3年前刚接触ACM的时候做的这一题,交了几十次怎么写都过不了......... 今天无意中又看到了这一题,随手一写终于过了..... Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33151    Accepted Submission(s): 8709 Problem Description Have y