C++风格写判断某年某月某日是一年的第几天

初学C++,在结构体中写函数及一些C++语言需要的一些格式

看代码

#include<iostream>
#include<cstdio>
using namespace std;

struct what_day
{
int year;
int month;
int day;
void count(int year,int month,int day)
{
int s[12]={0,31,28,31,30,31,30,31,31,30,31,30};
int sum=day;
for(int i=0;i<month;i++)
{
sum=sum+s[i];
}
if((year%400||(year%4==0&&year%100))&&month>2)
{
sum++;
}
cout<<sum<<endl;
}
};

int main()
{
cout<<"please input year month day"<<endl;
what_day num;
cin>>num.year>>num.month>>num.day;
num.count(num.year,num.month,num.day);
return 0;
}

时间: 2024-10-13 15:46:41

C++风格写判断某年某月某日是一年的第几天的相关文章

python中输入某年某月某日,判断这一天是这一年的第几天?

输入某年某月某日,判断这一天是这一年的第几天?程序分析 特殊情况,闰年时需考虑二月多加一天: 直接上代码 #定义一个函数,判断是否为闰年 def leapyear(y): return (y % 400 == 0 or (y % 4 ==0 and y % 100 ==0)) #定义一个数组,每个月的天数,由于python中的数组是从0开始,而月份是从1开始,所以数组第一个数为0 days = [0,31,28,31,30,31,30,31,31,30,31,30] #存储月份的天数 res =

Python实现 : 输入某年某月某日,判断某一天为当年的第几天

PTA_Python程序设计(判断某一天为当年的第几天) 输入某年某月某日,判断这一天是这一年的第几天?程序分析:以3月5日为例,应该先把前两个月的加起来,然后再加上5天即本年的第几天,特殊情况,闰年且输入月份大于3时需考虑多加一天.若输入错误的数据,则输出data error!输入格式: 2020 3 10 输出格式: it is the 70th day. 输入样例: 在这里给出一组输入.例如: 2020 3 101输出样例: 在这里给出相应的输出.例如: import datetime t

02-输出某年某月某日的天数

<!DOCTYPE html> <html> <head lang="en"> <meta charset="UTF-8"> <title></title> </head> <body> <script> //需求:输入某年某月某日,判断这一天是这一年的第几天?(闰年) //(四年一闰,百年不闰,四百年在闰) //步骤: //1.判断是否是闰年. //2.求天

iOS - 日期的时间差(某年某月某日的某一天。。。)

//首先创建格式化对象 NSDateFormatter *dateFormatter = [[NSDateFormatter alloc] init]; [dateFormatter setDateFormat:@"yyyy-MM-dd HH:mm:ss"]; //然后创建日期对象 NSDate *date1 = [dateFormatter dateFromString:@"2014-12-20 00:00:00"]; NSDate *date = [NSDate

JS计算从某年某月某日到某年某月某日的间隔天数差

直接贴代码了,你直接拷贝然后另存为html就可以用了,不多说,请看: <!DOCTYPE html> <html lang="en" xmlns="http://www.w3.org/1999/xhtml"><head> <meta charset="utf-8" /> <title></title> <script type="text/javascript

输入某年某月某日,判断这一天是这一年的第几天?

import java.util.Scanner; /** * @author 蓝色以太 从控制台输入月份,输出本月有多少天. */ public class Day { public static void main(String[] args) { Scanner sc = new Scanner(System.in); int month, year; do { System.out.println("请正确输入年份:"); year = sc.nextInt(); System

js 输出某年某月某日的天数/判断闰年

console.log(getDays(2017,12,12)); function getDays(year,month,day){ var arr = [31,28,31,30,31,30,31,31,30,31,30,31]; for(var i=0;i<month-1;i++){ day += arr[i]; } if(month>2 && isRN(year)){ day+=1; } return day; } function isRN(year){ if(year

输出某年某月某日的天数

(1)第一步,先判断是否是闰年; function isRN(year){ if(year%4===0 && year%100 !==0 || year%400 ===0){ return ture; }else{ return false; } (2)第二步,先把平年每个月的天数组成一个数组,写出天数的计算方式; var arr = [31,28,31,30,31,30,31,31,30,31,30,31]; var day = for(var i=0;i<month-1;i++)

给定某年某月某日,输出其为这一年的第几天。

int y = 0, m = 0, d = 0; int sum = 0;//用来存储其位这一年的第几天 printf("第七题:请输入年月日:"); scanf("%d%d%d", &y, &m, &d); int a[12] = {31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}; int b[12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30,