HDU 4707 Pet

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1909    Accepted Submission(s): 924

Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

Sample Input

1

10 2

0 1

0 2

0 3

1 4

1 5

2 6

3 7

4 8

6 9

Sample Output

2

Source

2013 ACM/ICPC Asia Regional Online —— Warmup

题意:在0号房间放一个奶酪,在距离D之内的房间的仓鼠都会被吸引过来,求在距离D之外的房间有多少个?

分析:用vector保存,遍历即可。

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
#define FIN freopen("in.txt","r",stdin)
using namespace std;
const int MAXN = 1000000+10;
vector<int> G[MAXN];
int d[MAXN];
int n,D,ans;
void bfs()
{
    memset(d,-1,sizeof(d));
    d[0]=0;
    queue<int> Q;
    Q.push(0);
    while(!Q.empty())
    {
        int u=Q.front(); Q.pop();
        for(int i=0;i<G[u].size();i++)
        {
            int v=G[u][i];
            if(d[v]==-1)
            {
                d[v]=d[u]+1;
                Q.push(v);
            }
        }
    }
}
void add(int u,int v)
{
    G[u].push_back(v);
    G[v].push_back(u);
}
int main()
{
    int kase;
    scanf("%d",&kase);
    while(kase--)
    {
        for(int i=0;i<n;i++) G[i].clear();

        scanf("%d %d",&n,&D);
        for(int i=1;i<n;i++)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            add(u,v);
        }

        bfs();

        ans=0;
        for(int i=0;i<n;i++)
            if(d[i]>D)
                ans++;
        printf("%d\n",ans);
    }
    return 0;
}

时间: 2024-09-30 00:59:27

HDU 4707 Pet的相关文章

hdu 4707 Pet【BFS求树的深度】

Pet                                                          Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1909    Accepted Submission(s): 924 链接:pid=4707">Click Me ! Problem Description O

hdu 4707 Pet(dfs,bfs)

Pet Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1548    Accepted Submission(s): 733 Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He sear

hduoj 4707 Pet 2013 ACM/ICPC Asia Regional Online —— Warmup

http://acm.hdu.edu.cn/showproblem.php?pid=4707 Pet Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in th

hdu 4707 bfs

bfs基础算法水题 #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<string> #include<vector> #include<queue> using namespace std; const int Max = 1e5+50; int dist[Max]; vector<int> t

Pet(hdu 4707 BFS)

Pet Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2052    Accepted Submission(s): 1007 Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He sear

HDU 4707 DFS

Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for

杭电 4707 pet(并查集求元素大于k的集合)

Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three da

hdu 4707 仓鼠 记录深度 裸bfs

题意:linji的仓鼠丢了,他要找回仓鼠,他在房间0放了一块奶酪,按照抓鼠手册所说,这块奶酪可以吸引距离它D的仓鼠,但是仓鼠还是没有出现,现在给出一张关系图,表示各个房间的关系,相邻房间距离为1,而且图中没有回路,每个房间都是联通的,求仓鼠可能出现的房间的数量. Sample Input110 20 10 20 31 41 52 63 74 86 9 Sample Output2 1 #include <cstdio> 2 #include <algorithm> 3 #inclu

HDU 4707 水DFS

所有房子组成一颗树,求出离根节点0的距离大于d的节点数目 DFS+vector存边 水过 #include "stdio.h" #include "string.h" #include "vector" using namespace std; vector<int>mapp[100010]; int ans,d; void dfs(int cur,int pre,int op) { int i; for (i=0;i<mapp