HDU 3746 Cyclic Nacklace(KMP求循环节)

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题意:给一个字符串,问至少需要增加几个字符使修改后的字符串含有至少两个循环节。此题给出两个基于KMP的思路。思路一:发现KMP的前缀next数组len-nxt[len]就是该字符串的最小循环节。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 4;
char s[maxn];
int nxt[maxn];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",&s);
                //next数组的构建
		int j = 0, k = -1;
		int len = strlen(s);
		nxt[0] = -1;
		while(j<len){
			if(k == -1 || s[j] == s[k]){
				j++;
				k++;
				nxt[j] = k;
			}
			else k = nxt[k];
		}
                //只有一个循环节
		if(nxt[len] == 0){
			printf("%d\n",len);
			continue;
		}
		int pos = len - nxt[len];
		int res;
                //有完整的多个循环节
		if(len % pos == 0) res = 0;
                //不完整的循环节
		else res = pos - len % pos;
		printf("%d\n",res);
	}
}

思路二:用一个该串作为模板串,从原串的第二个字符去匹配。相差的即为最小循环节。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 4;
char s[maxn];
int nxt[maxn];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",&s);
                //构建next数组
		int j = 0, k = -1;
		int len = strlen(s);
		nxt[0] = -1;
		while(j<len){
			if(k == -1 || s[j] == s[k]){
				j++;
				k++;
				nxt[j] = k;
			}
			else k = nxt[k];
		}
		//应用kmp
		int i = 1; k = 0;
		while(i<len){
			while(k != -1 && s[i] != s[k]) k = nxt[k];
			++i;
			++k;
		}
		int pos = len - k;
		int res = (pos - (len % pos)) % pos;
		if(pos == len) res = len;
		printf("%d\n",res);
	}
}

				
时间: 2024-12-30 21:34:48

HDU 3746 Cyclic Nacklace(KMP求循环节)的相关文章

hdu 3746 Cyclic Nacklace (KMP求最小循环节)

//len-next[len]为最小循环节的长度 # include <stdio.h> # include <algorithm> # include <string.h> using namespace std; int len; char a[100010]; int next[100010]; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=len) { if(j==-1||a[i]==a[j]) i

hdu 3746 Cyclic Nacklace KMP循环节问题

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4124    Accepted Submission(s): 1866 Problem Description CC always becomes very depressed at the end of this month, he has checke

hdu 3746 Cyclic Nacklace KMP

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=3746 题目: Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed

HDU 3746 Cyclic Nacklace (KMP 循环节)

分析:对next数组的深入理解,最重要的还是对最小循环节的处理. #include <stdio.h> #include <string.h> int next[100005]; char str2[100005]; void build_next(int len2) { int i=0,j=-1; next[0] = -1; while (i < len2) { if (j==-1 || str2[i] == str2[j]) { i++; j++; // if (str2

HDU 3746 Cyclic Nacklace (KMP找循环节)

题目链接:HDU 3746 Sample Input 3 aaa abca abcde Sample Output 0 2 5 Author possessor WC Source HDU 3rd "Vegetable-Birds Cup" Programming Open Contest Solution 题意 给定一个字符串,问至少需要在末尾添加多少个字符使得字符串循环. 思路 KMP 设前缀函数为 \(\pi()\),字符串长度为 \(n\),下标从 \(1\) 开始. 最小循环

hdu 3746 Cyclic Nacklace(求最少添加几个字符使得字符串是由n(n&gt;=2)个循环节组成的)

代码: #include<cstdio> #include<cstring> using namespace std; char a[100005]; int next[100005]; int LCPS[100005]; int n,m; void GetLCPS() { int j=0; int k=-1; int len=strlen(a); next[0]=-1; while(j<len) { if(k==-1||a[k]==a[j]) { LCPS[j++]=++k

HDU 3746 Cyclic Nacklace (KMP找循环节)

Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Bein

(KMP 1.4)hdu 3746 Cyclic Nacklace(使用next数组来求循环节的长度——求一个字符串需要添加多少个字符才能使该字符串的循环节的个数&gt;=2)

题目: Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3387    Accepted Submission(s): 1549 Problem Description CC always becomes very depressed at the end of this month, he has che

模板题 + KMP + 求最小循环节 --- HDU 3746 Cyclic Nacklace

Cyclic Nacklace Problem's Link: http://acm.hdu.edu.cn/showproblem.php?pid=3746 Mean: 给你一个字符串,让你在后面加尽量少的字符,使得这个字符串成为一个重复串. 例: abca---添加bc,成为abcabc abcd---添加abcd,成为abcdabcd aa---无需添加 analyse: 经典的求最小循环节. 首先给出结论:一个字符串的最小循环节为:len-next[len]. 证明: 举个例子:abcab

HDU - 3746 Cyclic Nacklace (KMP求循环节)

Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspir