NYOJ714 Card Trick 【队列模拟】

Card Trick

时间限制:1000 ms  |  内存限制:65535 KB

难度:3

描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
样例输入
2
4
5
样例输出
2 1 4 3
3 1 4 5 2

 /*
 **题意是给定一个1到n的某种初始序列,然后将列首数放到序列的末尾(操作一次),将新的队首元素放到
 **桌面,再将队首的两个数放到末尾(操作两次),新树放到桌面,以此类推。最终得到的数列是1到n的递
 **增序列。求初始序列。
 **这是一道模拟题,可以逆推:由于最终序列一定是1,2,3...n,所以最后一个摆在桌面上的数一定是n,
 **且n被“操作”了n次,倒数第二个被放到桌面的数一定是n-1且n-1一定和n一起被“操作”了n-1次,以此类推。
 **可以倒着模拟,即先将最终数列放到数组里,再从第n个数开始模拟,即将第n个数向前“操作”n次,实际上
 **位置没变,然后将第n-1个数加入到“操作”中且与第n个数一起向前“操作”n-1次,以此类推,最终得到的数
 **列即是初始序列。
 */
#include <stdio.h>
#include <string.h>
int a[15];

void move(int bot, int top, int n){
	while(n--){
		int t = a[top], tt;
		for(int i = bot; i <= top; ++i){
			tt = a[i];
			a[i] = t;
			t = tt;
		}
	}
}

int main(){
	int t, n, bot, top;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 1; i <= n; ++i) a[i] = i;
		top = bot = n;
		for(int i = n; i >= 1; --i){
			move(bot, top, i % (top - bot + 1));
			--bot;
		}
		for(int i = 1; i <= n; ++i)
			printf("%d ", a[i]);
		printf("\n");
	}
	return 0;
}
        

NYOJ714 Card Trick 【队列模拟】

时间: 2024-11-08 04:49:38

NYOJ714 Card Trick 【队列模拟】的相关文章

nyoj714 Card Trick(第六届河南省程序设计大赛)

题目714 题目信息 运行结果 本题排行 讨论区 Card Trick 时间限制:1000 ms  |  内存限制:65535 KB 难度:3 描述 The magician shuffles a small pack of cards, holds it face down and performs the following procedure: The top card is moved to the bottom of the pack. The new top card is deal

河南省第六届大学生程序设计竞赛--Card Trick

Card Trick Time Limit: 2 Seconds    Memory Limit: 64 MB Description The magician shuffles a small pack of cards, holds it face down and performs the following procedure: 1. The top card is moved to the bottom of the pack. The new top card is dealt fa

UVA246 - 10-20-30(队列+ 模拟)

题目:UVA246 - 10-20-30(队列+ 模拟) 题目大意:给出52张牌,不分花色,先发七张,形成7堆,然后再从左往右的发牌.如果能够找到三张牌他们的和是10, 20, 30的话,就可以把三张牌按照先后顺序放到你手中的牌的后面.这样一直进行下去,如果你手中有52张牌就赢了,如果你手中没有牌就输了,如果某个状态之前已经出现过,那么就输出draw.然后还要输出总共处理了多少张牌能够得到结果. 解题思路:注意这里不是有三种情况取三张牌,题目貌似保证只会出现这三种中的某一种,这样情况就减少了.然

用两个队列模拟实现一个栈的过程

栈具有"后进先出"的特点,即某个元素最后进入栈,却最先出栈:队列具有"先进先出"的特点,即元素从队尾依次进队列,依次从队头出队列:现在用两个队列模拟实现一个栈的过程,详细过程请看下面这张本人制作的gif图: 实现代码: #include <iostream> using namespace std; #include <queue> template <typename T> class Stack { public: void

Codeforces 704A Thor 队列模拟

题目大意:托尔有一部手机可执行三种操作 1.x APP产生一个新消息 2.读取x App已产生的所有消息 3.读取前t个产生的消息 问每次操作后未读取的消息的数量 题目思路: 队列模拟,坑点在于竟然卡内存……详细看代码. #include<iostream> #include<algorithm> #include<cstring> #include<vector> #include<stdio.h> #include<stdlib.h&g

uestcoj 890 Card Trick(dp+逆推)

题目链接: 啊哈哈,点我点我 思路:从终点向前递推. 首先p[I]表示从第i个点到终点的概率.则分为两种情况进行考虑. [1]已经翻到的点则它必定会到终点,则概率为1. [2]不知道的点则要进行枚举.那么p[i]=sum(p[i+j])/13(2=<j<=13).那么这个问题就解决了.. 为什么要逆推,因为从前往后走,要用到后面的状态. 哎,自己的dp好弱啊,一个暑假好像都没怎么做..哎,加油啊!!! 题目: Card Trick Time Limit: 2999/999MS (Java/Ot

火车车厢重排问题--队列模拟

①问题描述 一列货运列车共有n节车厢,每节车厢将停放在不同的车站.假定n个车站的编号分别为1-n,即货运列车按照第n站至第1站的次序经过这些车站.为了便于从列车上卸掉相应的车厢,车厢的编号应与车站的编号相同,这样,在每个车站只要卸掉最后一节车厢.所以,给定任意次序的车厢,必须重新排列它们. 车厢的重排工作可以通过转轨站完成.在转轨站中有一个入轨.一个出轨和k个缓冲轨,缓冲轨位于入轨和出轨之间.假定缓冲轨按先进先出的方式运作,设计算法解决火车车厢重排问题. ②基本要求 设计存储结构表示n个车厢.k

nyoj 714 Card Trick

Card Trick 时间限制:1000 ms  |  内存限制:65535 KB 难度:3 描述 The magician shuffles a small pack of cards, holds it face down and performs the following procedure: The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table.

用队列模拟基数排序

function Queue() { //用队列模拟基数排序对应的Queue构造函数中的方法一个都不能少,否则会出错 this.dataStore = []; this.enqueue = enqueue; this.dequeue = dequeue; this.empty = empty; } function enqueue(element) {//向队尾添加一个元素 this.dataStore.push(element); } function dequeue() {//删除队首的元素