hdu---5095---Linearization of the kernel functions in SVM

http://acm.hdu.edu.cn/showproblem.php?pid=5095

分析:当a[i]不为0的时候,就有输出;

 输出内容:1.系数为正数且不是第一个位置输出一个‘+‘;

      2.当系数为-1时且不是最后一个常数时输出一个‘-‘;

      3.系数不是-1或1或者是最后那个常数时输出这个数;

      4.最后一个位置没有字符要输出。

Problem Description

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.
Now your task is to write a program to change f into g.

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

Sample Input

2
0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

Sample Output

46q+3r+4u-5v-22w-8x-32y+24z+27
2p+31q-5r+12w-49z+12

Source

2014上海全国邀请赛——题目重现(感谢上海大学提供题目)

Recommend

hujie   |   We have carefully selected several similar problems for you:  5808 5807 5806 5805 5804

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include<vector>
#include<algorithm>
using namespace std;
#define PI 3.1415926

const int maxn=1000007;
const int INF=0x3f3f3f3f;

char str[10]={"pqruvwxyz"};
int a[10];

int main()
{
    int T;
    scanf("%d", &T);

    while(T--)
    {
        for(int i=0; i<10; i++)
            scanf("%d", &a[i]);

        int f=0;
        for(int i=0; i<10; i++)
        {
            if(a[i])///当a[i]不为0的时候,就有输出;
            {
                if(f && a[i]>0)printf("+");///系数为正数且不是第一个位置输出一个‘+‘;

                if(a[i]==-1 && i!=9)printf("-");///当系数为-1时且不是最后一个常数时输出一个‘-‘;

                if((a[i]!=-1&&a[i]!=1) || (i==9))printf("%d", a[i]);///系数不是-1或1或者是最后那个常数时输出这个数

                if(i!=9)printf("%c", str[i]);///最后一个位置没有字符要输出

                f=1;///标记判断

            }
        }
        printf("\n");
    }
    return 0;
}
时间: 2024-08-28 01:19:32

hdu---5095---Linearization of the kernel functions in SVM的相关文章

hdu 5095 Linearization of the kernel functions in SVM(模拟)

Linearization of the kernel functions in SVM Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 206    Accepted Submission(s): 109 Problem Description SVM(Support Vector Machine)is an important cl

HDU 5095 Linearization of the kernel functions in SVM(模拟)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5095 Problem Description SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions

hdu 5095 Linearization of the kernel functions in SVM 坑多的水题 细节

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5095 几个坑 系数为正负1是不输出系数(比赛时wa到死) 0时不输出但全零时要输出0 加号和减号的控制 #include <cstring> #include <cstdlib> #include <cstring> #include <cmath> #include <algorithm> #include <iostream> #in

模拟 HDOJ 5095 Linearization of the kernel functions in SVM

题目传送门 1 /* 2 题意:表达式转换 3 模拟:题目不难,也好理解题意,就是有坑!具体的看测试样例... 4 */ 5 #include <cstdio> 6 #include <algorithm> 7 #include <iostream> 8 #include <cstring> 9 #include <cmath> 10 #include <string> 11 #include <vector> 12 #i

HDU5095——水过——Linearization of the kernel functions in SVM

Problem Description SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss t

hdoj-2095-Linearization of the kernel functions in SVM

Linearization of the kernel functions in SVM Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2239 Accepted Submission(s): 599 Problem Description SVM(Support Vector Machine)is an important classif

hdu 5095

Linearization of the kernel functions in SVM Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1001    Accepted Submission(s): 286 Problem Description SVM(Support Vector Machine)is an important cl

2014上海全国邀请赛 解题报告

Game with Pearls 贪心水题 http://blog.csdn.net/u012774187/article/details/40711559 Beam Cannon 线段树陈题 http://blog.csdn.net/u012774187/article/details/40712359 Seam Carving 简单DP http://blog.csdn.net/u012774187/article/details/40712899 Battle ships 二分图陈题 ht

Android linux kernel privilege escalation vulnerability and exploit (CVE-2014-4322)

In this blog post we'll go over a Linux kernel privilege escalation vulnerability I discovered which enables arbitrary code execution within the kernel. The vulnerability affected all devices based on Qualcomm chipsets (that is, based on the "msm&quo