poj 3414 Pots(BFS)(简单题)

Pots

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11551   Accepted: 4900   Special Judge

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its
    contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the
desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

题意:

两个杯子,一个勺,两个杯子的水量通过勺子装水或倒水操作变化,求最初状态变化到最终状态所需最小步数。

思路:

bfs遍历,每次有6种变化,由最初状态变化到最终状态所需最小步数。

代码:

#include <stdio.h>
#include <memory.h>
#define MAX 10001
typedef struct Node
{
	int a,b,step,pre,flag;
};
int A,B,C;
Node queue[MAX];
bool visit[101][101];
int path[MAX],index;
void bfs()
{
	memset(visit,false,sizeof(visit));
	int front=0,rear=0;
	Node cur,next;
	cur.a=0,cur.b=0,cur.pre=-1,cur.step=0;
	visit[0][0]=true;
	queue[rear++]=cur;
	while(front!=rear)
	{
		cur=queue[front++];
		if(cur.a==C||cur.b==C) break;
		for(int i=0;i<6;i++)
		{
			switch(i)
			{
			case 0: next.a=A; next.b=cur.b; next.flag=0; break;
			case 1:next.a=cur.a; next.b=B; next.flag=1; break;
			case 2:next.a=0; next.b=cur.b; next.flag=2; break;
			case 3:next.a=cur.a; next.b=0; next.flag=3; break;
			case 4:
				if(B-cur.b<cur.a)
				{
					next.a=cur.a+cur.b-B;
					next.b=B;
					next.flag=4;
				}
				else
				{
					next.a=0;
					next.b=cur.a+cur.b;
					next.flag=4;
				}
				break;
			default:
				if(A-cur.a<cur.b)
				{
					next.a=A;
					next.b=cur.a+cur.b-A;
					next.flag=5;
				}
				else
				{
					next.a=cur.a+cur.b;
					next.b=0;
					next.flag=5;
				}
			}//遍历完由该状态可以到达的状态
			if(!visit[next.a][next.b])
			{
				next.step=cur.step+1;
				next.pre=front-1;//[front++]
				queue[rear++]=next;
				visit[next.a][next.b]=true;
			}
		}
	}
	if(front==rear) {printf("impossible/n"); return ;}
	index=0;
	for(int i=front-1;i>=0;)
	{
		path[index++]=i;
		i=queue[i].pre;
	}
	printf("%d\n",queue[front-1].step);
	for(int i=index-1;i>=0;i--)
	{
		switch(queue[path[i]].flag)
		{
		case 0:printf("FILL(1)\n");break;
		case 1:printf("FILL(2)\n"); break;
		case 2:printf("DROP(1)\n"); break;
		case 3:printf("DROP(2)\n"); break;
		case 4:printf("POUR(1,2)\n"); break;
		case 5:printf("POUR(2,1)\n"); break;
		}
	}
}
int main()
{
	scanf("%d %d %d",&A,&B,&C);
	bfs();
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-04 18:29:33

poj 3414 Pots(BFS)(简单题)的相关文章

POJ 3414 Pots (BFS + 记录路径)

Pots Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 10300 Accepted: 4362 Special Judge Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: FILL(i)        fill th

POJ 3414 Pots(BFS 倒水)

题意  你有两个容积分别为a,b杯子  你每次可以将某个杯子中的水倒满或者倒掉或者倒到另一个杯子  问能否通过这两个杯子量出c容量的水 和上一个倒可乐问题类似  只是这个操作更多了点  将两个杯子中各含有的水作为状态  每出队列一个状态  将所有可能到达的状态入队  直到有一个杯子里面水的体积为c   打印路径直接递归就行了 #include <map> #include <cstdio> #include <cstring> using namespace std;

POJ 3414 Pots(bfs打印路径)

题意:给定两个空桶的容量分别为A.B,经过6种操作使获得C升水,求最少操作数: 思路:广搜.最少操作数很简单,练习一下打印路径:打印最短路劲就是每次记录当前状态和上一步,找到终点后查找路径. #include<cstdio> #include<cstring> #include<algorithm> using namespace std; #define INF 0x3f3f3f3f int A,B,C; int shortest[150][150];//更新最短步数

poj 3414 pots (bfs+路径记录)

Pots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11703   Accepted: 4955   Special Judge Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: FILL(i)        f

POJ 3414 Pots (BFS/DFS)

Pots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7783   Accepted: 3261   Special Judge Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: FILL(i)        fi

POJ 3414 Pots (经典bfs )

Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: FILL(i)        fill the pot i (1 ≤ i ≤ 2) from the tap; DROP(i)      empty the pot i to the drain; POUR(i,j)    pour from

POJ 3414 Pots(罐子)

p.MsoNormal { margin-bottom: 10.0000pt; font-family: Tahoma; font-size: 11.0000pt } h1 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: left; font-family: 宋体; font-weight: bold; font-size: 24.0000pt } span.10 { font-family: "Times New Rom

广搜+输出路径 POJ 3414 Pots

POJ 3414 Pots Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 13547   Accepted: 5718   Special Judge Description You are given two pots, having the volume of A and B liters respectively. The following operations can be performed: FILL(i)

BFS简单题套路_Codevs 1215 迷宫

BFS 简单题套路 1. 遇到迷宫之类的简单题,有什么行走方向的,先写下面的 声明 const int maxn = 20; struct Status { int r, c; Status(int r = 0, int c = 0) : r(r), c(c) {} // int DIR; }; int N; //迷宫数量 int W; //迷宫宽度 char map[maxn][maxn]; //地图 //方向 : 分别代表 上.右.下.左向量 int dir[4][2] = { {-1, 0