Hdoj 2062

原题链接

描述

Consider the aggregate An= { 1, 2, …, n }. For example, A1={1}, A3={1,2,3}. A subset sequence is defined as a array of a non-empty subset. Sort all the subset sequece of An in lexicography order. Your task is to find the m-th one.

输入

The input contains several test cases. Each test case consists of two numbers n and m ( 0< n<= 20, 0< m<= the total number of the subset sequence of An ).

输出

For each test case, you should output the m-th subset sequence of An in one line.

样例输入

1 1

2 1

2 2

2 3

2 4

3 10

样例输出

1

1

1 2

2

2 1

2 3 1

思路

打表找规律后,能很容易发现递推公式f(n) = n * f(n-1) + n , f(n)表示n个数的时候最多有几个。

故利用递推公式预处理,然后把握好一些细节就可以了,有几个要注意的点:

1.每种情况最后一个数后面没有空格(因为这个我PE了一次);

2.确定上一个数字后,下一个数字的情况应当加一,因为存在空集的情况,而算f(n)的时候是没有考虑空集的。

代码

#include <bits/stdc++.h>
#define ll long long
using namespace std;

ll n, m;
ll a[22] = {0, 1};

void myprintf(int f[], int t)
{
    int sum = 0;
    for(int i = 0; i <= 20; i++)
    {
        if(f[i] == 0) sum++;
        if(sum == t)
        {
            printf("%d", i+1);
            m--; n--;
            m %= a[n] + 1;
            if(m > 0) printf(" ");
            f[i] = 1;
            break;
        }
    }
}

int main()
{
    for(int i = 2; i < 21; i++) a[i] = i * a[i - 1] + i;
    while(~scanf("%lld %lld", &n, &m))
    {
        int f[21] = {0};
        while(m > 0 && n >= 0)
        {
            int t = m / (a[n - 1] + 1);
            if(m % (a[n - 1] + 1) == 0) myprintf(f, t);
            else myprintf(f, t + 1);
        }
        printf("\n");
    }
    return 0;
}

原文地址:https://www.cnblogs.com/HackHarry/p/8372051.html

时间: 2024-10-09 18:30:20

Hdoj 2062的相关文章

【HDOJ】4328 Cut the cake

将原问题转化为求完全由1组成的最大子矩阵.挺经典的通过dp将n^3转化为n^2. 1 /* 4328 */ 2 #include <iostream> 3 #include <sstream> 4 #include <string> 5 #include <map> 6 #include <queue> 7 #include <set> 8 #include <stack> 9 #include <vector>

POJ Xiangqi 4001 &amp;&amp; HDOJ 4121 Xiangqi

题目链接(POJ):http://poj.org/problem?id=4001 题目链接(HDOJ):http://acm.hdu.edu.cn/showproblem.php?pid=4121 Xiangqi Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1108   Accepted: 299 Description Xiangqi is one of the most popular two-player boa

【HDOJ】4956 Poor Hanamichi

基本数学题一道,看错位数,当成大数减做了,而且还把方向看反了.所求为最接近l的值. 1 #include <cstdio> 2 3 int f(__int64 x) { 4 int i, sum; 5 6 i = sum = 0; 7 while (x) { 8 if (i & 1) 9 sum -= x%10; 10 else 11 sum += x%10; 12 ++i; 13 x/=10; 14 } 15 return sum; 16 } 17 18 int main() { 1

HDOJ 4901 The Romantic Hero

DP....扫两遍组合起来 The Romantic Hero Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 547    Accepted Submission(s): 217 Problem Description There is an old country and the king fell in love with a

【HDOJ】1099 Lottery

题意超难懂,实则一道概率论的题目.求P(n).P(n) = n*(1+1/2+1/3+1/4+...+1/n).结果如果可以除尽则表示为整数,否则表示为假分数. 1 #include <cstdio> 2 #include <cstring> 3 4 #define MAXN 25 5 6 __int64 buf[MAXN]; 7 8 __int64 gcd(__int64 a, __int64 b) { 9 if (b == 0) return a; 10 else return

【HDOJ】2844 Coins

完全背包. 1 #include <stdio.h> 2 #include <string.h> 3 4 int a[105], c[105]; 5 int n, m; 6 int dp[100005]; 7 8 int mymax(int a, int b) { 9 return a>b ? a:b; 10 } 11 12 void CompletePack(int c) { 13 int i; 14 15 for (i=c; i<=m; ++i) 16 dp[i]

HDOJ 3790 双权值Dijkstra

1 #include <iostream> 2 #include <stdio.h> 3 #include <string.h> 4 #include <cstring> 5 using namespace std; 6 7 const int INF = 1000000; 8 const int MAXSIZE = 1005; 9 10 int map[MAXSIZE][MAXSIZE]; 11 int price[MAXSIZE][MAXSIZE]; 1

HDOJ 1217 Floyed Template

1 #include <iostream> 2 #include <stdio.h> 3 #include <string.h> 4 #include <cstring> 5 #include<map> 6 using namespace std; 7 8 map<string,int>name; 9 const int INF = 1000000; 10 const int MAXSIZE = 1005; 11 const int

hdoj 4004 The Frog&#39;s Games(二分)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 5676    Accepted Submission(s): 2732 Problem Description The annual Games in frogs' kingdom started again. The most famous game i