hdu1598 find the most comfortable road (枚举)+【并查集】

<题目链接>

题目大意:

XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ), 
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。


Input

输入包括多个测试实例,每个实例包括: 
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。 
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000 
然后是一个正整数Q(Q<11),表示寻路的个数。 
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

Output

每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input

4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2

Sample Output

1
0解题分析:由于数据范围很小,所以可以先将所有边排序,然后枚举最小边,然后按顺序枚举最大边,每次枚举的时候都判断一下起点和终点是否连通(用并查集判断),如果联通了,就更新一下最大、最小边权之差。
#include <cstdio>
#include <algorithm>
using namespace std;

#define INF 0x3f3f3f3f
#define M 205
struct EDGE{
    int x,y,val;
}edge[1005];
int father[M],n,m;
void init(){
    for(int i=1;i<=n;i++)father[i]=i;
}
int find(int x){
    if(father[x]==x)return x;
    father[x]=find(father[x]);
    return father[x];
}
bool cmp(EDGE a,EDGE b){
    return a.val<b.val;
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=1;i<=m;i++)scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].val);
        sort(edge+1,edge+1+m,cmp);
        int q;scanf("%d",&q);
        while(q--){
            int s,e;scanf("%d%d",&s,&e);
            mn=INF;
            for(int i=1;i<=m;i++){  //枚举最小边
                init();
                bool fp=false;
                for(int j=i;j<=m;j++){    //寻找最大边
                    int f1=find(edge[j].x);
                    int f2=find(edge[j].y);
                    if(f1!=f2){
                        father[f2]=f1;
                    }
                    if(find(s)==find(e)){   //判断起点与终点是否连通
                        fp=true;
                        mn=min(mn,edge[j].val-edge[i].val);    //更新最大、最小边权之差
                    }
                }
                if(!fp)break;  //如果从第i条边开始,即使连上了所有边也不能使起点、终点连通,就直接跳出,因为后面从i+1,i+2开始的所有边连接后也不能使起点、终点连通
            }
            if(mn==INF)printf("-1\n");
            else printf("%d\n",mn);
        }
    }
    return 0;
}

2018-10-07

原文地址:https://www.cnblogs.com/00isok/p/9751958.html

时间: 2024-11-13 09:42:36

hdu1598 find the most comfortable road (枚举)+【并查集】的相关文章

HDU1598 find the most comfortable road 【并查集】+【枚举】

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3686    Accepted Submission(s): 1565 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超

hdu 1598 find the most comfortable road(并查集+枚举)

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4899    Accepted Submission(s): 2131 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超

hdoj 1598 find the most comfortable road 【并查集】+【暴力枚举】

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4022    Accepted Submission(s): 1732 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超

hdu1598 find the most comfortable road 枚举+最小生成树

1 #include<cstdio> 2 #include<cstring> 3 #include<algorithm> 4 #define MAXN 210 5 #define INF 2147483646 6 using namespace std; 7 8 int f[MAXN], Rank[MAXN]; //Rank长度 9 int n, m, pos; 10 11 struct Edge{ 12 int u, v, val; 13 //按照val从小到大排列

HDU1598 find the most comfortable road

题目描述: XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),但XX星人对时间却没那么多要求.要你找出一条城市间的最舒适的路径.(SARS是双向的). 输入: 输入包括多

hdu 1598 find the most comfortable road(枚举+卡鲁斯卡尔最小生成树)

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3999    Accepted Submission(s): 1720 Problem Description XX 星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超

(枚举+并查集) hdu 1598

find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4096    Accepted Submission(s): 1768 Problem Description XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级

枚举+并查集 之 CODE[VS] 1001 舒适的路线 2006年

/* 枚举所有情况,通过并查集判断在当前情况下,是否包含起始和终止点, 若包含,则需判断是否在当前情况下,最大速度和最小速度的比更小, 若是,则更新最大速度和最小速度. 最后枚举过所有情况后,即获得答案. */ 1 #include <iostream> 2 #include <cstdlib> 3 #include <cstdio> 4 #include <cstddef> 5 #include <iterator> 6 #include &l

BZOJ 1050: [HAOI2006]旅行comf(枚举+并查集)

[HAOI2006]旅行comf Description 给你一个无向图,N(N<=500)个顶点, M(M<=5000)条边,每条边有一个权值Vi(Vi<30000).给你两个顶点S和T,求一条路径,使得路径上最大边和最小边的比值最小.如果S和T之间没有路径,输出”IMPOSSIBLE”,否则输出这个比值,如果需要,表示成一个既约分数. 备注: 两个顶点之间可能有多条路径. Input 第一行包含两个正整数,N和M.下来的M行每行包含三个正整数:x,y和v.表示景点x到景点y之间有一条