poj3280--Cheapest Palindrome(区间dp)

Cheapest Palindrome

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6186   Accepted: 3014

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag‘s contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of
N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows‘s ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤
cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow‘s ID tag and the cost of inserting or deleting each of the alphabet‘s characters, find the minimum cost to change the ID tag so
it satisfies FJ‘s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and
M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 +
350 = 900, which is the minimum.

给出一个字符串,每个字符被添加或删除都有一个花费,问将字符串改为回文串的最小花费。

dp[i][j]代表字符串中从i到j的这一段子串改成回文串的最小花费,由dp[i][j],添加或删除一个字符在两侧可以得到,

dp[i-1][j],dp[i][j+1],如果str[i-1]==str[j+1]那么就得到了,dp[i-1][j+1]

最终求得的结果dp[0][m-1]

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define INF 0x3f3f3f3f
#define LL __int64
struct node{
    int k1 , k2 ;
}p[30];
char str[2100] ;
LL dp[2100][2100] ;
int main()
{
    int n , m , x , k1 , k2 , i , j , l ;
    char ch ;
    scanf("%d %d", &n, &m) ;
    scanf("%s", str) ;
    for(i = 0 ; i < n ; i++)
    {
        getchar() ;
        scanf("%c %d %d", &ch, &k1, &k2) ;
        x = ch - 'a' ;
        p[x].k1 = k1 ; p[x].k2 = k2 ;
    }
    memset(dp,INF,sizeof(dp)) ;
    for(i = 0 ; i < m ; i++)
    {
        dp[i][i] = 0 ;
        if( i+1 < m && str[i] == str[i+1])
            dp[i][i+1] = 0 ;
    }
    for(l = 0 ; l < m ; l++)
    {
        for(i = 0 ; i <= m-l ; i++)
        {
            j = i+l-1 ;
            if( i > 0 )
                dp[i-1][j] = min( dp[i-1][j],min( p[str[i-1]-'a'].k1,p[str[i-1]-'a'].k2 )+dp[i][j] ) ;
            if( j < m )
                dp[i][j+1] = min( dp[i][j+1],min( p[str[j+1]-'a'].k1,p[str[j+1]-'a'].k2 )+dp[i][j] ) ;
            if( i > 0 && j < m && str[i-1] == str[j+1] )
                dp[i-1][j+1] = min( dp[i-1][j+1],dp[i][j] ) ;
        }
    }
    /*for(i = 0 ; i < m ; i++)
    {
        for(j = 0 ; j < m ; j++)
            printf("%I64d ", dp[i][j]) ;
        printf("\n") ;
    }*/
    printf("%I64d\n", dp[0][m-1]) ;
    return 0;
}

时间: 2024-09-30 19:30:42

poj3280--Cheapest Palindrome(区间dp)的相关文章

POJ 3280:Cheapest Palindrome 区间DP好题

Cheapest Palindrome 题目链接: http://poj.org/problem?id=3280 题意: 给出一个只由小写字母组成的串,可以添加或删除一些字母(添加和删除都需要花费且花费不同),求将这个串改变成一个回文串的最小花费. 题解: 设dp[i][j]是将区间[i,j]改变成回文串的最小花费,则两种情况 ①显而易见,当s[i]==s[j]时,dp[i][j]=dp[i+1][j-1] ②当s[i]!=s[j]时,dp[i][j]有四种可能的取值,区间 [i,j-1] 删除

POJ3280 Cheapest Palindrome 【DP】

Cheapest Palindrome Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 6013   Accepted: 2933 Description Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow a

poj 3280 Cheapest Palindrome(区间DP)

Cheapest Palindrome Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 5995   Accepted: 2922 Description Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow a

POJ 3280 Cheapest Palindrome ( 区间DP &amp;&amp; 经典模型 )

题意 : 给出一个由 n 中字母组成的长度为 m 的串,给出 n 种字母添加和删除花费的代价,求让给出的串变成回文串的代价. 分析 :  原始模型 ==> 题意和本题差不多,有添和删但是并无代价之分,要求最少操作几次才能是其变成回文串 ① 其实细想之后就会发现如果没有代价之分的话删除和增添其实是一样的,那么除了原串原本拥有的最长回文串不用进行考虑处理,其他都需要进行删除或者增添来使得原串变成回文串,所以只要对原串 S 和其反向串 S' 找出两者的最长公共子串长度 L 再用总长减去 L 即可 ②

POJ 3280 Cheapest Palindrome(DP)

题目链接 题意 :给你一个字符串,让你删除或添加某些字母让这个字符串变成回文串,删除或添加某个字母要付出相应的代价,问你变成回文所需要的最小的代价是多少. 思路 :DP[i][j]代表的是 i 到 j 这一段位置变成回文所需的最小的代价. 1 //3280 2 #include <stdio.h> 3 #include <string.h> 4 #include <iostream> 5 6 using namespace std ; 7 8 char sh[2100]

POJ 1159 Palindrome(区间DP/最长公共子序列+滚动数组)

Palindrome Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 56150   Accepted: 19398 Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a

POJ3280Cheapest Palindrome(区间dp)

Language: Default Cheapest Palindrome Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 6227   Accepted: 3032 Description Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has insta

poj3280 Cheapest Palindrome

思路: 区间dp.添加和删除本质相同. 实现: 1 #include <iostream> 2 #include <cstdio> 3 using namespace std; 4 int n,m; 5 int cost[30]; 6 int dp[2005][2005]; 7 int main() 8 { 9 string s; 10 int x,y; 11 char z; 12 cin >> n >> m >> s; 13 for(int i

[luoguP2890] [USACO07OPEN]便宜的回文Cheapest Palindrome(DP)

传送门 f[i][j] 表示区间 i 到 j 变为回文串所需最小费用 1.s[i] == s[j] f[i][j] = f[i + 1][j - 1] 2.s[i] != s[j] f[i][j] = min(f[i + 1][j] + cost[s[i]], f[i][j - 1] + cost[s[j]]) 开头去掉一个字母和结尾增加一个字母的效果是一样的 所以 cost[s[i]] = min(add[s[i]], del[s[i]]) ——代码 1 #include <cstdio>

Uva 10617 Again Palindrome(区间dp)

Again Palindromes Input: Standard Input Output: Standard Output Time Limit: 2 Seconds A palindorme is a sequence of one or more characters that reads the same from the left as it does from the right. For example, Z, TOT and MADAM are palindromes, but