poj1573&&hdu1035 Robot Motion(模拟题)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1035

POJ:   http://poj.org/problem?id=1573

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

纯模拟题;

代码如下:

#include <iostream>
using namespace std;
#include <cstring>
#define M 1000
char mat[M][M];
int re[M][M];
int n, m, s;
int ans, i, j, k;
void F()
{
	i = 1; j = s;
	k = 0;
	for(int l = 1; ; l++)
	{
		if(re[i][j] != 0)
		{
			ans = k - re[i][j];
			break;
		}
		if(i>n || i<1 || j>m || j<1)
		{
			break;
		}
		if(mat[i][j] == 'N')
		{
			k++;
			re[i][j] = k;
			i-=1;
			continue;
		}
		if(mat[i][j] == 'S')
		{
			k++;
			re[i][j] = k;
			i+=1;

			continue;
		}
		if(mat[i][j] == 'W')
		{
			k++;
			re[i][j] = k;
			j-=1;
			continue;
		}
		if(mat[i][j] == 'E')
		{
			k++;
			re[i][j] = k;
			j+=1;
			continue;
		}
	}
}
int main()
{
	while(cin>>n>>m>>s)
	{
		ans = 0;
		if(n == 0 && m == 0 && s == 0)
		break;
		memset(mat,0,sizeof(mat));
		memset(re,0,sizeof(re));
		for(i = 1; i <= n; i++)
		{
			for(j = 1; j <= m; j++)
			{
				cin>>mat[i][j];
			}
		}
		F();
		if(ans == 0)
		cout<<k<<" step(s) to exit"<<endl;
		else
		cout<<re[i][j]-1<<" step(s) before a loop of "<<ans+1<<" step(s)"<<endl;
	}
	return 0;
}

poj1573&&hdu1035 Robot Motion(模拟题)

时间: 2024-08-28 00:03:49

poj1573&&hdu1035 Robot Motion(模拟题)的相关文章

POJ1573 ZOJ1708 UVA10116 UVALive5334 HDU1035 Robot Motion【DFS+BFS】

Robot Motion Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 16166 Accepted: 7643 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a g

[ACM] hdu 1035 Robot Motion (模拟或DFS)

Robot Motion Problem Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down t

hdu1035 Robot Motion (DFS)

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8180    Accepted Submission(s): 3771 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

HDU1035 Robot Motion【链式前向星】

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7039    Accepted Submission(s): 3244 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

HDU 1035 [Robot Motion] 模拟 记忆

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1035 题目大意:给出一个地图,每个点都指定下一步的方向.问移动情况(何时走出地图或几步后进入多长的循环) 关键思想:模拟+记忆化.我的做法是访问过的点vis置1,往后每走一步,走过的所有点vis++,因为每个点都可能是循环的节点.后面回到一个vis>1的点,vis-1就是循环长度了.(也可以记录到每个点的步数,最后点的步数差值就是循环长度) 代码如下 //模拟 记忆.可优化 #include <i

69棋牌游戏源码,POJ 1573 Robot Motion模拟

主题:http://pj.org/Debug ID=1573    主要思想:棋盘上充满了N,E,S,W指令.人们按照棋盘的指示从北方的初始列开始移动,直到你下完棋或四处走动.    N意味着向北(向上)移动.    E意味着向东移动(右).    S意味着向南移动(下).    W意味着向西移动(左).    分析:因为棋盘只有10*10,也就是说最多只有100步,所以您可以使用模拟算法.我们声明一个用于记录指令的字符卡映射,以及一个初始值为零的象棋卡,用于记录所走过的路径.国际象棋棋局或发现

poj1573 Robot Motion

题目链接: http://poj.org/problem?id=1573 题目: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10202   Accepted: 4971 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direct

POJ1573——Robot Motion

Robot Motion Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down the page)

HDOJ1035 Robot Motion 【模拟】

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6079    Accepted Submission(s): 2844 Problem Description A robot has been programmed to follow the instructions in its path. Instruc