ACboy needs your help(DP)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4542    Accepted Submission(s): 2431

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the
profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

题意: 题目给出n个课程和m天,问如何安排m天的课程使得最后的收益达到最大值.

题解: 简单DP,以dp[i]表示当前安排i天可以获得的最大收益,则可以得出状态转移方程dp[k + j] = max(dp[k + j], dp[k] + a[i][j]); 表示当前的课程安排j天的最
优解. 具体看下代码吧!

AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#define eps 1e-9

using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int M = 200;
const int INF = 0x3f3f3f3f;
const int mod = 10000007;
int maxn[M][M],dp[M],tp[M];

int main(){
    //freopen("in","r",stdin);
    int n,m;
    while(~scanf("%d %d",&n,&m) && (n | m)){
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= m; j++){
                scanf("%d",&maxn[i][j]);
            }
        }
        for(int i = 1; i <= m; i++) dp[i] = maxn[1][i]; //初始化
        for(int i = 2; i <= n; i++){
            for(int k = 1; k <= m; k++) tp[k] = dp[k]; //防止当前的状态会覆盖之前的值,所以先把最优值保存在tp数组中;
            for(int j = 1; j <= m; j++){
                for(int k = 0; k + j <= m; k++){
                    tp[k + j] = max(tp[k + j],dp[k] + maxn[i][j]);
                }
            }
            for(int k = 1; k <= m; k++) dp[k] = max(tp[k],dp[k]);
        }
        int Max = 1;
        for(int i = 2; i <= m; i++)
            if(dp[Max] < dp[i]) Max = i;
        printf("%d\n",dp[Max]);
    }
    return 0;
}
时间: 2024-12-11 18:24:02

ACboy needs your help(DP)的相关文章

hdu1561--H - ACboy needs your help(树形dp)

H - ACboy needs your help Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from diffe

HDU 1712 ACboy needs your help(DP)

Problem Description ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the

hdu 1712 ACboy needs your help (dp 分组背包)

#include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int a[200][200]; int dp[200]; int main() { int n,m; int i,j,k; while(scanf("%d%d",&n,&m)!=EOF) { if(n==0&&m==0

hdu 1561 The more, The Better 树状DP

The more, The Better Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5844    Accepted Submission(s): 3476 Problem Description ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝

[HDU 1561] The more, The Better (树形dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1561 题目大意:ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物.但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡.你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗? 设计状态 dp[u][i] 代表以u为根的,选择i个的最大收获 状态转移 dp[u][j+k] =

HD1561The more, The Better(树形DP+有依赖背包)

The more, The Better Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6765    Accepted Submission(s): 3978 Problem Description ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物

(树形DP) hdu 1561

The more, The Better Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5822    Accepted Submission(s): 3469 Problem Description ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物

hdu 1561The more, The Better(树形dp&amp;01背包)

The more, The Better Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4949    Accepted Submission(s): 2918 Problem Description ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝

HDU_1561_The more, The Better_树型dp

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1561 The more, The Better Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7031    Accepted Submission(s): 4121 Problem Description ACboy很喜欢玩一种战略游戏,