MySQL架构组成之物理文件组成

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 1651    Accepted Submission(s): 653

Problem Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the
right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!

At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power
she need to escape from the LOOPS.

Input

The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1,
c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000
/*题意:有一个迷宫r行m列,开始点在[1,1]现在要走到[r,c]
对于在点[x,y]可以打开一扇门走到[x+1,y]或者[x,y+1]
消耗2点魔力
问平均消耗多少魔力能走到[r,c]

分析:假设dp[i][j]表示在点[i,j]到达[r,c]所需要消耗的平均魔力(期望)
则从dp[i][j]可以到达:
dp[i][j],dp[i+1,j],dp[i][j+1];
对应概率分别为:
p1,p2,p3
由E(aA+bB+cC...)=aEA+bEB+cEC+...//包含状态A,B,C的期望可以分解子期望求解
得到dp[i][j]=p1*dp[i][j]+p2*dp[i+1][j]+p3*dp[i][j+1]+2;
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=1000+10;
int n,m;
double dp[MAX][MAX],p[MAX][MAX][3];

int main(){
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j)scanf("%lf%lf%lf",&p[i][j][0],&p[i][j][1],&p[i][j][2]);
        }
        memset(dp,0,sizeof dp);
        for(int i=n;i>=1;--i){
            for(int j=m;j>=1;--j){
                if(i == n && j == m)continue;
                if(p[i][j][0] == 1.00)continue;//该点无路可走,期望值肯定为0(dp[i][j]=0)
                dp[i][j]=(p[i][j][1]*(dp[i][j+1])+p[i][j][2]*(dp[i+1][j])+2)/(1-p[i][j][0]);
            }
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
} 

MySQL架构组成之物理文件组成

时间: 2024-10-11 17:57:48

MySQL架构组成之物理文件组成的相关文章

论Mysql5.7.13架构组成之物理文件

论Mysql5.7.13架构组成之物理文件 防伪码:岁寒,然后知松柏之后凋也 一.MySQL Server 简介 什么是 MySQL MySQL 是由 MySQL AB 公司(目前已经被ORACLE 公司收归麾下)自主研发的,目前 IT 行 业 最流行的开放源代码的数据库管理系统之一,它同时也是一个支持多线程高并发多用户的关 系型数据库管理系统. MySQL 数据库以其简单高效可靠的特点,在最近短短几年的时间就从一个名不见经传的 数据库系统,变成一个在 IT 行业几乎是无人不知的开源数据库管理系

MySQL 架构组成--物理文件组成

博主QQ:819594300 博客地址:http://zpf666.blog.51cto.com/ 有什么疑问的朋友可以联系博主,博主会帮你们解答,谢谢支持! 一.MySQL Server 简介 什么是MySQL? 答:是目前IT行业最流行的开放源代码的数据库管理系统之一,它同时也是一个支持多线程高并发多用户的关系型数据库管理系统. 特点: 简单:安装简单 高效:读写性能高,仅次于oracle 可靠:运行稳定 MySQL 与其他数据库的简单比较: 1)       功能比较 2)       易

MySQL 架构组成--物理文件组成 for mysql6.7.13

http://hongge.blog.51cto.com/ 一.MySQL Server 简介 什么是MySQL MySQL 是由MySQL AB 公司(目前已经被SUN 公司收归麾下)自主研发的,目前IT 行业 最流行的开放源代码的数据库管理系统之一,它同时也是一个支持多线程高并发多用户的关 系型数据库管理系统. MySQL 数据库以其简单高效可靠的特点,在最近短短几年的时间就从一个名不见经传的 数据库系统,变成一个在IT 行业几乎是无人不知的开源数据库管理系统.从 小型的web 网站,至大型

MySQL 物理文件体系结构的简单整理说明

本文出处:http://www.cnblogs.com/wy123/p/7102128.html (保留出处并非什么原创作品权利,本人拙作还远远达不到,仅仅是为了链接到原文,因为后续对可能存在的一些错误进行修正或补充,无他) 本文的数据库版本是MySQL5.7.18,简单介绍一下MySQL数据文件目录的物理结构和作用,从中可以窥见MySQL的整体上的物理文件结构以及逻辑功能.可以从整体结构上了解到MySQL的物理体系架构(本人学习的思路往往是被与已了解的事物对照学习,或者快速了解其轮廓,再逐步细

mysql物理文件组成

一:MySQL 与其他数据库比较 1)功能比较 作为一个成熟的数据库系统管理系统,现在已经具备通用数据库管理系统的相关功能 2)易用性比较 对于普通用户操作难度相对简单易用原则,从安装方面来说,MySQL安装包仅仅只有100MB左右,安装难易程度要比Oracl,数据库简单很多,不论是通过已经编译好的二进制分发包还是源码编译安装,都比较简单 3)性能比较 MySQL非常优异表现,而且其他商用的通用数据库系统中,只有Oracle数据库能相提并论. 4可靠性)MySQL数据库发展过程三个原则, 简单,

MySQL 物理文件

1 .参数文件及mysql参数 查看mysql 的 my.cnf 配置文件位置命令:>./bin/mysql --help | grep my.cnf 查看mysql 的参数设置命令: mysql >  show variables  --显示所有参数; // show variables like 'log_error%' 显示某匹配参数 mysql > select @@session.read_buffer_size; 查看当前session的read_buffer_size my

SSM+MySQL开发架构中SQL mapper文件的解析和审计

SSM+MySQL已是Java开发的主流架构.在SSM+MySQL架构中,SQL一般写在mapper映射文件中,对于mapper文件的审计一直是个头疼的问题,测试人员很难覆盖mapper文件中动态SQL的所有情况,开发人员更是无法罗列每一个select id对应的所有SQL.在和开发同时沟通后,觉得自己可以写一个小工具来解决这一痛点!笔者作为一名DBA,自学了golang,经过七个月的努力初步完成了myaudit这一款实用性极强的SQLAudit小工具的开发,欢迎使用和吐槽,项目地址:https

一次修改数据库物理文件造成Mysql宕机的恢复记录

事件起始 某夜,我正在床上冥想准备入睡,忽然同事向我求救:消息内容如下: Oh My Gold 改了些配置,啥都没了!都没了!没了!了! 我仔细询问,原来是她因为某些原因将某库的物理文件夹改名后,发现数据库找不到了.于是又将名称改回来.结果仍然找不到.这让她觉得数据可能被损坏了,于是赶忙来找我修复. 修复过程 我们数据库用的版本是 MySQL5.7 ,放置在Linux服务器上,在my.cnf 配置了数据库物理文件的存放地址.存放于 data 文件夹下. 表的存储引擎全部使用 InnoDB,dat

数据库学习之--Oracle 架构与MySQL架构对比

数据库学习之--Oracle 架构与MySQL架构对比 一.Oracle .MySQL应用对比 如果要说明三者的区别,首先就要从历史入手. Oracle:中文译作甲骨文,这是一家传奇的公司,有一个传奇的大老板Larry Ellision. Ellision 32岁还一事无成,读了三个大学,没得到一个学位文凭,换了十几家公司,老婆也离他而去.开始创业时只有1200美元,却使得Oracle公司连续12年销售额每年翻一番. Oracle成立于1977年,早期的理论基础,反而来自于一篇IBM的论文<A