hdu 4268 Alice and Bob(multiset|段树)

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2901    Accepted Submission(s): 941

Problem Description

Alice and Bob‘s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob‘s. The card A can cover the card B if the height
of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob‘s cards that Alice can cover.

Please pay attention that each card can be used only once and the cards cannot be rotated.

Input

The first line of the input is a number T (T <= 40) which means the number of test cases.

For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and
width of Alice‘s card, then the following N lines means that of Bob‘s.

Output

For each test case, output an answer using one line which contains just one number.

Sample Input

2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4 

Sample Output

1
2

Source

field=problem&key=2012+ACM%2FICPC+Asia+Regional+Changchun+Online&source=1&searchmode=source">2012 ACM/ICPC Asia Regional Changchun Online

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  4272 4277 

pid=4273" target="_blank">4273 4270 4269

题意:

A,B两个人各有n个矩形。

(n<=1e5)如今A想用自己的矩形覆盖B的矩形。一个矩形覆盖还有一个矩形的条件是宽和高都不还有一个矩形相应的宽和高小。如今问A最多能覆盖B的多少个矩形。每一个矩形最多覆盖一个还有一个矩形。且矩形不能旋转。

思路:

就是贪心的思想。先把两个人的矩形都按w排序。

然后对于A的每个矩形。找一个w<=自己w.h<自己H且尽量接近的B的矩形覆盖即可了。

覆盖后删除这两个矩形。对于找上述条件的矩形能够用multiset维护。

可是比赛时换了种姿势用线段树写了发。

思路都差点儿相同。离散化。维护区间和。找小于等于p且最靠右的位置。

具体见代码:

#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define lson L,mid,ls
#define rson mid+1,R,rs
const int maxn=100010;
int num[maxn<<3];//离散化后有2*n忘了改大空间了。

坑
struct node
{
    int w,h;
} ag[maxn],bg[maxn];
int H[maxn<<1];
inline bool cmp(const node &a,const node &b)
{
    if(a.w==b.w)
        return a.h<b.h;
    return a.w<b.w;
}
void build(int L,int R,int rt)
{
    num[rt]=0;
    if(L==R)
        return ;
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1;
    build(lson);
    build(rson);
}
void update(int L,int R,int rt,int p,int d)
{
    if(L==R)
    {
        num[rt]+=d;
        return;
    }
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1;
    if(p<=mid)
        update(lson,p,d);
    else
        update(rson,p,d);
    num[rt]=num[ls]+num[rs];
}
int qu(int L,int R,int rt,int p)
{
    if(!num[rt])
        return -1;
    if(L==R)
        return L;
    int ls=rt<<1,rs=ls|1,mid=(L+R)>>1,pos=-1;
    if(p<=mid)
        return qu(lson,p);
    if(num[rs])
         pos=qu(rson,p);
    if(pos!=-1)
        return pos;
    return qu(lson,p);
}
int main()
{
    int t,n,i,m,p,ans;

    scanf("%d",&t);
    while(t--)
    {
        m=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&ag[i].h,&ag[i].w);
            H[m++]=ag[i].h;
        }
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&bg[i].h,&bg[i].w);
            H[m++]=bg[i].h;
        }
        sort(ag,ag+n,cmp);
        sort(bg,bg+n,cmp);
        sort(H,H+m);
        m=unique(H,H+m)-H;
        build(1,m,1);
        ans=p=0;
        for(i=0;i<n;i++)
        {
            while(p<n&&bg[p].w<=ag[i].w)
                update(1,m,1,lower_bound(H,H+m,bg[p].h)-H+1,1),p++;
            int pos=qu(1,m,1,lower_bound(H,H+m,ag[i].h)-H+1);
            if(pos!=-1)
            {
                ans++;
                update(1,m,1,pos,-1);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

时间: 2024-10-14 19:17:08

hdu 4268 Alice and Bob(multiset|段树)的相关文章

hdu 4268 Alice and Bob(multiset|线段树)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2901    Accepted Submission(s): 941 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

HDU 4268 Alice and Bob(multiset的使用)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3046    Accepted Submission(s): 995 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

hdu 4268 Alice and Bob(multiset)

# include<stdio.h> # include<algorithm> # include<iostream> # include<string.h> # include<map> # include<set> # include<vector> using namespace std; struct node { int h; int w; }; struct node a[100010],b[100010];

HDU 4268 Alice and Bob(贪心+multiset)

HDU 4268 题意:Alice与Bob在玩卡片游戏,他们每人有n张卡片,若Alice的一张卡片长与宽都不小于Bob的一张卡片,则Bob的卡片就会被盖住,一张卡片只可以使用一次,且不可旋转求Alice最多可以盖住多少张Bob的卡片. 思路:记录两人卡片情况,并按照长度将两人卡片分别降序排序.遍历两人的卡片,将长度小于Alice的卡片长度的Bob卡片的宽度插入multiset中,在multiset中找到小于等于Alice卡片宽度的第一个数,将这个数给消去且答案+1.//贪心法自行发挥即可. co

HDU 4268 Alice and Bob(贪心+Multiset的应用)

 题意: Alice和Bob有n个长方形,有长度和宽度,一个矩形可以覆盖另一个矩形的条件的是,本身长度大于等于另一个矩形,且宽度大于等于另一个矩形,矩形不可旋转,问你Alice最多能覆盖Bob的几个矩形? 思路:贪心,先按照h将Alice和Bob的矩形排序,对于Alice的每个矩形,如果Bob的矩形的h小于Alice的h,将Bob的w插入到集合中. 然后,在集合中找到不大于Alice矩形d的最大的Bob的d,那么这样做肯定是最优的. #include<cstdio> #include<

hdu 4268 Alice and Bob(贪心+multiset+二分)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3511    Accepted Submission(s): 1129 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In thi

hdu 4268 Alice and Bob

Alice and Bob Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 5   Accepted Submission(s) : 1 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Alice and Bob's game nev

HDU 4268 Alice and Bob(贪心)

Alice and Bob                                                                Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description Alice and Bob's game never ends. Today, they introduce a new game. I

HDU 4268 Alice and Bob 贪心STL O(nlogn)

B - Alice and Bob Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively.