HDU1532 Drainage Ditches (网络流)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14451    Accepted Submission(s): 6840

Problem Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow.
Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch,
so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has
dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections
between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题意:n个点,m条单向边,求1到n的最大流。

分析:是一道网络流的基础入门题,也是道模板题。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 1e9;
const int MOD = 1e9+7;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define N 1010

int n,m,s,t;
int pre[N];
int mat[N][N];
bool vis[N];

bool bfs()
{
    int cur;
    queue<int> Q;
    CL(pre, 0);
    CL(vis, false);
    vis[s] = true;
    Q.push(s);
    while(!Q.empty())
    {
        cur = Q.front();
        Q.pop();
        //cout<<cur<<endl;
        if(cur == t) return true;
        for(int i=1; i<=n; i++)
        {
            if(!vis[i] && mat[cur][i])
            {
                Q.push(i);
                pre[i] = cur;
                vis[i] = true;
                //cout<<cur<<"->"<<i<<endl;
            }
        }
    }
    return false;
}

int max_flow()
{
    int ans = 0;
    while(1)
    {

        if(!bfs()) return ans;
        int Min = INF;
        for(int i=t; i!=s; i=pre[i])
            Min = min(Min, mat[pre[i]][i]);
        for(int i=t; i!=s; i=pre[i])
        {
            mat[pre[i]][i] -= Min;
            mat[i][pre[i]] += Min;
        }
        ans += Min;
    }
}

int main()
{
    int u,v,c;
    while(scanf("%d%d",&m,&n)==2)
    {
        CL(mat, 0);
        s = 1;
        t = n;
        //Q.push(s);
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&c);
            mat[u][v] += c;
        }
        printf("%d\n",max_flow());
    }
    return 0;
}

时间: 2024-10-09 05:46:06

HDU1532 Drainage Ditches (网络流)的相关文章

POJ 1273 Drainage Ditches(网络流 最大流)

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 55893   Accepted: 21449 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

POJ 1273 Drainage Ditches 网络流基础

Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage

hdu1532——Drainage Ditches(网络流模板)

Problem Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of d

POJ 1273 Drainage Ditches (网络流Dinic模板)

Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage

POJ 1273 Drainage Ditches (网络流最大流基础 Edmonds_Karp算法)

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 59219   Accepted: 22740 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

hdu-----(1532)Drainage Ditches(最大流问题)

Drainage Ditches Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9580    Accepted Submission(s): 4541 Problem Description Every time it rains on Farmer John's fields, a pond forms over Bessie's

USACO 4.2 Drainage Ditches(网络流模板题)

Drainage DitchesHal Burch Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a se

poj 1273 Drainage Ditches 网络流最大流基础

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 59176   Accepted: 22723 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

HDU1532 Drainage Ditches 【最大流】

Drainage Ditches Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9715    Accepted Submission(s): 4623 Problem Description Every time it rains on Farmer John's fields, a pond forms over Bessie's