HDOJ-1050-Moving Tables(nyoj220)

推桌子

时间限制:1000 ms  |  内存限制:65535 KB

难度:3

描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager‘s problem.
输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.
输出
The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
样例输出
10
20
30
上传者
苗栋栋

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int num[300]={0};//初始化数组。一共400个房间,简化后为200个,所以定义300大小,没问题;
int s,e,t,n;
while(~scanf("%d",&n))
{
for(int i = 0;i<n;i++)
{
scanf("%d%d",&s,&e);
s = (s+1)/2;  //可以看为将对面两个房间的房间号变为一样,将房间数简化为200个,且在一条直线上,看做区间覆盖问题。
e = (e+1)/2;
if(s>e)//不论是从小房间号到大房间号,还是从大房间号到小房间号,都化为一条直线上从小到大的排序,便于标记计算。
swap(s,e);//交换大小
for(int j = s;s<=e;j++)//重点来了,之前初始化数组为0,现在对每一组输入进行标记,比如从15-16,其实s=8,e=8,标记在一条线段上为8处+1,以此类推,若第二组经过8,则8处再+1; 
num[j]++;
}
int ans = 0;//初始比较数,设为0,没有经过的房间数在数组中值都为0,经过以此即为1,以此类推;
for(int i = 0;i<200;i++)
{
if(num[i]>ans)
ans = num[i];//循环遍历整个200大小的数组,找出数组中的最大值,即为推桌子活动中重叠的次数;
}
printf("%d\n",ans*10);
}
return 0;
}

终于弄懂了,入门艰难,且行且珍惜,加油!!

时间: 2024-08-26 19:23:14

HDOJ-1050-Moving Tables(nyoj220)的相关文章

hdoj 1050 moving tables

代码: #include <iostream> #include <algorithm> //#include <fstream> using namespace std; int f[201]; int main() { //ifstream cin("1050_input.txt");   //调试用 int t, n, i, j, s, e; cin >> t; while( t-- ){ memset( f, 0, sizeof(

hdoj 1050 Moving Tables【贪心区间覆盖】

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24316    Accepted Submission(s): 8053 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a b

HDOJ 1050 Moving Tables(经典贪心)

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24553    Accepted Submission(s): 8116 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a

Hdoj 1050.Moving Tables 题解

Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made

HDU 1050 Moving Tables

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23044    Accepted Submission(s): 7749 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a

HDU 1050 Moving Tables (贪心)

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20302    Accepted Submission(s): 6889 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a

HDU 1050.Moving Tables【细节与方法选取】【8月26】

Moving Tables Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. The floor has 200 rooms each on the north side and south side along the corridor. Recently the

HDU 1050 Moving Tables(贪心)

Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made

--hdu 1050 Moving Tables(贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050 AC code: #include<stdio.h> #include<string.h> int m[210]; int main(void) { int t,n,i,j,st,en,ma; scanf("%d",&t); while(t--) { memset(m,0,sizeof(m)); scanf("%d",&n)

贪心/Hdu 1050 Moving Tables

#include<cstdio> #include<cstring> using namespace std; int a[220]; int cmax(int a,int b){return a>b?a:b;} int main() { int T; scanf("%d",&T); for (int t=1;t<=T;t++) { int n; scanf("%d",&n); int x,y,xx,yy; int