time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16377 Accepted Submission(s): 10155
Problem Description
There are some students in a class, Can you help teacher find the highest student .
Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
Output
For each case output the highest height, the height to two decimal plases;
Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
Sample Output
180.00 182.00
问题描述
在一个班里有一些学生,可以帮助教师发现学生最高。
输入
在某些情况下。第一行包含一个整数T,表示例;每一种情况下有一个整数N(1≤N 100,N≤)遵循学生的身高。
输出
对于每一种情况下输出的最高高度,高度保留2位小数;
#include<stdio.h>
main()
{
float a,b,x[1000];
int i,j,n,k;
scanf("%d",&n);
while(n--)
{
scanf("%d",&k);
for(i=0;i<k;i++)
scanf("%f",&x[i]);
b=x[0];
for(i=0;i<k;i++)
if(b<x[i])
b=x[i];
printf("%.2f\n",b);
}
return 0;
}